LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2014, 09:38 AM   #1
josephf63
LQ Newbie
 
Registered: Nov 2013
Location: Centereach, NY
Distribution: RHEL 5
Posts: 3

Rep: Reputation: Disabled
freshclam reporting incorrect version


I am running RHEL 5.3, preparing to upgrade to 5.10, however wanted to upgrade ClamAV first.Ran yum install clamav clamd clamav-milter and successfully installed. However every time freshclam runs I get the following message:

WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.98 Recommended version: 0.98.1
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
daily.cvd is up to date (version: 18354, sigs: 652081, f-level: 63, builder: neo)
bytecode.cld is up to date (version: 235, sigs: 44, f-level: 63, builder: dgoddard)
If i run yum install clamav clamd clamav-milter again I get:
Package clamav-0.98-2.el5.x86_64 already installed and latest version
Package clamav-0.98-2.el5.i386 already installed and latest version
Package clamd-0.98-2.el5.x86_64 already installed and latest version
Package clamav-milter-0.98-2.el5.x86_64 already installed and latest version
Nothing to do

ClamAv version returns:
clamscan -V
ClamAV 0.98/18354/Wed Jan 15 07:56:57 2014

Any Ideas on how to get freshclam to report correct version?
 
Old 01-15-2014, 06:29 PM   #2
csmwww
LQ Newbie
 
Registered: Jan 2014
Location: Pittsburgh, PA USA
Posts: 1

Rep: Reputation: Disabled
Same here, still an issue. I've been ignoring, but figured at this point another report might encourage the matter. I did a "yum remove clamav" and "yum install clamd" and the issue persists. I hate ignoring these sorts of messages, since they encourage me to ignore ones that might matter.

[root@smtpproxy ~]# uname -a
Linux smtpproxy 2.6.18-371.3.1.el5 #1 SMP Thu Dec 5 12:47:01 EST 2013 i686 athlon i386 GNU/Linux
[root@smtpproxy ~]# yum install clamd
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* addons: ftp.usf.edu
* base: mirror.beyondhosting.net
* extras: centos.mirror.nac.net
* rpmforge: repoforge.spinellicreations.com
* rpmforge-extras: repoforge.spinellicreations.com
* updates: mirrors.usinternet.com
216 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package clamd.i386 0:0.98-2.el5.rf set to be updated
--> Processing Dependency: clamav = 0.98-2.el5.rf for package: clamd
--> Processing Dependency: libclamav.so.6 for package: clamd
--> Processing Dependency: libclamav.so.6(CLAMAV_PRIVATE) for package: clamd
--> Processing Dependency: libclamav.so.6(CLAMAV_PUBLIC) for package: clamd
--> Running transaction check
---> Package clamav.i386 0:0.98-2.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
clamd i386 0.98-2.el5.rf rpmforge 242 k
Installing for dependencies:
clamav i386 0.98-2.el5.rf rpmforge 3.0 M

Transaction Summary
================================================================================
Install 2 Package(s)
Upgrade 0 Package(s)

Total download size: 3.2 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): clamd-0.98-2.el5.rf.i386.rpm | 242 kB 00:00
(2/2): clamav-0.98-2.el5.rf.i386.rpm | 3.0 MB 00:01
--------------------------------------------------------------------------------
Total 1.8 MB/s | 3.2 MB 00:01
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : clamav 1/2
Installing : clamd 2/2

Installed:
clamd.i386 0:0.98-2.el5.rf

Dependency Installed:
clamav.i386 0:0.98-2.el5.rf

Complete!
[root@smtpproxy ~]# freshclam
ClamAV update process started at Wed Jan 15 19:10:22 2014
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.98 Recommended version: 0.98.1
DON'T PANIC! Read [-- a URL a newbie can't post on this forum --]
Downloading main.cvd [100%]
main.cvd updated (version: 55, sigs: 2424225, f-level: 60, builder: neo)
...[bla,bla,bla...]
 
Old 01-16-2014, 12:48 AM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
the version of clam in the thirdparty repos is normally a year or so behind , an might not even be supported

uninstall using yum
and manually install the current
it will be a while before it is updated again

http://www.clamav.net/lang/en/

and the version in RHEL 5.3 will be MANY years out of date

Last edited by John VV; 01-16-2014 at 12:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] repquota reporting incorrect values? Griever92 Linux - Server 1 11-14-2012 03:48 AM
GNU/Linux reporting incorrect free space on external drive gnurza Linux - Newbie 4 10-31-2007 07:24 PM
kcore reporting incorrect size magiconexxx Linux - Software 3 04-04-2007 10:47 PM
incorrect swap reporting on SLES9.3 da_tibmeister SUSE / openSUSE 2 09-07-2006 01:10 PM
Qt Parted reporting incorrect parition types nrunge Linux - Software 2 01-28-2004 11:21 AM


All times are GMT -5. The time now is 04:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration