LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-05-2010, 12:12 PM   #16
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728

Quote:
Originally Posted by jstnice View Post
Strange. I really don't like NetworkManager, but on OpenSuse as desktop it works very well.
jstnice;
I posted another reply where you had copied out of someone's post without giving attribution. Now I see that it is a pattern with you....

do not do this again at LQ
 
Old 05-05-2010, 12:45 PM   #17
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 3,903

Rep: Reputation: 775Reputation: 775Reputation: 775Reputation: 775Reputation: 775Reputation: 775Reputation: 775
Quote:
I really don't like NetworkManager, but on OpenSuse as desktop it works very well.
...and I'm not even sure how helpful the original comment was: the network manager that was shipped with early versions of KDE 4 was notoriously bad, but improved dramatically sometime around KDE 4.3 or so. So, I don't know exactly enough whether the OP is likely to have the 'good' or the 'bad' version of Network Manager (unless it has been upgraded since install, or is using a different GUI (Gnome, KDE 3, XFCE...), in which case it is almost certainly a 'good' version).

So, yes, it works really well on late versions of KDE 4 and really badly on early versions.
 
Old 05-05-2010, 05:10 PM   #18
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 250

Rep: Reputation: 40
worked for me, thanks

Thanks it worked for me!
 
Old 05-06-2010, 12:44 PM   #19
nyflyguy
LQ Newbie
 
Registered: Apr 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by paulsm4 View Post
Hi -


You'll notice the ABSENCE of any interface besides "127.0.0.1" (your loopback address).

You're not going to get ANYTHING working until your system finds at least one hardware interface (Ethernet or wireless, preferably Ethernet).

Sooooooo .....

You need to figure out why it's not seeing your Ethernet.

Make sure it's plugged in.

Try swapping in another NIC card, if necessary.

If you happen to have an on-board NIC, check your BIOS to make sure it's enabled.

But your #1 priority at this point is to do ANYTHING you can to make your Ethernet hardware device wake up and say "Hi!" to Linux. Right now (for whatever reason) it appears completely "dead".

Always reboot after making any hardware changes.

Upon reboot, Linux should auto-detect your NIC hardware, and you should be able to see it (and bring it UP and DOWN) in Yast, Network devices.

You can also look at "dmesg" (startup messages) and/or /var/log/messages (all system messages, including failed kernel driver loads).

'Hope that helps .. PSM




I dont know if I mentioned this already but I am trying to get openSUSE 11.2 to work on a brand new Toshiba laptop, so I dont know how easy it would be for me to swap the NIC card or even if its necessary. Also, like I said, I had SUSE 11.1 working flawlessly on the same laptop, and all the drivers and firmware were were automatically found and installed by openSUSE so there should be no reason why I cant get all of my hardware up and running with this version of SUSE since I already know they work on linux.


I know I am not the only person out there with this problem. If anyone has a solution for me please clue me in because this is starting to get very frustrating...
 
Old 05-06-2010, 01:29 PM   #20
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

Again: for whatever reason, *THE* problem is that SuSE isn't autodetecting your network hardware. I think a lot of the suggestions have been good. But I definitely sympathize with your frustration. And, unfortunately, there's been a lot of "noise" and "cross-talk" on this thread (no need to mention names )

NEW SUGGESTIONS:
Quote:
1. Log on to a terminal window as "root".

2. Run "lspci -v"
Cut/paste the output for your Ethernet controllers
<= I'm assuming you probably have an on-board Ethernet, and it's probably a PCI device. Please correct me if I'm wrong.

3. run "ifconfig eth0 up"
run "ifconfig eth0"
Cut/paste the output

4. Check "dmesg|less" for anything related to your Ethernet device.
Cut/paste the output

5. Check "less /var/log/messages" for anything related to your Ethernet device.
Cut/paste the output
'Hope that helps .. PSM
 
Old 05-06-2010, 07:25 PM   #21
nyflyguy
LQ Newbie
 
Registered: Apr 2010
Posts: 10

Original Poster
Rep: Reputation: 0
lspci -v :

Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast Ethernet Controller (rev 12)
Subsystem: Toshiba America Info Systems Device ff50
Flags: fast devsel, IRQ 16
Memory at b6000000 (64-bit, non-prefetchable) [size=16K]
I/O ports at 2000 [size=256]
Capabilities: [48] Power Management version 3
Capabilities: [5c] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [c0] Express Legacy Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [130] Device Serial Number 9f-de-8f-ff-ff-8b-23-00

08:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
Subsystem: Intel Corporation Device 1201
Flags: fast devsel, IRQ 17
Memory at b6100000 (64-bit, non-prefetchable) [size=8K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [e0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 00-22-fa-ff-ff-9a-cf-f0




ifconfig eth0 up:

eth0: unknown interface: No such device




ifconfig eth0:

eth0: error fetching interface information: Device not found




dmesg|less:

I think this is the ethernet. I am not too sure.

[ 0.828797] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[ 0.829004] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
[ 0.829144] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP01._PRT]
[ 0.829258] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP05._PRT]
[ 0.846580] ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 10 12 14 15) *11
[ 0.846731] ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 *5 6 7 11 12 14 15)
[ 0.846880] ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 *6 7 10 12 14 15)
[ 0.847032] ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 5 6 7 11 12 14 15) *10
[ 0.847180] ACPI: PCI Interrupt Link [LNKE] (IRQs 1 3 4 5 6 7 10 12 14 15) *0, disabled.
[ 0.847329] ACPI: PCI Interrupt Link [LNKF] (IRQs 1 3 4 5 6 7 *11 12 14 15)
[ 0.847476] ACPI: PCI Interrupt Link [LNKG] (IRQs 1 3 4 5 6 7 *10 12 14 15)
[ 0.847625] ACPI: PCI Interrupt Link [LNKH] (IRQs 1 3 4 5 6 *7 11 12 14 15)
[ 0.847878] SCSI subsystem initialized
[ 0.848037] libata version 3.00 loaded.
[ 0.848037] usbcore: registered new interface driver usbfs
[ 0.848052] usbcore: registered new interface driver hub
[ 0.848057] usbcore: registered new device driver usb
[ 0.848057] PCI: Using ACPI for IRQ routing
[ 0.848057] pci 0000:00:1c.0: BAR 13: can't allocate resource
[ 0.848059] pci 0000:00:1c.0: BAR 14: can't allocate resource
[ 0.848061] pci 0000:00:1c.0: BAR 15: can't allocate resource
[ 0.848063] pci 0000:00:1c.4: BAR 13: can't allocate resource
[ 0.848065] pci 0000:00:1c.4: BAR 14: can't allocate resource
[ 0.848067] pci 0000:00:1c.4: BAR 15: can't allocate resource
[ 0.848069] pci 0000:00:1c.5: BAR 13: can't allocate resource
[ 0.848071] pci 0000:00:1c.5: BAR 14: can't allocate resource
[ 0.848073] pci 0000:00:1c.5: BAR 15: can't allocate resource
[ 0.851037] hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0, 0
[ 0.851044] hpet0: 4 comparators, 64-bit 14.318180 MHz counter
[ 0.855010] Switched to high resolution mode on CPU 0
[ 0.855583] Switched to high resolution mode on CPU 1
[ 0.855951] AppArmor: AppArmor Filesystem Enabled
[ 0.857261] pnp: PnP ACPI init
[ 0.857273] ACPI: bus type pnp registered
[ 0.858821] pnp 00:04: io resource (0x2e-0x2f) overlaps 0000:07:00.0 BAR 2 (0x0-0xff), disabling
[ 0.858825] pnp 00:04: io resource (0x4e-0x4f) overlaps 0000:07:00.0 BAR 2 (0x0-0xff), disabling
[ 0.858828] pnp 00:04: io resource (0x61-0x61) overlaps 0000:07:00.0 BAR 2 (0x0-0xff), disabling
[ 0.858832] pnp 00:04: io resource (0x63-0x63) overlaps 0000:07:00.0 BAR 2 (0x0-0xff), disabling
[ 0.858835] pnp 00:04: io resource (0x65-0x65) overlaps 0000:07:00.0 BAR 2 (0x0-0xff), disabling
[ 0.858838] pnp 00:04: io resource (0x67-0x67) overlaps 0000:07:00.0 BAR 2 (0x0-0xff), disabling





less /var/log/messages:

Apr 25 19:50:49 linux-17gu network: NetworkManager is active even though not configured.
Apr 25 19:50:49 linux-17gu network: Check your config or restart network.
Apr 25 19:50:49 linux-17gu network: Shutting down the NetworkManager
Apr 25 19:50:50 linux-17gu ifup: lo
Apr 25 19:50:50 linux-17gu ifup: lo
Apr 25 19:50:50 linux-17gu ifup: IP address: 127.0.0.1/8
Apr 25 19:50:50 linux-17gu ifup:
Apr 25 19:50:50 linux-17gu ifup:
Apr 25 19:50:50 linux-17gu ifup: IP address: 127.0.0.2/8
Apr 25 19:50:50 linux-17gu ifup:
Apr 25 19:50:50 linux-17gu SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Apr 25 19:50:50 linux-17gu SuSEfirewall2: Warning: no interface active
Apr 25 19:50:50 linux-17gu SuSEfirewall2: batch committing...
Apr 25 19:50:50 linux-17gu SuSEfirewall2: Firewall rules successfully set
Apr 25 19:51:40 linux-17gu su: (to root) Jeremy on /dev/pts/1
Apr 25 19:51:40 linux-17gu su: (to root) Jeremy on /dev/pts/1
Apr 25 19:52:55 linux-17gu su: (to root) Jeremy on /dev/pts/0
Apr 25 19:56:12 linux-17gu su: (to root) Jeremy on /dev/pts/1
Apr 25 19:56:17 linux-17gu sudo: root : TTY=pts/1 ; PWD=/home/Jeremy ; USER=root ; COMMAND=/bin/echo nameserver 8.8.8.8
Apr 25 20:04:47 linux-17gu su: (to root) Jeremy on /dev/pts/1
 
Old 05-07-2010, 12:26 AM   #22
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

This seems to be your exact scenario:
http://www.linuxquestions.org/questi...2/#post3389949

Try sending Moonrover a private message and see if he responds.

You can get a driver specifically for the Toshiba 88E8040T Ethernet adapter here:

http://switch-www.marvell.com/support.html

These instructions should be OK for SuSE:

http://ubuntuforums.org/showthread.p...54#post5285654

http://forums.computers.toshiba-euro...ssageID=133840

'Hope that helps .. PSM

Last edited by paulsm4; 05-07-2010 at 12:35 AM.
 
Old 05-09-2010, 12:11 AM   #23
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Thanx, Moonrover:
Quote:
http://www.linuxquestions.org/questi...2/#post3960980

Wow! It's been awhile since I posted my success story. Surprised to hear they are having problems with a current SUSE distro.

1) Check the PC or Laptop Bios; see if you see any problems with your hardware configuration.

2) Swap the Ethernet card out if it is in a Desktop, or on a laptop try the same exercise on a different laptop to see if it is the hardware.

3) If SuSE installs, boot it up and try to configure the Ethernet card yourself using Yast or one of the other system tools. Do a direct connect to your DSL or cable modem, which must also be configured to operate with the Internet connection (PPoE, etc., etc.).

4) If you're not sure if your modem or DSL is working, and have a Windoze PC, boot it up and see if it can connect to the Internet. If it does, you're down to just the SuSE configuration.

5) If you're using a LinkSys Wireless Router to direct-connect to a DSL, sign on to it in Admin mode at its IP address and step thru the menus to look at all its settings. If running in WPA mode, check your shared key in SuSE to make sure it matches.

Let's see how far you can get started with these tips.
nyflyguy - Please keep us posted what happens.

Last edited by paulsm4; 05-09-2010 at 12:14 AM.
 
Old 05-09-2010, 09:35 AM   #24
moonrover
Member
 
Registered: Jan 2005
Location: Orange County, CA
Distribution: SUSE 11.0
Posts: 46

Rep: Reputation: 16
No problem, PSM. I had a lot of suggestions I didn't post because they appear to have already tried them. It all came down to having to manually flip the NIC card settings. You would think SuSE had figured out all the correct settings for Toshiba NIC cards, but my out-of-the-box experience for their distro twice had the same mis-configuration blues for me.
Both times, the BIOS was fine, the NIC card was fine; it just came down to the settings. I was also fortunate to have multiple laptops for testing, and a working Linksys wireless router for Windoze to do research & download stuff.

Last edited by moonrover; 05-09-2010 at 09:41 AM.
 
1 members found this post helpful.
  


Reply

Tags
connection, ethernet, internet, opensuse, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to the internet on Opensuse 11.2 Raziel616 Suse/Novell 3 01-16-2010 05:41 AM
Partitioning a fresh install of openSUSE 11.1 manuleka Linux - Newbie 6 02-26-2009 05:38 AM
Fresh Install - Will Not Boot, OpenSUSE 10.2 on IBM System x3650 MoschopsUK Linux - Newbie 6 04-03-2008 02:42 AM
Can't connect to internet with Opensuse 10.2 bastjan Linux - Laptop and Netbook 2 05-24-2007 12:36 PM
cant connect to internet on fresh install of suse9.1 springdog Linux - Newbie 13 12-27-2004 03:47 PM


All times are GMT -5. The time now is 11:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration