LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Fresh install of openSUSE 11.2 cannot connect to internet for the life of me...why? (http://www.linuxquestions.org/questions/linux-newbie-8/fresh-install-of-opensuse-11-2-cannot-connect-to-internet-for-the-life-of-me-why-804162/)

nyflyguy 04-25-2010 09:47 PM

Fresh install of openSUSE 11.2 cannot connect to internet for the life of me...why?
 
I installed openSUSE 11.2 a few days ago on my Toshiba satellite M305-S4910 and I cannot find a way to connect to the internet. I have googled and searched on the opensuse fourms but found no answer, so i figured maybe someone has had this problem here before and can possibly help me. To give you a little more information about my problem, I had openSUSE 11.1 installed before and everything was working fine until I did a fresh install of 11.2. Now I dont even have an option to connect wirelessly or via ethernet. When i try to connect my ethernet wire nothing happens. I can see my ethernet card and wireless card under devices in yast but network manager does not allow me to select the wireless tab at all, so i disabled network manager somehow so i can edit my settings through yast and now i dont know how to re enable it. I am very new to linux so any help would be greatly appreciated, and if there is already a thread related to my problem and i overlooked it I apologize.

paulsm4 04-25-2010 09:55 PM

Suggestion -

1. Go into the Yast2 GUI, add/remove programs, and REMOVE network manager.

2. Go back into Yast2, and re-add network manager.

3. Reboot.

4. Go into Yast, Network devices and see if you can configure your Ethernet card.

5. Focus on Ethernet first (since it sounds like you have both).
If Wifi doesn't come back automatically after step 3, then wait until you get Ethernet working before you worry about it.

6. Post back any questions/problems you encounter any step along the way.

'Hope that helps .. PSM

nyflyguy 04-25-2010 10:05 PM

Thank you for your very quick response. I will do as you suggested and post my results as soon as i can.

nyflyguy 04-25-2010 10:59 PM

I'm sorry but I could not find add/remove programs. Maybe you meant software management, however, I clicked that and the list was empty. Its as if I have nothing installed. I also tried to search for network manager but received no matches.

paulsm4 04-25-2010 11:27 PM

OK, please try this instead:
Quote:

1. Test basic connectivity:

/sbin/ifconfig
Code:

eth0      Link encap:Ethernet  HWaddr 00:50:8D:7C:18:05
          inet addr:192.168.0.7  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::250:8dff:fe7c:1805/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4830 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2445 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5699632 (5.4 Mb)  TX bytes:185278 (180.9 Kb)
          Interrupt:20 Base address:0xe000
  <= My Ethernet0 is enabled and configured
    My IP address is 192.168.0.7

/sbin/route -n
Code:

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
192.168.0.0    0.0.0.0        255.255.255.0  U    1      0        0 eth0
127.0.0.0      0.0.0.0        255.0.0.0      U    0      0        0 lo
0.0.0.0        192.168.0.1    0.0.0.0        UG    0      0        0 eth0
  <= My gateway is 192.168.0.1

ping 192.168.0.7
Code:

PING 192.168.0.7 (192.168.0.7) 56(84) bytes of data.
64 bytes from 192.168.0.7: icmp_seq=1 ttl=64 time=0.070 ms
64 bytes from 192.168.0.7: icmp_seq=2 ttl=64 time=0.056 ms
...
  <= Good: I can "ping" myself...

ping 192.168.0.1
Code:

PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=255 time=0.864 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=255 time=0.561 ms
...
  <= Good: I can also "ping" my gateway


Please run the above commands, and cut/paste the results.

From what you've said, they'll probably fail. But they're basic "first steps" for ANY network troubleshooting - you should definitely run them before doing anything else.

Quote:

2. Go into YAST, Network Devices, Network settings
<= I get a warning: "The network is currently controlled by Network manager..."

I'm guess you probably WON'T get this warning.

Please post back the results.
Quote:

3. Re-enable Network Manager:
Yast, Network Devices, Network Settings, [Global Options],
Network Setup Method,
User Controlled with NetworkManager= Y

<<Reboot>>

Check networking after reboot

fbsduser 04-25-2010 11:42 PM

Hook the network cable and try at the console
Code:

ifconfig eth0 down
ifconfig eth0 up
dhclient eth0

This should manually reset your wired interface, bring it up and assign an IP (if you use static IP addresses skip the last command) which should get you connected at least through ethernet, from there you can work out the wifi issue.

nyflyguy 04-26-2010 02:56 AM

1. Test Basic Connectivity

~> /sbin/ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:106 errors:0 dropped:0 overruns:0 frame:0
TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7196 (7.0 Kb) TX bytes:7196 (7.0 Kb)


~> /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo


~> /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
Jeremy@linux-17gu:~> ping 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.051 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.050 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.046 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.049 ms
64 bytes from 127.0.0.1: icmp_seq=5 ttl=64 time=0.052 ms
64 bytes from 127.0.0.1: icmp_seq=6 ttl=64 time=0.066 ms
64 bytes from 127.0.0.1: icmp_seq=7 ttl=64 time=0.050 ms
64 bytes from 127.0.0.1: icmp_seq=8 ttl=64 time=0.051 ms
64 bytes from 127.0.0.1: icmp_seq=9 ttl=64 time=0.051 ms
64 bytes from 127.0.0.1: icmp_seq=10 ttl=64 time=0.049 ms



2. Network Settings
88E8040T PCI-E Fast Ethernet Controller (Not connected)
BusID : 0000:07:00.0
Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.



3. Re-enable Network Manager
I did this and I received an error. It said something like “No network is on.” But I went back in and I saw that “user controlled with network manager” was still selected and I got that warning so I guess it worked.

Rebooted: Network Manager is now enabled again

nyflyguy 04-26-2010 02:59 AM

Quote:

Originally Posted by fbsduser (Post 3947655)
Hook the network cable and try at the console
Code:

ifconfig eth0 down
ifconfig eth0 up
dhclient eth0

This should manually reset your wired interface, bring it up and assign an IP (if you use static IP addresses skip the last command) which should get you connected at least through ethernet, from there you can work out the wifi issue.


I tried this but I kept getting something like "No such device"

nyflyguy 04-26-2010 08:43 PM

Sorry for being impatient, but any more suggestions?

UnderV 04-27-2010 04:59 AM

Hello!
As I understand Network Manager worked for You before.
So we should make it work again :)

To check what network management You are using - NetworkManager or Traditional ifup/ifdown, do the following:
1. Open Yast
2. Select "Network Settings" module
3. Check "Global Options" (There are 2 options in "Network Setup Method" section - 1. Network manager, 2. Traditional method). If You select traditional method then Yast could configure network devices, but it have problems with wireless connections. I suggest to use only Network manager on laptops.

If You already have "Network manager" setting enabled, then select Traditional, apply changes, restart PC and select "Network manager" back. It should work (small icon in tray).

Sometimes you should delete all network settings in NetworkManager and create them again.

nyflyguy 04-27-2010 10:15 PM

Quote:

Originally Posted by UnderV (Post 3949036)
Hello!
As I understand Network Manager worked for You before.
So we should make it work again :)

To check what network management You are using - NetworkManager or Traditional ifup/ifdown, do the following:
1. Open Yast
2. Select "Network Settings" module
3. Check "Global Options" (There are 2 options in "Network Setup Method" section - 1. Network manager, 2. Traditional method). If You select traditional method then Yast could configure network devices, but it have problems with wireless connections. I suggest to use only Network manager on laptops.

If You already have "Network manager" setting enabled, then select Traditional, apply changes, restart PC and select "Network manager" back. It should work (small icon in tray).

Sometimes you should delete all network settings in NetworkManager and create them again.


Network Manager never worked for me. I just had disabled it by accident trying to connect to my network either wireless or via ethernet but i couldn't get it to work. I was finally able to re enable network manager but i still can't connect to the internet. I have my laptop set as dual boot with opensuse 11.2 and windows 7 and windows is able to connect to my network with no problems at all.

UnderV 04-28-2010 05:41 AM

Quote:

Originally Posted by nyflyguy (Post 3950007)
Network Manager never worked for me. I just had disabled it by accident trying to connect to my network either wireless or via ethernet but i couldn't get it to work.

Strange. I really don't like NetworkManager, but on OpenSuse as desktop it works very well.

Does NetworkManager find Wireless networks around You?
Do You tried delete already created configuration in NetworkManager and create it again (sometimes it could help)?

nyflyguy 04-29-2010 01:21 AM

Quote:

Originally Posted by UnderV (Post 3950340)
Strange. I really don't like NetworkManager, but on OpenSuse as desktop it works very well.

Does NetworkManager find Wireless networks around You?
Do You tried delete already created configuration in NetworkManager and create it again (sometimes it could help)?



No it doesn't find any wireless around me even though wireless is enabled. And I don't think I deleted anything like that.

paulsm4 05-04-2010 11:52 PM

Hi -

This suggestion still stands:
Quote:

Suggestion -

1. Go into the Yast2 GUI, add/remove programs, and REMOVE network manager.

2. Go back into Yast2, and re-add network manager.

3. Reboot.

4. Go into Yast, Network devices and see if you can configure your Ethernet card.

5. Focus on Ethernet first (since it sounds like you have both).
If Wifi doesn't come back automatically after step 3, then wait until you get Ethernet working before you worry about it.

6. Post back any questions/problems you encounter any step along the way.
In other words:
a) use Network manager (it's easier, it should work)
b) focus on Ethernet (it's easier than wireless, and you believe it should work)

Here's your current problem:
Quote:

1. Test Basic Connectivity

~> /sbin/ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:106 errors:0 dropped:0 overruns:0 frame:0
TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7196 (7.0 Kb) TX bytes:7196 (7.0 Kb)
You'll notice the ABSENCE of any interface besides "127.0.0.1" (your loopback address).

You're not going to get ANYTHING working until your system finds at least one hardware interface (Ethernet or wireless, preferably Ethernet).

Sooooooo .....

You need to figure out why it's not seeing your Ethernet.

Make sure it's plugged in.

Try swapping in another NIC card, if necessary.

If you happen to have an on-board NIC, check your BIOS to make sure it's enabled.

But your #1 priority at this point is to do ANYTHING you can to make your Ethernet hardware device wake up and say "Hi!" to Linux. Right now (for whatever reason) it appears completely "dead".

Always reboot after making any hardware changes.

Upon reboot, Linux should auto-detect your NIC hardware, and you should be able to see it (and bring it UP and DOWN) in Yast, Network devices.

You can also look at "dmesg" (startup messages) and/or /var/log/messages (all system messages, including failed kernel driver loads).

'Hope that helps .. PSM

jstnice 05-05-2010 02:23 AM

Strange. I really don't like NetworkManager, but on OpenSuse as desktop it works very well.


All times are GMT -5. The time now is 01:58 PM.