LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-22-2003, 07:24 AM   #1
matt combe
LQ Newbie
 
Registered: Apr 2003
Distribution: RedHat 8.0
Posts: 5

Rep: Reputation: 0
Question freelords 0.2.2



Im having trouble compiling this game - freelords 0.2.2 i have downloaded and compiled all of the necessary dependencies: SDL 1.2.5, paragui 1.0.3 & libsigc++ 1.2.4 they all installed without problems but the problem is when i try to compile freelords i get this error msg:
[root@localhost freelords-0.2.2]# ./configure
loading cache ./config.cache
checking for c++... (cached) c++
checking whether the C++ compiler (c++ ) works... yes
checking whether the C++ compiler (c++ ) is a cross-compiler... no
checking whether we are using GNU C++... (cached) yes
checking whether c++ accepts -g... (cached) yes
checking target system type... ./config.sub: ./config.sub: No such file or directory

checking for sdl-config... (cached) /usr/local/bin/sdl-config
checking for SDL - version >= 1.2.0... yes
checking for paragui-config... (cached) /usr/local/bin/paragui-config
checking for PARAGUI - version >= 1.0.0... no
*** Could not run PARAGUI test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding PARAGUI or finding the wrong
*** version of PARAGUI. If it is not finding PARAGUI, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error: *** ParaGUI version 1.0.0 not found!

i have edited the LD_LIBRARY_PATH and ld.so.conf but there is no difference. the only progress i have made is to use the command "./configure --disable-paraguitest" it will then configure but when i go to "make" the program i get this error:
[root@localhost freelords-0.2.2]# make
cd src && make
make[1]: Entering directory `/root/Desktop/freelords-0.2.2/src'
cd common; make;
make[2]: Entering directory `/root/Desktop/freelords-0.2.2/src/common'
g++ -g -Wall -fPIC `paragui-config --cflags` `pkg-config --cflags sigc++-1.2` -I. -I../graphic -I../server -Werror -c armyset_army.cpp -o armyset_army.o
cc1plus: changing search order for system directory "/usr/local/include"
cc1plus: as it has already been specified as a non-system directory
make[2]: *** [armyset_army.o] Error 1
make[2]: Leaving directory `/root/Desktop/freelords-0.2.2/src/common'
make[1]: *** [MYLIBS] Error 2
make[1]: Leaving directory `/root/Desktop/freelords-0.2.2/src'
make: *** [all] Error 2

im really stuck ive looked everywhere but there is very little documentation anywhere on this, it is probably something really simple i have overlooked.
any help would be much appreciated
thanks in advance. matt
 
Old 04-22-2003, 07:28 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

http://www.linuxquestions.org/rules.php
 
Old 04-22-2003, 07:30 AM   #3
matt combe
LQ Newbie
 
Registered: Apr 2003
Distribution: RedHat 8.0
Posts: 5

Original Poster
Rep: Reputation: 0
sorry

sorry mate won't happen again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration