LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-22-2015, 06:41 AM   #1
iFunction
Member
 
Registered: Nov 2015
Posts: 185

Rep: Reputation: Disabled
format 64Gb usb drive to Fat32 only gives 32Gb?


Hi there,

I have to format approx 200 USB drives to Fat32. On my mac, no problem but in Linux from the command line it only gives me 32Gb instead of the full capacity.

Here is what I am doing:

Code:
sudo su

umount /dev/sda

mkfs.vfat -n 'round01' -I /dev/sda
this formats nice and quickly, but only gives me a 32Gb partition and as I am a little new to this, I am struggling somewhat to understand what the "-n" means and the "-I" means.

How can I get this to be a 64Gb partition?

Kind regards

iFunc
 
Old 12-22-2015, 06:56 AM   #2
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,078

Rep: Reputation: Disabled
you got Gparted? use that --- if something wrong with the usb normally it can be fix within that too --- just incase partitons maybe screewed up-- that should let you know.

for -> mkfs.vfat <-

Last edited by BW-userx; 12-22-2015 at 06:59 AM.
 
Old 12-22-2015, 07:52 AM   #3
TxLonghorn
Member
 
Registered: Feb 2004
Location: Austin Texas
Distribution: Mandrake 9.2
Posts: 569

Rep: Reputation: 183Reputation: 183
Quote:
Originally Posted by iFunction View Post
I have to format approx 200 USB drives to Fat32. On my mac, no problem but in Linux from the command line it only gives me 32Gb instead of the full capacity.
Take one USB drive that you formatted correctly on your Mac.
Plug that in to your linux box.
Plug in the unformatted USB drive.
Discover the device designations >
Code:
sudo fdisk -l
Clone /dev/sdc to /dev/sdd (or whatever the correct device designations are...)
Code:
sudo dd if=/dev/sdc of=/dev/sdd

Last edited by TxLonghorn; 12-22-2015 at 08:04 AM. Reason: to edit
 
1 members found this post helpful.
Old 12-22-2015, 07:57 AM   #4
TxLonghorn
Member
 
Registered: Feb 2004
Location: Austin Texas
Distribution: Mandrake 9.2
Posts: 569

Rep: Reputation: 183Reputation: 183
Quote:
Originally Posted by iFunction View Post
Here is what I am doing:
Code:
mkfs.vfat -n 'round01' -I /dev/sda
I am struggling somewhat to understand what the "-n" means and the "-I" means.
"-n" means set the volume name (label) of the file system.
"-n 'round01' " - set the label using the chosen text inside the quotes.
"-I" - means you are doing a "superfloppy" format. That is formatting the entire disk, not partitions. The -I tells the format command to ignore the fact that you have no partitions.
 
1 members found this post helpful.
Old 12-22-2015, 10:40 AM   #5
iFunction
Member
 
Registered: Nov 2015
Posts: 185

Original Poster
Rep: Reputation: Disabled
Ok, thanks for the replies.

As for Gparted, can't get it to work at all, it doesn't appear to support FAT 32 that I can see.

Can I assume that only mac will actually partition a large USB drive to FAT 32 then? I thought you would be able to do it in the command line easily.

the reason I ask is that I don't want to wear out the usb ports on my mac as that is mine not a works machine.

kind regards
iFunc
 
Old 12-22-2015, 11:09 AM   #6
TxLonghorn
Member
 
Registered: Feb 2004
Location: Austin Texas
Distribution: Mandrake 9.2
Posts: 569

Rep: Reputation: 183Reputation: 183
It can probably be done using the -S option in your command:
mkfs.vfat -n 'round01' -I /dev/sda
to increase the logical sector size.
I will try to figure out the exact parameters.
 
Old 12-22-2015, 12:07 PM   #7
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
You haven't created a partition yet, you're just trying to create a filesystem on the raw device. Use fdisk or parted or gparted to create a partition on the device first, then create the filesystem on the partition (sda1, not sda).

As for gparted and fat32, yes absolutely gparted supports fat32, it would be ridiculous for it not to.

As for wearing out your USB port, use a $5 extension cable and plug your drives into that.

Last edited by suicidaleggroll; 12-22-2015 at 12:09 PM.
 
1 members found this post helpful.
Old 12-22-2015, 12:49 PM   #8
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,078

Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
As for wearing out your USB port, use a $5 extension cable and plug your drives into that.
I never thought of that, wearing out a USB port -- I mostly use it for my Mouse on my LapTop, but still good advice.
 
Old 01-02-2016, 04:55 AM   #9
iFunction
Member
 
Registered: Nov 2015
Posts: 185

Original Poster
Rep: Reputation: Disabled
Ok, tried to use fdisk, now I only have 32K of space, that's much worse, can someone please point me at a tutorial that will make it so I can format a 64Gb Drive from exFat format to FAT32 please.
 
Old 01-02-2016, 07:00 AM   #10
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,601

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
Fat32 does not support any filesystem larger than 32GB.

reference: http://support.wdc.com/KnowledgeBase...r.aspx?ID=1287
reference: https://technet.microsoft.com/en-us/.../cc938432.aspx

BTW, the filesystem also limits file sizes to 4GB.

If you want to use more with linux, use a linux native filesystem.

You will also get better error recovery.
 
Old 01-02-2016, 07:15 AM   #11
TxLonghorn
Member
 
Registered: Feb 2004
Location: Austin Texas
Distribution: Mandrake 9.2
Posts: 569

Rep: Reputation: 183Reputation: 183
Code:
sudo mkdosfs /dev/sdX -s 128 -F 32 -I
 
Old 01-02-2016, 07:57 AM   #12
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,078

Rep: Reputation: Disabled
Quote:
Originally Posted by TxLonghorn View Post
Code:
sudo mkdosfs /dev/sdX -s 128 -F 32 -I
isn't that a command line arg that just, when you hit enter it goes, Ka chunk, and its formated, no waiting?
 
Old 01-02-2016, 08:11 AM   #13
TxLonghorn
Member
 
Registered: Feb 2004
Location: Austin Texas
Distribution: Mandrake 9.2
Posts: 569

Rep: Reputation: 183Reputation: 183
Quote:
Originally Posted by BW-userx View Post
isn't that a command line arg
It is a complete command, not just an argument.

Quote:
Originally Posted by BW-userx View Post
when you hit enter it goes, Ka chunk, and its formated, no waiting?
Formatting a 64GB drive will require some waiting, about 10 minutes depending on the machine's capabilities.
 
Old 01-02-2016, 08:15 AM   #14
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,078

Rep: Reputation: Disabled
Quote:
Originally Posted by iFunction View Post
Hi there,

I have to format approx 200 USB drives to Fat32. On my mac, no problem but in Linux from the command line it only gives me 32Gb instead of the full capacity.

Here is what I am doing:

Code:
sudo su

umount /dev/sda

mkfs.vfat -n 'round01' -I /dev/sda
this formats nice and quickly, but only gives me a 32Gb partition and as I am a little new to this, I am struggling somewhat to understand what the "-n" means and the "-I" means.

How can I get this to be a 64Gb partition?

Kind regards

iFunc
Man Pages

parted

fdisk

mkfs.vfat(8)
 
Old 01-02-2016, 08:22 AM   #15
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,078

Rep: Reputation: Disabled
Quote:
Originally Posted by TxLonghorn View Post
It is a complete command, not just an argument.

Formatting a 64GB drive will require some waiting, about 10 minutes depending on the machine's capabilities.
Oh I remember way back when they had this meddium that was called a floppy, it came in 3 sizes, 8" , 5 1/4" and3.5". the little one that wasn't really a floppy, it was hard plastic. NeverTheLess my friend that truned me on to Linux (Slackware) showed me a command line that all I had to do was write something giving it the prams, hit inter then that 3.5 floppy was fotmated instead of waiting for it to format under the format command. it was done as soon after hiting enter.

Linux wasn't support that well back then had to go back to Windows and forgot what it was that he showed me. maybe it only worked on 3.5 floppies. either way it was was really fast when used. just type size of drive - sectors and where it was at then hit enter (maybe missing a few prams) but whatever it was, It was done as soon as enter was hit. hit that arrow on the keyborad and do another one, it went faster then the old waiting for it to format every sector slowly

Last edited by BW-userx; 01-02-2016 at 08:37 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] USB drive fat32 format will not mount snakeman34 Linux - Newbie 5 09-05-2011 08:51 PM
How to Format a NTFS (USB) Hard Drive to FAT32 (or Ext3)? tomihasa Linux - Newbie 4 06-14-2009 06:29 AM
Format FAT32 > 32Gb in Linux for share with XP akafitz Linux - Newbie 1 07-06-2006 06:42 PM
SCSI Drive No Longer Available After FAT32 Format lplates Linux - Hardware 18 10-31-2004 03:10 PM
How to format my linux drive back to fat32 Underworld135 Linux - Newbie 5 10-19-2001 10:42 AM


All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration