LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-16-2009, 07:25 PM   #1
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Rep: Reputation: 0
Foreign letters appear when i type my username in ubuntu 9.04


Hi i'm new to linux. I purchased a mesh computer which came with unbuntu 8.10 which worked perfectly, i decided to use the download manager included in unbuntu to upgrade to the latest version of ubuntu 9.04. Unfortunately i cant seem to log in since when i type in my user name, it seems to type it in arabic or some foreign characters. As such it keeps getting refused. i have tried changing the language to english, but it just still types in arabic. Any help or guidance on this matter would be greatly appreciated.

alan
 
Old 07-16-2009, 07:38 PM   #2
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by vanitycat View Post
Hi i'm new to linux. I purchased a mesh computer which came with unbuntu 8.10 which worked perfectly, i decided to use the download manager included in unbuntu to upgrade to the latest version of ubuntu 9.04. Unfortunately i cant seem to log in since when i type in my user name, it seems to type it in arabic or some foreign characters. As such it keeps getting refused. i have tried changing the language to english, but it just still types in arabic. Any help or guidance on this matter would be greatly appreciated.

alan
try booting into single user mode. that should by pass the login and give you a command prompt. then try running
Code:
setxkbmap us
here is the information to get into single user mode http://www.cyberciti.biz/faq/grub-bo...gle-user-mode/

Last edited by jstephens84; 07-16-2009 at 07:39 PM.
 
Old 07-16-2009, 08:11 PM   #3
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
right dont know if its me being stupid but this is what happened.

I added Single to the kernel line as it requested in the guide link. it put me into the grub screen which i could write on, but everything i wrote came out as random arabic style letters still.
 
Old 07-16-2009, 08:19 PM   #4
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Ok, try booting a knoppix cd then mount your partition and edit the xorg config file and change the following
Code:
option "XkbLayout" "us"
course your will be something other than us. that should probably get you back up.
 
Old 07-17-2009, 02:36 AM   #5
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
sorry, you lost me at mounting the partition, not really sure how to do that since yeserday was the first time i've used linux ever, do you have any guidance on this? I've manage to load up knoppix. thats as far as i have got.
 
Old 07-17-2009, 03:30 AM   #6
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
right not sure if i'm doing this right but i found an Xorg file in /media/sda1/usr/X11R6/bin

When i type sudo nano /media/sda1/usr/X11R6/bin/Xorg.conf , i think it creates a new file in the editor, since there is nothing written in it.

is there another way to edit the config that i'm not aware of or am i doing this conpletely wrong?
 
Old 07-17-2009, 10:47 AM   #7
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by vanitycat View Post
right not sure if i'm doing this right but i found an Xorg file in /media/sda1/usr/X11R6/bin

When i type sudo nano /media/sda1/usr/X11R6/bin/Xorg.conf , i think it creates a new file in the editor, since there is nothing written in it.

is there another way to edit the config that i'm not aware of or am i doing this conpletely wrong?
nope you are on the right path. But you need to change /etc/X11/xorg.conf

you can mount your drive by using the following format

mount -t <filesystem> <device> <path>
Code:
mkdir /media/livesys
mount -t ext3 /dev/sda1 /media/livesys
what that will do is mount the partition sda1 which should contain your /, /root /etc ... and so on. Any changes here will modify your old system. From there you should be able to edit /etc/X11/xorg.conf.

you can also do
Code:
fdisk -l
to list the hard drive partitions. that way when you do the mount command you can insert /dev/sda1 for what ever you have.

here is the output from my laptop.

Code:
bsdtux@bsdtux-laptop ~ $ sudo fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x90909090

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13        6375    51097600    7  HPFS/NTFS
/dev/sda3   *        6375       14277    63472815   83  Linux
/dev/sda4           14277       14593     2544433+  82  Linux swap / Solaris
bsdtux@bsdtux-laptop ~ $
so If I was wanting to edit my xorg.conf file from a live boot cd I would mount /dev/sda3
 
Old 07-17-2009, 01:04 PM   #8
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
hi, thanks for all your help so far but i managed to get into the edit xorg config but the option XkbLayout us was already in the xorg conf file

see below

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

so what do i do now? :-S. i can copy and paste anything to you from my linux machine and have access to the internet through knoppixif that helps you in any way
 
Old 07-17-2009, 01:17 PM   #9
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by vanitycat View Post
hi, thanks for all your help so far but i managed to get into the edit xorg config but the option XkbLayout us was already in the xorg conf file

see below

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

so what do i do now? :-S. i can copy and paste anything to you from my linux machine and have access to the internet through knoppixif that helps you in any way
Just as a dumb question but where Xorg file is this. If you do a
Code:
pwd
what directory does it return?
 
Old 07-17-2009, 01:36 PM   #10
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
erm ok it says home/knoppix. ok so it looks like my attempt at mounting didnt work

it refused me as i wasnt the root user, so i put sudo infront of yous and presumed the mounting had worked sorry about this.

knoppix@Microknoppix:~$ mkdir /media/livesys
mkdir: cannot create directory `/media/livesys': Permission denied
knoppix@Microknoppix:~$ sudo mkdir /media/livesys
knoppix@Microknoppix:~$ sudo mount -t ext3 /dev/sda1 /media/livesys
knoppix@Microknoppix:~$ mount -t ext3 /dev/sda1 /media/livesys
mount: only root can do that
knoppix@Microknoppix:~$ sudo nano /etc/X11/xorg.conf
knoppix@Microknoppix:~$ pwd
/home/knoppix

this is all i have done
 
Old 07-17-2009, 01:47 PM   #11
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by vanitycat View Post
erm ok it says home/knoppix. ok so it looks like my attempt at mounting didnt work

it refused me as i wasnt the root user, so i put sudo infront of yous and presumed the mounting had worked sorry about this.

knoppix@Microknoppix:~$ mkdir /media/livesys
mkdir: cannot create directory `/media/livesys': Permission denied
knoppix@Microknoppix:~$ sudo mkdir /media/livesys
knoppix@Microknoppix:~$ sudo mount -t ext3 /dev/sda1 /media/livesys
knoppix@Microknoppix:~$ mount -t ext3 /dev/sda1 /media/livesys
mount: only root can do that
knoppix@Microknoppix:~$ sudo nano /etc/X11/xorg.conf
knoppix@Microknoppix:~$ pwd
/home/knoppix

this is all i have done
Ok well after doing a sudo you then need to go to /media/livesys/etc/x11 and edit the xorg.conf file. and that should hopefully get you going. I will try to setup a lab server and recreate this problem if I can get a chance.
 
Old 07-17-2009, 02:01 PM   #12
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Ok right think i've done what you've said, this is what appeared. where do i put the option Xkblayout us ?


GNU nano 2.0.7 File: /media/livesys/etc/X11/xorg.conf

xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection
 
Old 07-18-2009, 10:07 AM   #13
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
I tried adding in the the keyboard lines in the Xorg.conf file, but when i reboot computer to ubuntu, there was still no change.

I tried to look for people with simular problems, one fix they suggested was to replace the xorg file(i've kept a back up of the original) with the knoppix version of the xorg file. however this has also had very little effect when i tried it. the text is still coming up in arabic, and when i type it starts at the right side of them screen just like arabic. is there any other files that might be corrupted?
 
Old 07-18-2009, 11:06 AM   #14
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Upgrading" from 8.10 to 9.04 should go smoothly, but the net is littered with complaints.

The general advice is to save your personal files, and then do a fresh install of 9.04, then restore your personal files.

Code:
knoppix@Microknoppix:~$ mount -t ext3 /dev/sda1 /media/livesys
mount: only root can do that
So you didn't manage to mount your /dev/sda1 so you cannot edit the xorg.conf file If you really wanted to mount it like that then you should have done
Code:
knoppix@Microknoppix:~$ su mount -t ext3 /dev/sda1 /media/livesys
I think knoppix uses su not sudo If one doesn't work, try the other.
[Edit: you did use sudo, it worked, but then the file you needed would have been at /media/livesys/etc/X11/xorg.conf [/Edit]
But IIRC knoppix puts all disk partitions as icons on your desktop, and you just have to R-click them and choose "mount" before you can access the files in those partitions. You don't even need to give a password. It's worth a try.

If you can get this to work, I suggest you get yourself an external drive, and copy all of your HDD install home ( /home/yourusername/ ) to the external drive. Make sure you can read your files there. Then shutdown, remove the external drive and then do a fresh install of 9.04. Then restore your files from the USB disk.

Of course, if you have only been using linux for 2 days, there may be nothing of value in your home, and you can just go ahead a do a fresh install.

I suppose the point I am trying to make is that a fresh install is going to be easier than trying to figure out what, exactly, went wrong with the "upgrade" (and there may be a lot more to it than your language / locale being set to arabic).

Good luck, and let us know how you get on.

Last edited by tredegar; 07-18-2009 at 11:08 AM.
 
Old 07-20-2009, 05:54 AM   #15
vanitycat
LQ Newbie
 
Registered: Jul 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks Guys for all your help. Tredegar - i did originally think of doing this but wasnt sure on the whole formatting and reinstalling of ubuntu, plus mesh came with a facility to get the nvidia graphics working, but i decided to go ahead with the reinstall, it was actually a breeze and the ubuntu found the drivers i needed for nvidia so all is well. I think i have also managed to get my wireless netgear wg111v3 working too. So all is good and well.

I have a question which i know isnt about the original topic i started but i ask anyway.

I wanted to run tiny xp within ubuntu. what is the best program to do this? is it virtual box or is there a better one that you could recommend?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Random device letters assigned on Ubuntu 8.04? brianpbarnes Linux - Hardware 1 12-04-2008 07:26 PM
Cannot type username when looging into SLED 10 mpruehs SUSE / openSUSE 1 03-16-2007 11:28 AM
squares with letters in appearing in KDE 3.5.2 under Ubuntu 6.06 Lordandmaker Linux - Newbie 6 02-15-2007 04:59 AM
How to use scim to type foreign languages? renshao Linux - Newbie 2 03-30-2006 12:25 PM
How can I set to type with foreign languages(special characters most) petru_b16 Linux - Software 1 07-27-2003 04:32 PM


All times are GMT -5. The time now is 02:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration