LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-10-2007, 10:09 AM   #1
obsolete123
LQ Newbie
 
Registered: Jul 2007
Distribution: Red Hat 9
Posts: 2

Rep: Reputation: 0
Forcing RH9 to automatically log in


I have a server running Red Hat 9, the only purpose of which is to save and archive logs from our network switches. It's on a private network, isolated from the outside world, and is also in a physically secure room.

I don't want to have to run to the computer room every time I'd like to use it, though--I've set it up with x11vnc and the VNC server starts up automatically when I log in as root and works well.

I'm okay with using the root account because it's the login/password that all of our trusted users have, and the machine is reasonably secure/not mission-critical as outlined above.

Anyhow, VNC needs a user to be logged in and have an open Gnome session, so I tried the following, which I believe is the standard procedure:

Desktop -> System Settings -> Login Screen
General Tab -> Automatic Login ->
Login a user automatically on first bootup (Checked)
Automatic login username: "root" after 10 seconds.

And...it doesn't work! The machine boots to a Gnome login prompt and just sits there. Is there just a "Don't automatically log in as root, stupid!" block built in, or am I missing something?

TIA.

Last edited by obsolete123; 07-10-2007 at 10:18 AM.
 
Old 07-10-2007, 11:51 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Did you try a regular user account login? I mean root should not be able to log onto X at all, it's usually prevented because it's a security hole the size of your serverroom

And yes, there is a configuration option to allow root logins to X.
 
Old 07-10-2007, 03:43 PM   #3
obsolete123
LQ Newbie
 
Registered: Jul 2007
Distribution: Red Hat 9
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by obsolete123
Is there just a "Don't automatically log in as root, stupid!" block built in...
Quote:
Originally Posted by b0uncer
Did you try a regular user account login? I mean root should not be able to log onto X at all, it's usually prevented because it's a security hole the size of your serverroom
This was exactly the problem. I ended up just creating another account, adding the x11vnc command it its .bashrc, and using it instead, after which things went just fine. I guess some people are just going to have to use a different login and password, but it's not an oft-used machine, so it shouldn't be too big an inconvenience.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I prevent my box from automatically forcing fsck after the default number of abefroman Linux - Software 4 12-16-2005 05:25 PM
automatically log in TranceDude Fedora 14 08-13-2005 01:03 PM
Log in as root automatically, possible? rand0mh3ro Linux - General 16 12-01-2004 12:41 AM
Automatically forcing file system check? The_Nerd Linux - Hardware 1 11-30-2004 11:37 PM
Log in a user Automatically Swampy Debian 2 10-09-2004 03:02 AM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration