LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-30-2001, 06:02 AM   #1
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 212

Rep: Reputation: 30
"forced check" when booting


I've installed Suse 7.3 and whenever I boot I see a message that the drive on which Linux has been installed wasn't successfully umounted (or something like that...) at the previous shutdown. It then apparently checks/scans the whole drive before continuing with the boot process.

Any advice as to what I can change or tweak to make this irritation go away?

Thanks
Joe
 
Old 12-30-2001, 09:23 AM   #2
bluecadet
Member
 
Registered: Oct 2001
Distribution: MD81 RH71
Posts: 555

Rep: Reputation: 30
the most likely cause is that your system is not closing down properly. are you letting it turn itself of properly and such like?
 
Old 12-30-2001, 01:29 PM   #3
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 212

Original Poster
Rep: Reputation: 30
Yes, I do it by the book . Click on shutdown or reboot and keep my hands off the keyboard and mouse until it's time to login again. It's definitely not caused by me pulling the plug or anything similar.
 
Old 12-31-2001, 03:32 AM   #4
Wazza
Member
 
Registered: Dec 2000
Location: South Australia
Distribution: RedHat 7.2
Posts: 55

Rep: Reputation: 15
Hi
Do you mean that you wait until your at the log-on screen again to shut down???
 
Old 12-31-2001, 10:28 AM   #5
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 212

Original Poster
Rep: Reputation: 30
Here's the scenario:

I'm logged on & decide to shutdown or reboot. Click on the KDE button and click on the log out option (or something like that). The login screen duly appears. I click on shutdown and select either reboot or shutdown from the menu that appears.

When I select shutdown, the machine shuts down. No problem.

When I select reboot or when I boot after a shutdown, the machine boots and eventually comes to the point where it goes thru the "check forced" bit.

And that's the problem I'm trying to have solved.
 
Old 01-01-2002, 04:31 AM   #6
ugge
Senior Member
 
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
Have you tried to make a manual fsck.
I recall that I have heard manual checking can sometimes work when the clean flag won't set on the hard drive.
At least it would probably show us if it is the system not shutting down properly or something else.

Try booting your suse with the rescue floppy/cd (don't know which route suse has chosen). Then try to run e2fsck /dev/hda1, that is if your linux partition is hda1.
Now shutdown with the command shutdown. I'm mixing all the different commands for shutdown on the systems I use so read man page for shutdown.

Now we have checked the drive but not mounted it. Now the clean flag on your hard disk should signal that the drive was unmounted cleanly. Try to reboot normally and see what happens.
 
Old 10-10-2002, 02:25 AM   #7
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 212

Original Poster
Rep: Reputation: 30
Just for the sake of completeness...

The good people at Suse responded as follows to my query:

*****************************
Title: The Hard Disk Is Checked After Every Reboot

http://sdb.suse.de/en/sdb/html/jkoeke_fsck73.html
_______________________________________________________

Applies to

SuSE Linux: Version 7.3
Kernel: Version 2.4.10

Symptom

Your root partition is checked for errors after every
reboot.

Cause

The cause is a problem regarding the cooperation between the
standard kernel and LVM.

Solution

Login as user root.
Use any editor of your choice (e.g Pico) to modify the
following entry (line 164) in file /etc/init.d/boot :

if test "$fs" = / -a -f "$des" -a "$type" != "reiserfs"

Please change here the if query to:

if test "$fs" = / -a -b "$des" -a "$type" != "reiserfs"

The only change takes place in the option from -f to -b.
******************************
And that was the end of the forced check.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Telling people to use "Google," to "RTFM," or "Use the search feature" Ausar General 77 03-21-2010 11:26 AM
"Frame check sequence"-error (802.11b Ad hoc) rickthemick Linux - Wireless Networking 2 08-21-2008 10:04 AM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
dual booting winME with RedHat 7.2 "HOW TOOO""HELP" jdbarrow Linux - Software 1 03-11-2002 05:33 PM
"File system with errors, check forced" Luis Rosso Linux - General 5 02-02-2001 07:26 PM


All times are GMT -5. The time now is 09:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration