LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-22-2008, 10:32 AM   #1
helptonewbie
Member
 
Registered: Aug 2006
Location: England Somewhere
Distribution: Mandriva, PCLinuxOS, Karoshi, Suse, Redhat, Ubuntu
Posts: 518

Rep: Reputation: 39
Force Network Interface changes ie speed?? not working


Hello,
I'm trying to force a speed change on my network card. Its a server which has two ports on one card...one of the ports is correct and works at 1000baseT and the other on the same card is 100baseT when it should be 1000baseT.

ethtool eth1
Settings for eth1:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes

ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes

Now i've tried ethtool -r eth1 and still doesn't work...i've tried ethtool -s eth1 speed 1000 duplex full autoneg off, and this reports just speed unknown and so on. Whats going on...i haven't tried forcing it on the switch which i can do but i'd prefer to fix this, have several other boxes one of which is doing the same however the rest are all running on both ports 1000baseT/Full which means i can't understand why its not picking up the autoneg properly. Is there a way to debug the autoneg process? or what should i try next

Regards
 
Old 07-22-2008, 11:04 AM   #2
helptonewbie
Member
 
Registered: Aug 2006
Location: England Somewhere
Distribution: Mandriva, PCLinuxOS, Karoshi, Suse, Redhat, Ubuntu
Posts: 518

Original Poster
Rep: Reputation: 39
All resolved....nothing to do with linux or the switch....the patch panel cabling had a fault in a couple of ports whereas the rest of the patch ports are ok....yea ok networking 101 :-)

hmm at least it wasn't me that did the cabling
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Limit the speed of a network interface. exodist Linux - Networking 8 08-15-2008 10:37 PM
Force service on certain interface ajaimes Linux - Networking 2 06-18-2007 10:24 AM
network interface and usb devices not working.. szehanz Solaris / OpenSolaris 4 03-22-2005 08:56 PM
Setting Network Interface Speed ITJedi Linux - Networking 4 05-14-2004 11:02 PM
How do I force speed and duplex? daveherrmann Linux - Networking 10 04-18-2002 01:55 PM


All times are GMT -5. The time now is 02:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration