LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   font too small (http://www.linuxquestions.org/questions/linux-newbie-8/font-too-small-400839/)

Lotharster 01-08-2006 07:43 AM

font too small
 
I installed gtksee on my computer.
The problem is that the font is too small (see picture). I have the same problem with XMMS. Unfortunately, neither of the applications has an option to enlarge the font. What can I do?

I'm Using KDE 3.3 on Debian Sarge.
I'm using a 17'' TFT monitor with a 1260x1024 resolution.

http://img225.imageshack.us/img225/2563/look7kx.jpg

T.Hsu 01-08-2006 07:58 AM

They are gtk1 applications, their gui apperence can be adjusted through ~/.gtkrc. What is your locale, look at files in /etc/gtk for examples.

Lotharster 01-09-2006 01:17 PM

I installed gtk-theme-switch to configure the gtk font, butthat did not change anything. I have no ide how to configure .gtkrc manually. Below is the current content of ~/.gtkrc. Can You tell me what I should write in there? I'm located in Germany, but a normal US font should do in case there's nothing else.

Code:

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Amaranth/gtk/gtkrc"

include "/home/lo/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT


HappyTux 01-09-2006 02:13 PM

Try the site I have in my file to give you an idea of what you need to do.
Code:

## Added by me to get larger fonts from gtk1.x apps from info at http://www.linuxcompatible.org/thread27498-1.html  Commented out the include directory does not exist on my machine.

style "gtk-default" {
 fontset = "-monotype-times new roman-medium-r-normal--25-*-*-*-p-*-iso10646-1,\-microsoft-georgia-medium-r-normal--0-0-0-0-p-0-iso8559-15,\
  -*-Nimbus Sans L-medium-r-normal--14-*-*-*-p-*-iso10646-1,\
  -*-clearlyu-medium-r-normal--17-*-*-*-p-*-iso10646-1,\
    -*-r-*-iso10646-1,*"
}
class "GtkWidget" style "gtk-default"




#include "/usr/share/themes/Geramik/gtk-2.0/gtkrc"


stress_junkie 01-09-2006 02:49 PM

I think that you are having the same problem that I have. I am using KDE as my desktop. When I run a gnome application such as gnome-terminal the toolbar fonts are too small. When I start Gnome Control Center (gnome-control-center) and activate the fonts configuration applet then the fonts for gnome-terminal get bigger. I had set the toolbar font to be bigger a while back. Apparently this setting doesn't activate under KDE unless you run the Gnome Control Center | Font applet. I don't know how to get this to activate for gnome applications when KDE starts.

Lotharster 01-09-2006 03:48 PM

I solved it!

The gnome-control-center worked. It's a bit easier doing this with a gui.

Thanks to both of you for your help!


All times are GMT -5. The time now is 11:09 AM.