LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-13-2001, 10:51 AM   #1
juagut
Member
 
Registered: Apr 2001
Distribution: Red Hat 7.1
Posts: 39

Rep: Reputation: 15
Unhappy


Ok, could some please please dumb down how to get my pppd up and running so i can dial up to my ISP, i've been trying to read along on it, and i'm gettin lost, so if someone could help me out with that, that'd be nice...

As for errors when mounting my cdrom and floppy, when i try to mount my floppy drive : mount -t vfat /dev/fd0 /mnt/floppy i get an error of
end_request: I/O error, dev 02:00 (floppy), sector 8
mount: /dev/fd0 is not a valid block device

also, i've tried to mount my cdrom by using:
mount -t iso9660 /dev/cdrom /mnt/cdrom
but it tells me "block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found"

and samething if i try to mount hdc instead of cdrom (i checked out what exactly /dev/cdrom, and i saw it was a link to hdc)

This is what my fstab looks like:
/dev/hda5 / ext2 defaults 1 1
/dev/hda1 /boot ext2 defaults 1 2
/dev/hda6 swap swap defaults 0 0
/dev/fd0 /mnt/floppy ext2 noauto 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,ro 0 0
none /proc proc defaults 0 0
none /dev/pts devpts mode=0622 0 0

if i try do umount, it says the device isn't mounted (i just did it as a test)

Thanks
 
Old 04-13-2001, 11:13 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Try mounting without the -t flag like this:

mount /dev/cdrom /mnt/cdrom

That is the way I usually sometimes mount my cdrom and it works for me.
 
Old 04-13-2001, 11:34 AM   #3
NGene
Member
 
Registered: Mar 2001
Location: Turku, Finland
Distribution: Ubuntu
Posts: 66

Rep: Reputation: 16
You could also try mounting with only like:



mount /mnt/cdrom



This should work, too (works for me) because you already have the entries for it in /etc/fstab.



It looks normal when it says something about "mounting read-only" when you mount cdrom but the "no medium found" looks rather strange.



Try changing the filesystem type for floppy in fstab from ext2 to auto. Then, if you mount without the -t flag, it can detect the filesystem of the floppy automatically and you should be able to mount the floppy with:



mount /mnt/floppy



If you keep getting the same errors when mounting floppy: can you read/write it in windows (looks like it's formatted in windows)?



These are just my 2 cents...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation Follow up ar2007lx Fedora - Installation 5 07-17-2005 04:25 PM
how to follow a thread masand LQ Suggestions & Feedback 2 03-15-2005 12:06 AM
first steps a new admin must follow ddaas Linux - Newbie 3 12-21-2004 04:53 PM
Follow the link alaios Linux - General 1 07-03-2004 07:13 PM
I will destroy QT and all who follow it!!!! ciphercam Linux - Software 4 07-17-2003 12:33 AM


All times are GMT -5. The time now is 08:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration