LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-23-2008, 05:28 PM   #16
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346

Quote:
Originally Posted by openSauce View Post
<snip>
I think you misread his output - it's the user lin who is the only one who can access SECONDARY. And on my system, Nautilus is running under my username. So I'm a bit baffled as to why Nautilus can't read the permissions. Maybe a child process with a different UID? </snip>
Yes, you're correct. But then there's a question: Can lin have rwx as owner, when lin is not a member of the root group?

Of course, lin may be a member of the root group, but that would be unusual, and, of course, leave the Ubuntu system open to hacking web sites since programs run under lin's id could be run with root privileges.

Anyhow, I saw the column of root names and didn't look closely at what was actually there. My bad.
 
Old 10-24-2008, 06:12 AM   #17
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
lin@name:~$ sudo /sbin/fdisk -l /dev/sd?
[sudo] password for lin:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x35db35db

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2550 20482843+ 7 HPFS/NTFS
/dev/sda2 2551 9729 57665317+ 5 Extended
/dev/sda5 2551 9430 55263568+ 83 Linux
/dev/sda6 9431 9729 2401686 82 Linux swap / Solaris

Disk /dev/sdb: 20.4 GB, 20490559488 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x38c138c1

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 2490 20000893+ c W95 FAT32 (LBA)

Disk /dev/sdc: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x17e1dd8d

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 14593 117218241 c W95 FAT32 (LBA)

Disk /dev/sdd: 257 MB, 257474560 bytes
8 heads, 62 sectors/track, 1013 cylinders
Units = cylinders of 496 * 512 = 253952 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
lin@name:~$ ps aux | grep nautilus?
lin 7313 0.0 0.0 3004 764 pts/0 R+ 04:42 0:00 grep nautilus?
lin@name:~$

I haven't any problem with accessing SECONDARY as only a user. The only problem I'm having is that silly message, lol. It's really too bad I can't get it to show up using a terminal so I could paste it here for you. I've looked in Nautilus to see if I could change it somehow so it wouldn't display the 'unknown' under each drive partition and make it somehow able to determine the permissions of "/". But I didn't see anything helpful there though. This is something that was somehow caused by my using Amarok to access SECONDARY to rename mp3's. Since I'm unfamiliar with the OS, I made the mistake of concluding that it would crash as easily as win95 or winme used to. I'm entirely used to looking up error messages in order to fix winme and I got quite capable of making that OS do things it normally wouldn't be capable of. It was always my aspiration though, to move up to Linux as soon as I could figure out how to install and run it. Only thing was, no one locally wanted anything to do with it. I even have a 'Linux Bible' though it's fourteen years out of date.
 
Old 10-24-2008, 06:42 AM   #18
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
Quote:
Originally Posted by linn View Post
lin@name:~$ ps aux | grep nautilus?
lin 7313 0.0 0.0 3004 764 pts/0 R+ 04:42 0:00 grep nautilus?
lin@name:~$
Sorry, I didn't mean for the question mark to be part of the command . The question mark wasn't in bold on my previous post, but I should have made that clearer. I'm just wondering if Nautilus is running as some other user although that seems unlikely.

Did you try those chown and chmod commands?
 
Old 10-25-2008, 04:40 PM   #19
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
okay, I tried the 'chown' commands and all I got was several pages of this line:chown: changing ownership of `/media/SECONDARY/Wavs/StarTrek/lev10acc.wav': Operation not permitted
I also tried the 'mount' command and it came back with:
lin@name:~$ sudo mount /mnt/d*
mount: can't find /mnt/d* in /etc/fstab or /etc/mtab

Does it make a difference that I share SECONDARY with windoze? It's formatted in FAT32 so I could do that...

Is it 'safe' for me to reboot?
 
Old 10-25-2008, 08:14 PM   #20
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
First, you can only do the mount after you have
(1) created the mnt/d mount point: sudo mkdir /mnt/d
and
(2) added the line /dev/sdb1 /mnt/d vfat defaults,rw,uid=lin,gid=lin 1 2 to the /etc/fstab file by entering the command sudo gedit /etc/fstab from a terminal window.

After you've done those two steps -- and TESTED the change, the mount /mnt/d (no *) should work. That is, in fact, the test.

Since the command you quoted (with the d*) should have failed, and did, I can't say if you should reboot.

<edit>Notice that I changed the driver name from ntfs-3g to vfat since you neglected to mention heretofore that your D: drive was FAT formatted. (The ntfs-3g driver is for NTFS formatted drives which can, of course, be access with no problems from Linux. In fact, you could access your C: drive that way if you wished.)
</edit>

Last edited by PTrenholme; 10-25-2008 at 08:20 PM.
 
Old 10-25-2008, 09:18 PM   #21
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
okay, just did all that stuff and now I get in response to:
lin@name:~$ mount /mnt/d
mount: according to mtab, /dev/sdb1 is mounted on /media/SECONDARY
mount failed

now what? Is this messed up? Do I take out that last line you had me add to fstab?

lin@name:~$ ps aux | grep nautilus
lin 6822 0.0 1.4 88324 29896 ? Sl 08:10 0:22 nautilus --no-default-window --sm-client-id default2
lin 10113 0.0 0.0 3004 760 pts/0 R+ 20:51 0:00 grep nautilus

Last edited by linn; 10-25-2008 at 09:53 PM.
 
Old 10-25-2008, 10:05 PM   #22
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Yes, or try sudo umount /dev/SECONDARY and try the sudo mount /mnt/d again. If that works, look at /mnt/d in palces to see if the "unknown" stuff has been resolved. If it has, try the reboot. (If the reboot fails, then you'll need to boot in "rescue" mode and comment out the line by adding a # as its first character.)

Note that the un-mount command is umount, not unmount. One of the many Linux "gotchs."

Ih the reboot works, your SECONDARY drive will be /mnt/d and, if you do the same thing using /dev/sda /mnt/c ntfs-3g defaults,rw,gid=lin,uid=lin 1 2 you should also have access to your Windows C: drive.
 
Old 10-25-2008, 10:45 PM   #23
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
Results:
lin@name:~$ sudo umount /dev/SECONDARY
[sudo] password for lin:
umount: /dev/SECONDARY: not found
lin@name:~$ sudo mount /mnt/d

But...I already had access to my Primary C drive, all I had to do was click on it, how will this affect that? D SECONDARY is a separate physical drive formatted in fat32 so that I could share stuff between windoze and linux. Please assure me that rebooting will be successful...I'm not that keen on working in 'recovery' mode. Do I get a gui to work with if I have to comment out that line?

lin@name:~$ sudo mount /mnt/d
mount: /dev/sdb1 already mounted or /mnt/d busy
mount: according to mtab, /dev/sdb1 is already mounted on /mnt/d

Is there any way to be certain that the computer will boot up after all this?

Present contents of my fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda5
UUID=0a713fe7-aae3-43e1-8e40-3a2c8b0a0005 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda6
UUID=ae5734bc-f079-4ab4-b573-59cda2c181a2 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdb1 /mnt/d vfat defaults,rw,uid=lin,gid=lin 1 2

Last edited by linn; 10-25-2008 at 11:27 PM.
 
Old 10-26-2008, 12:23 AM   #24
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
Okay, it booted up fine, I just can't see SECONDARY any more. Please advise me on repairing this...

Thanks for your kind attentions...
 
Old 10-26-2008, 09:39 AM   #25
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
OK, what you've done is moved SECONDARY to /mnt/d, so that's where you look for it. You've also set the owner and group to "lin" so you can read and write to the drive without needing a sudo command.

The point in this was to see if the "unknown" or "unable to read" messages were suppressed when you looked at the drive.

You can leave it as the way it is now, or you can "revert" to the way it was before all this fuss by deleting (or commenting out) the last line (the dev/sdb1 one) in your /etc/fstab.

So, did the change "fix" the warning messages that were bothering you?
 
Old 10-28-2008, 06:32 PM   #26
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
Thanks for the help. I did comment out the line that you had me add to fstab, but the line also changed all the files on SECONDARY so that now I don't have to be in sudo to change the names of all the music there, which is good. How might I also apply this type of 'fix' to my main installation in order to alleviate the 'unknown' descriptions under each of the recognised drives? I think I might just be happy with what I have for now though, since everything works fine, and it's only some kind of a display error. Though it isn't an error it's displaying, lol.
 
Old 10-29-2008, 06:03 PM   #27
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Strange.

Well, if you want to try it, do the same things you did for "SECONDARY," except use /dev/sda1 for thye device and ntfs-3g (instead of vfat) for the driver name. At least it should do no harm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unrar and Rename to Parent Folder Recursively Vasto Linux - Newbie 9 10-16-2008 07:36 AM
How can I rename a folder's content to the name of the folder itself? xmrkite Linux - Software 7 07-25-2008 01:28 PM
Rename Folder in numerics infonlinebr Linux - Newbie 7 06-10-2008 03:02 PM
rename last character in file/folder name BoraX Programming 9 10-26-2006 11:01 AM
rename file/folder command hct224 Linux - Newbie 4 09-19-2003 10:44 AM


All times are GMT -5. The time now is 01:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration