LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-05-2002, 03:46 AM   #1
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Rep: Reputation: 15
Folder permissions


This is my first post in the forum, I'm testing you now to see how quickly you can reply

I have installed the new Mandrake 8.2 and have logged in as root to mount my windows partition to linux

My main user "jim" however can see this folder (/mnt/windows) but cannot see the files. Root cannot change the file permissions either (Could not set permissions for /mnt/windows is the error.) What do I need to set and what am I doing wrong?


Another thing, How do i get SuperUser access from another account? (in XTerm for example)


Thanks very much,

Jim

Last edited by fatboyjim; 06-05-2002 at 04:06 AM.
 
Old 06-05-2002, 03:54 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
sorry... 8 minutes. bit slow for me....

root can't change permissions on a vfat file system as the permissions don't exist in the first place. you need to set it in /etc/fstab which will create pretend rights for the entire drive. e.g.

/dev/hdb1 /mnt/windows vfat defaults,umask=000

it's the umask bit you'll end to edit.

and SuperUser? you mean root yeah? well just use "su" in a terminal

Last edited by acid_kewpie; 06-05-2002 at 03:59 AM.
 
Old 06-05-2002, 04:03 AM   #3
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Original Poster
Rep: Reputation: 15
Thank you, su is what I meant (I thought that's what su stood for)

so what do i change the umask to so that "jim" can see and edit the files and folders?

Thanks again,
 
Old 06-05-2002, 04:06 AM   #4
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Original Poster
Rep: Reputation: 15
And another thing...

The link at the bottom of your sig (http://www.ibiblio.org/pub/Linux/doc...nux-HOWTO.html) doesn't work (404)
 
Old 06-05-2002, 04:08 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
with a umask of 000 the rights (a la ls) will read rwxrwxrwx so EVERYONE can edit the files. if you specifically wish to restrict it to one group then set the gid= flag to the group number you want, presumably you could set the uid= to the same value in stead, as i presume you are the only person in your group.

yeah.. that link 404d a month back.. can't be arsed to remove it.
 
Old 06-05-2002, 04:19 AM   #6
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks a lot

Jim
 
Old 06-05-2002, 05:59 AM   #7
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Original Poster
Rep: Reputation: 15
OK, it kinda worked

I added /dev/hda1 /mnt/windows ntfs defaults,umask=000

to the etc/fstab file as root

Now when I login as root it's all done for me, and it all works

But when I log in as jim still no joy

Any ideas?

Thanks
 
Old 06-05-2002, 07:01 AM   #8
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Are you running NTFS or FAT on your Windows? If you don't know, you should... well actually if you can acess it as root, I am guessing it's NTFS. First you probably don't want to enable "write" access as this is known to destroy your drive unless you do it the "correct" way. I don't know the correct way, so I just leave it as "read-only" by adding this to my fstab:
/dev/hda1 /mnt/windows ntfs auto,user,ro,nouser,async 0 0

I don't know if I need ALL of that, but it mounts it just fine for all my users. I think maybe the 'nouser' part makes it available to anyone?
 
Old 06-05-2002, 07:03 AM   #9
vfs
Member
 
Registered: Apr 2002
Location: Brazil
Distribution: Slackware
Posts: 184

Rep: Reputation: 30
Do a

chmod 1777 /mnt/windows

HTH
 
Old 06-05-2002, 08:25 AM   #10
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Original Poster
Rep: Reputation: 15
NTFS, thanks for the help

I'll reply when and if it works
 
Old 06-05-2002, 10:55 AM   #11
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Original Poster
Rep: Reputation: 15
Don't know what I did but it's finally working for all users

Thanks a lot for all of your help
 
Old 06-05-2002, 01:50 PM   #12
vfs
Member
 
Registered: Apr 2002
Location: Brazil
Distribution: Slackware
Posts: 184

Rep: Reputation: 30
Surely is the 'chmod 1777 /mnt/windows'
 
Old 06-05-2002, 02:20 PM   #13
fatboyjim
LQ Newbie
 
Registered: Jun 2002
Location: UK
Distribution: Mandrake / RedHat
Posts: 26

Original Poster
Rep: Reputation: 15
I didn't actually need to do that

It was already working when I was about to type it in
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
permissions difference between /home/..../folder and /root/folder darkleaf Linux - General 3 07-21-2005 05:23 PM
folder permissions steve007 Linux - Newbie 1 06-30-2005 12:46 PM
Folder permissions Canam97 Mandriva 7 03-10-2005 11:01 PM
Folder permissions help Seventh Linux - Newbie 2 04-22-2004 05:56 PM
Folder Permissions DB03 Linux - Newbie 5 04-18-2004 03:08 PM


All times are GMT -5. The time now is 08:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration