LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-15-2004, 11:58 PM   #1
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
fluxbox upgrade question..


I am still very new to installing/upgrading packages on linux.

I downloaded the new fluxbox-0.9.10 slackware package.

I copied it to /home/blair --- my user home.

I ran installpkg flux*

I then ran startx as root and flux upgraded to .9...

I exited flux
logged in as user blair "me".
ran startx and fluxbox was still 1.14....

How do I install the package so it upgrades flux for everyone not just root user?

I know this question is better poster to software, but I am still a newb
. Software forum answers are often go over my head.

Thanks,
Blair
 
Old 12-16-2004, 12:41 AM   #2
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Rep: Reputation: 33
That is kinda strange, it should have updated for everyone. I updated Flux with Swaret, so you might try that.

After setting up swaret:
Code:
 swaret --upgrade fluxbox
Replace fbsetbg with something that allows for transparent menues:
Code:
 swaret --install feh
After that Flux will be up to date and you'll have nice looking, transparent menus.

Swaret
 
Old 12-16-2004, 08:21 AM   #3
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
It seemed weird to me also.

I will try swaret., and thanks for the transparent menus heads up.

Regards,
Blair
 
Old 12-16-2004, 10:35 PM   #4
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
tried swaret.

It says fluxbox packages are up to date.

I did swaret --install feh, and it said no available packages matching feh.

Still stuck.
 
Old 12-16-2004, 10:59 PM   #5
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Rep: Reputation: 33
You can get feh if you add linuxpackages.net to your swaret repositories file.

Some Good Info

I'm on my Debian box, so I can't tell you what url you need for linuxpackages, but the answer is on this board somewhere.

Note: Some reccommend against using third party repos with swaret as it can break the system. I haven't noticed anything troubling, but just so you know.
 
Old 12-17-2004, 12:14 AM   #6
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
I followed this to configure swaret
http://shilo.is-a-geek.com/slack/swaret7.html

BTW. I went back into user fluxbox and it says the old version #(0.1.14.), but looks like current version(.0.9.10)???????????

*not sure if version are correct I m doing it from memory.

As user I could now tinker with alpha values.
So I guess something worked.

I will read up on feh.

Still puzzled, but happier.

Thanks,
Blair
 
Old 12-28-2004, 02:47 PM   #7
MylesCLin
Member
 
Registered: Sep 2004
Location: Texas, USA
Distribution: Slack 9.1 with slackware-current packages...
Posts: 164

Rep: Reputation: 30
Is it saying the old version in the right-click menu?
If so, open up a terminal and type fluxbox --version.
If it says the new 0.9.10, edit ~/.fluxbox/menu to say 0.9.10
 
Old 12-28-2004, 03:00 PM   #8
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
You can call it anything you want,sounds like you have the newer fluxbox it is just your old menu,also check your ~/.fluxbox/init and make sure it is reading your menu ~./fluxbox/menu.Here is the first part of mine;
# you can change the menu name in .fluxbox/init to:
# session.menuFile: /home/you/.fluxbox/my-menu
[begin] (Gentoo.tux)
[exec] (aterm) {aterm}
[exec] (Eterm) {Eterm}
[exec] (firefox) {/home/david/firefox-installer/firefox}
[exec] (Run) {fbrun }
See mine is Gentoo.tux,you could call yours SlackBox if you wanted.
 
Old 12-28-2004, 09:28 PM   #9
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
That fixed it.

I changed menu from old version to just "fluxbox".


comprookie on aterm you just have it set as:

[exec] (aterm) {aterm} ?

did you set your aterm settings somewhere else?

I did - ( in /home/me/.fluxbox/menu) :

[exec] (aterm) {aterm -tr -tint blue -fg yellow -cp white}
That gives me transparency a blue tint with yellow text and a white cursor. It shows up better on my dark background.

Just curious

Thank you for your help.

Regards,
Blair
 
Old 12-28-2004, 09:31 PM   #10
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
I put them in .Xdefaults;
Code:
Aterm*scrollBar: false
Aterm*transparent: true
Aterm*background: black
Aterm*foreground: white
Aterm*tintingType: true
Aterm*shading: 60
Aterm*fading: 50
Aterm*loginShell: true
Aterm*saveLines: 5000
Aterm*font: -pxl-*-*-*-*-*-16-*-*-*-*-*-*-*
Aterm*cursorColor: red
Aterm*title: Gentoo


Aterm*colorBDMode:	on
Aterm*colorBD:          white
Aterm*colorULMode:	on
Aterm*colorUL:		white
XTerm*scrollBar:    false
XTerm*background:   black
XTerm*foreground:   gray
XTerm*cursorColor:  yellow
Xterm*font: -pxl-*-*-*-*-*-16-*-*-*-*-*-*-*
here is some more dot file's for fluxbox;
http://fluxbox.sourceforge.net/download/dotfiles/

Last edited by comprookie2000; 12-28-2004 at 09:42 PM.
 
Old 12-28-2004, 09:35 PM   #11
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
that was fast.
 
Old 12-28-2004, 09:51 PM   #12
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
These fonts look great,just edit your style;get the en ones (english)
http://sourceforge.net/project/showf...group_id=95348
Here is the howto;
http://artwizaleczapka.sourceforge.net/README
What I do is download them and then move them to /usr/share/fonts then cd /usr/share/fonts
su
tar xvfj <filename>
remove the tar.bz2
then edit /etc/X11/xorg.conf like this

FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/sharefonts/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/pxl2000-0.95/"
FontPath "/usr/share/fonts/ttf-bitstream-vera/"
FontPath "/usr/share/fonts/artwiz/"
FontPath "/usr/share/fonts/freefont/"
FontPath "/usr/share/fonts/artwiz-aleczapka-en/"
FontPath "/usr/share/fonts/corefonts/"
 
Old 12-28-2004, 11:33 PM   #13
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
Thanks for the info.

I have tried artwiz a few installs ago. ( when I mess up my box beyond repair I just re-install.)
This is a learning process for me. I have learned more with slackware in a couple months than a year plus with SUSE.
anyway i am babbling. Thanks for the help.

I will try artwiz again with your instructions. Thx.

Regards,
Blair
 
Old 12-28-2004, 11:45 PM   #14
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
All right comprookie.

I just checked out you sig links.

Is that desktop picture flux?
How did you do the icons? is that through fbdesk?
The other stuff is that super karamba?

Sorry for all the questions, and I know all this is off the thread topic, but i had 2 ask.

Regards,
Blair.

Thx for the linuxcommand linkthe "ps -A" command has come in handy over the last month.
(I have been looking for that site for a couple weeks.)
 
Old 12-29-2004, 12:17 AM   #15
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
If you want icons in flux, fbdesk and rox can do it fine but iDesk provides some nice eye candy if you're into looking good too Looks like fluxbox and the "other stuff" is gDesklets, not superkaramba
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 01:33 PM
upgrade to fluxbox 0.9.X linuxhippy Slackware 4 05-15-2005 07:30 PM
Fluxbox upgrade, something's wrong. littlemidget Debian 5 01-24-2005 11:53 PM
FluxBox question... Zerodark Slackware 9 09-07-2003 10:57 PM
Fluxbox upgrade breakage Phantomas Linux - Newbie 3 08-11-2003 01:21 PM


All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration