LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2008, 12:58 AM   #1
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Rep: Reputation: 0
Fluxbox/Slackware


Well, I've installed slackware 12.0 since I had an installation disk laying around and my windows Vista trial was over. I used to have a KDE/pekwm setup, and now I use Flux. I am having a bit of trouble with configuring the system to how I want it, and I can't set backgrounds or anything. The volume doesn't work, although the drivers are installed (according to KMix, and I use headphones). So, I need to get the sound to work, the background, and file permissions (I can't start XMMS which was installed with installpkg unless I'm under root/su in a terminal?). Its been a long break for me from linux, I just need a little push into the right direction to getting my system tweaked for performance and verstality.
 
Old 08-04-2008, 01:06 AM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 69
What is your soundcard? Did you try the alsamixer command?
In Fluxbox the background can be set in .fluxbox/init file. Like this, for example
session.screen0.rootCommand: fbsetbg ~/Desktop/tigger_1610.jpg
 
Old 08-04-2008, 01:14 AM   #3
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Uncle_Theodore View Post
What is your soundcard? Did you try the alsamixer command?
In Fluxbox the background can be set in .fluxbox/init file. Like this, for example
session.screen0.rootCommand: fbsetbg ~/Desktop/tigger_1610.jpg
I'm using a Dell version of the Soundblaster Audigy card, made by Dell.

Edit:

I can't download files in Firefox? I get an error saying that I cannot write to the /tmp/ directory. I can't install add-ons into firefox either =\

Last edited by fishbones; 08-04-2008 at 01:23 AM.
 
Old 08-04-2008, 01:30 AM   #4
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 69
Quote:
Originally Posted by fishbones View Post
I'm using a Dell version of the Soundblaster Audigy card, made by Dell.
Well, I don't know anything about it, so the best thing I can suggest is a google link:
Quote:
http://linuxedge.blogspot.com/2008/0...igy-4-for.html
Edit:

I can't download files in Firefox? I get an error saying that I cannot write to the /tmp/ directory. I can't install add-ons into firefox either =\
Hm. What does

ls -l /

return for /tmp? Try doing

chmod 777 /tmp
 
Old 08-04-2008, 02:22 AM   #5
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Uncle_Theodore View Post
Well, I don't know anything about it, so the best thing I can suggest is a google link:


Hm. What does

ls -l /

return for /tmp? Try doing

chmod 777 /tmp
The /tmp/ directory is fine now, but my sound still doesn't work. Anymore suggestions?
 
Old 08-04-2008, 07:13 AM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
What's the output of /sbin/lspci so we can determine the sound card type/chipset, etc?

As for backgrounds in flux, try the following: http://www.newlinuxuser.com/howto-se...er-in-fluxbox/
 
Old 08-04-2008, 12:04 PM   #7
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by trickykid View Post
What's the output of /sbin/lspci so we can determine the sound card type/chipset, etc?

As for backgrounds in flux, try the following: http://www.newlinuxuser.com/howto-se...er-in-fluxbox/
Results:
Code:
0000:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02):
01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a2)
02:01.0 Modem: Intel Corporation FA82537EP 56K V.92 Data/Fax Modem PCI (rev 04)
02:02.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X
02:02.1 Input device controller: Creative Labs [SB Live! Value] Input device controller
02:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 02)
 
Old 08-04-2008, 02:58 PM   #8
bashyow
Member
 
Registered: Jun 2008
Location: uk
Distribution: Slackware 12.1, AND IM LOVIN EVERY MINUTE OF IT, JERRY! :D
Posts: 122

Rep: Reputation: 15
first thing to try is open a terminal, then type 'alsamixer', bring all the levels up, then unmute your card by toggling the 'M' key on your keyboard. its best to have an mp3 playing in your media player while trying this.

theres also a quirk with some SB live cards (including mine), in that '00' mutes the sound, while 'MM' actually gives sound so toggle that 'M' key!

then once you have sound (hopefully), press the escape key (top left) go back to the terminal, then as root, type 'alsactl_store' to save your changes.

Last edited by bashyow; 08-04-2008 at 03:03 PM.
 
Old 08-04-2008, 03:06 PM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
You seem to have two sound cards, an AC97 and a SoundBlaster. I'd assume the AC97 is onboard, you may want to disable the one that is onboard in the BIOS. Both should be supported though, I'd go with the soundblaster though if you can.
 
Old 08-04-2008, 03:10 PM   #10
Maligree
Member
 
Registered: Mar 2008
Distribution: Gentoo, CentOS, Fedora, Arch
Posts: 231
Blog Entries: 1

Rep: Reputation: 42
Quote:
(..) type 'alsactl_store' to save your changes.
Without the underscore if I remember right, so:
Code:
alsactl store
 
Old 08-05-2008, 11:27 PM   #11
fishbones
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
I still haven't found a solution, is it because I'm using headphones?
 
Old 08-05-2008, 11:46 PM   #12
Reasa
Member
 
Registered: Aug 2008
Distribution: Slackware
Posts: 53

Rep: Reputation: 16
yeah about that 2 soundcards- $alsamixer will show you the name of the audio card in use
Card: SB Live 5.1
Chip: SigmaTel

thats what it says for me
i heard on windows you can setup to get audio-out even via microphone-in slot with some drivers. make sure its plugged in audio out (analog)

Last edited by Reasa; 08-05-2008 at 11:47 PM.
 
Old 08-06-2008, 04:04 AM   #13
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Aren't you supposed to run alsaconf before alsamixer or alsactl store?
 
Old 08-06-2008, 09:51 AM   #14
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally Posted by fishbones View Post
I still haven't found a solution, is it because I'm using headphones?
Not necessarily, unless your plugging them into the soundcard that isn't properly setup or configured. did you ever try disabling one?
 
Old 08-06-2008, 01:25 PM   #15
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by Uncle_Theodore View Post
Well, I don't know anything about it, so the best thing I can suggest is a google link:


Hm. What does

ls -l /

return for /tmp? Try doing

chmod 777 /tmp
That needs to be 1777, /tmp is meant to be "sticky"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 11.0 Fluxbox Menu wastelander42 Slackware 2 01-28-2007 05:25 AM
Fluxbox error /usr/share/fluxbox/nls/en_GB/fluxbox.cat humbletech99 Debian 2 12-29-2005 10:16 AM
Cyrillics oh Slackware 10.2 and fluxbox 0.9.14 kosmonaft Slackware 1 11-13-2005 03:21 PM
FluxBox and Slackware XPediTioN Linux - Software 1 07-17-2003 12:18 PM
slackware 9.0, Phoenix 0.5, fluxbox :) Bluesuperman Slackware 0 05-25-2003 06:25 PM


All times are GMT -5. The time now is 12:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration