LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2004, 09:05 AM   #1
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Rep: Reputation: 15
Fluxbox questions - sound problem.


How can I remove stuff from the Fluxbox menu?
How can I add stuff to the Fluxbox menu?

How do I uninstall programs? I have Mozilla installed but now I installed Firefox and I don't really need Mozille then.

I can't get any sound. I haven't tried changing anything 'cause I don't know what I'm supposed to do. So what do I do to setup my sound card or whatever it is that I'm supposed to do?

When I change my keyboard settings to swedish go to /usr/X11R6/bin/ and type ./setxkbmap se but everytime I start my computer I have to do that again. How do I save that setting?
 
Old 03-05-2004, 09:22 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
to add/remove stuff to/from the fluxbox menu, use the tool FluxMenu, that is found when you right-click the desktop with your mouse, then select Fluxbox-menu -> Tools -> FluxMenu and just use it the tool lets you add and remove, edit and re-arrange all the menuentries, and after you're ready, save your changes and use them.

uninstalling programs depends on your distribution, not fluxbox...so it's a bit different thing if you use Fedora, than if you use Gentoo. what are you running?

and sound..that too depends quite a lot of what distribution you have. first of all, do your apps do anything (like error msgs) when you try to use sound? for example, if you open Xmms and play a song, will it start "playing" (but without sound) or does it tell you that no sound is available?

and the keyboard...edit (with some text-editor, root mode required I guess) your /etc/X11/XF86Config like this: find the Input Devices -section, and there is some info about your keyboard. here's some of my file:

Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "fi"

those tell my X what kind of keyboard I use. when you need to change your keyboard's language, just change the XkbLayout, and (I have finnish, so it's fi) change the given option into what you need (se). that should do (for X, console needs another type of edit).

EDIT: of course, after editing XF86Config you need to (re)start your X to get the new options work

Last edited by b0uncer; 03-05-2004 at 09:25 AM.
 
Old 03-05-2004, 09:46 AM   #3
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
Actually I don't have FluxMenu. I only have WindowName there.

I use Slackware 9.1, you can see that below my username to the left

When I try to play an mp3 with XMMS it looks like it's playing and all only I don't get any sound out of my speakers.

I tried installing as little as possible when installing Slackware and it seems I left out some things I shouldn't have left out. AbiWord for example would probably have been a good program when changing stuff eh? I know what other text editor to use since I didn't install KDE or Gnome and therefore don't have Kwrite and so on. I tried downloading and installing Abiword but I must have done something wrong.
I get

abiword: error while loading shared libraries: libgucharmap.so.3: cannot open shared object file: No such file or directory

When I type "abiword". And I'm in /home/MY-USERNAME/abiword-2.0.3/abi while trying this.
 
Old 03-05-2004, 11:29 AM   #4
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
You can manually edit the fluxbox menu by editing the file

~./fluxbox/menu.

Tis pretty easy to understand how the file works.

On Slackware you should be able to remove progs by running pkgtool as root.
 
Old 03-05-2004, 02:54 PM   #5
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
oh, sorry about the distribution...I was stupid of course I can see it on the left.. (but why on earth I didn't look at it? hehe) hmm...

I checked out fluxbox's site, and you'll need an app called FluxConf which gives you the tools "fluxmenu", "fluxconf" etc. check out http://devaux.fabien.free.fr/flux/ and download the app, and install it..or if you know where to get a binary or something for Slack, get it FluxConf is definitely an app you should get, it makes editing menus etc. so easy..(even if the menu-file editing would be easy)

ok, so Xmms plays but without sound... first, open somekind of mixer app and check that your volume levels are _not_ set to zero I've had this problem once. a basic, but good app is called aumix - try it. also, open up your Xmms' Options -> Prefences and on the first page check Output plugin - try to either change it (if you can) or then Configure it...this should probably be ok, if Xmms doesn't give errors. (my guess would be the volume levels...but try seeing the mixer levels).

I tried googling for "libgucharmap.so.3" and RPMfind.net told me that the package you need is gnome-utils (yes, a package that comes along gnome...but just get the single package and you should do). I use OpenOffice for my writings and all other office-stuff, altough it's a bit bigger than AbiWord (hey, it's an office-suite! hehe)

so now get the FluxConf (it's not big) and see what your volume levels are...
 
Old 03-08-2004, 01:35 PM   #6
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
I got the sound working by changing the colume levels with aumix, thanks

With amp, how do I play files that have spaces in their names? I can't just write 'em 'cause that won't work and when I try with " before and after the filename it won't work either.

About manually editing fluxboxmenu, where should I be when typing <B>~./fluxbox/menu</B> 'cause I can't seem to get it to work.

I downloaded FluxConf but I don't know how to start FluxMenu. On the site it says that it should be in Fluxbox-menu --> Tools but I guess they don't get there automatically 'cause it's still just WindowName there.

Last edited by NomDeGuerre; 03-10-2004 at 09:42 AM.
 
Old 03-09-2004, 06:33 PM   #7
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
*bump*
 
Old 03-09-2004, 06:40 PM   #8
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
you could try using <tab> key to complete the file's name. You could also use backslashes like this:
xmms name\ of\ my\ music\ file.mp3

hope this helps
 
Old 03-10-2004, 06:14 AM   #9
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
Yea thanks, that helped.
Anyone got answers for the other questions?
 
Old 03-10-2004, 07:13 AM   #10
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
Quote:
About manually editing fluxboxmenu, where should I be when typing <B>~./fluxbox/menu</B> 'cause I can't seem to get it to work.

I downloaded FluxConf but I don't know how to start FluxMenu. On the site it says that it should be in Fluxbox-menu --> Tools but I guess they don't get there automatically 'cause it's still just WindowName there.
Oops. I meant to write ~/.fluxbox/menu. Basically open it with whatever text editor you use.

As to fluxconf, if it's installed correctly try restarting fluxbox from the right-click menu.
 
Old 03-10-2004, 07:47 AM   #11
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
Thanks.

It used to say:
Code:
[begin] (Fluxbox-0.1.14)
	[exec]    (rxvt) {rxvt}
	[exec] (mozilla) {mozilla}
And I changed it to:
Code:
[begin] (Fluxbox-0.1.14)
	[exec]    (rxvt) {rxvt}
	[exec] (firefox) {firefox}
But when I click "Firefox" in the Fluxmenu nothing happens.
What did I miss?
 
Old 03-10-2004, 07:56 AM   #12
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
Probably cos firefox is run as mozilla-firefox.

Leastways mine is.

Last edited by Chris H; 03-10-2004 at 08:02 AM.
 
Old 03-10-2004, 08:37 AM   #13
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
That wasn't it but I looked at some other stuff in the menu and tried some stuff.
It should have been

Code:
[exec] (firefox) {/home/MYUSERNAME/firefox/firefox}
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions about X and FluxBox Mercurius Linux - Software 16 10-10-2005 11:29 AM
KDE versus Fluxbox Sound Problem Murdock1979 Linux - Software 2 09-23-2005 08:41 AM
Sound, mousewheel, and fluxbox questions c_olin3404 Linux - General 2 05-15-2005 10:27 PM
2 questions (Change sound format and nvidia driver problem) KETrel Linux - General 0 10-19-2004 12:57 PM
fluxbox questions saiz66 Slackware 54 05-26-2003 01:55 PM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration