LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-16-2011, 04:00 PM   #1
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 40
Fluxbox not starting, I know the problem just not the solution


Here is what is happening:
I startup the ol' computer, Choose Ubuntu, select my user, and change session to Fluxbox, enter password, press OK,BLACKSCREEN.

The reason I think this is happening:
My wi-fi wasn't working, Searched on the web and found this dandy little helper:
Code:
nm-applet --sm-disable
To be inserted in ~/.fluxbox/startfluxbox. Which I did right before the 'exec fluxbox' line, as it said that was the last thing to run.
The first time I tried it, I did it in terminal from an already active session (prior to adding it to flux/start), terminal ran it and my wi-fi worked great! However it never stopped running the command and returning to :$. So I think with it being BEFORE the exec flux, that it is stuck in a 'loop'. retrospectively this was not the smartest of moves, But as my signature says 'You know that thing you did? don't do that.' ... So now I know

What I have tried:
Editing the file from another distro [b]&/b] editing it from same distro, just using ubuntuclassic as my DM. But it is not showing startfluxbox just start (which isn't the same file at all NOR does it have the nm-applet line), even when I enable Show Hidden Files.


What I would like:
For anyone willing and able to give me a tip,trick,suggestion,idea,feedback, or anything on how to A.) Start Flux & B.) where to properly insert nm-applet at to keep my wi-fi going.

Thanks for taking the time to read this, and thanks for any suggestions you can give.

Last edited by Hevithan; 06-16-2011 at 04:04 PM.
 
Old 06-16-2011, 04:02 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
Try backgrounding it
Code:
nm-applet --sm-disable >/tmp/nm-applet.log 2>&1 &
 
1 members found this post helpful.
Old 06-16-2011, 04:21 PM   #3
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
started up as usual, and used CTRL+ALT+F1 to bring up terminal,
Entered
Code:
nm-applet -sm-disable > /tmp/nm-applet.log 2>1 &
, the output returned was
Code:
[1]1923
ALT+F7 to leave terminal, waited a few minutes - nothing happened.
$ sudo reboot
login - Nothing still
 
Old 06-16-2011, 04:51 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I use the ~/.fluxbox/apps file to start things when fluxbox starts. If I were in your shoes, I would remove the command from startfluxbox file and put the following into apps:

Code:
[startup] {nm-applet --sm-disable >/tmp/nm-applet.log 2>&1 &}
My guess is that things are goofed up because the way you've got it nm-applet is trying to start before fluxbox does, so it probably can't find an X screen to work with and crashes or does funky things.
 
1 members found this post helpful.
Old 06-16-2011, 09:23 PM   #5
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,361
Blog Entries: 12

Rep: Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751
Try this:

Code:
nm-applet -sm-disable &
And it should before the exec fluxbox line.

See the Fluxbox wiki for more.
 
1 members found this post helpful.
Old 06-16-2011, 09:45 PM   #6
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
Quote:
Originally Posted by frankbell View Post
Try this:

Code:
nm-applet -sm-disable &
And it should before the exec fluxbox line.

See the Fluxbox wiki for more.
It is before the exec, I just didn't put the &. I'd give it a go but my resolution is all messed up, and xrandr is only picking up 640 X 480 ... So it'll have to wait. Sorry . I'll post when solved because I am about 98% sure this is the cause of my problem. Thank you all for your help.
 
Old 06-16-2011, 10:14 PM   #7
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
The problem was the lack of the '&' symbol. It's all kosher now, thanks again everyone for the help in making flux work.
 
Old 06-17-2011, 08:20 PM   #8
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,361
Blog Entries: 12

Rep: Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751
Congrats.

Thanks for the rest of the story.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Fluxbox.... AceTech747 Linux - Software 13 12-15-2003 05:02 PM
starting fluxbox tombomb300 Linux - Software 8 11-20-2003 01:06 AM
starting fluxbox in rh9.0 shiny Linux - Software 6 05-31-2003 01:44 PM
Starting Fluxbox rdanda Slackware 10 05-01-2003 01:58 PM
Black screen when starting X -- solution! glorinc Linux - Hardware 1 07-22-2002 06:59 PM


All times are GMT -5. The time now is 05:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration