LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2005, 12:32 PM   #1
AltUlster
LQ Newbie
 
Registered: Apr 2005
Location: Buckle, BibleBelt, USA
Distribution: Debian Sarge
Posts: 9

Rep: Reputation: 0
Fluxbox help and RAM issues


Iím still fairly new to Linux, so I thought Iíd post my questions here. I recently moved to Debian Sarge and have found it to very stable compared to my previous distros (FC3, simplyMepis, Yoper, and DSL). With the help of this forum I have got everything working just like I want; nVidia 3d acceleration, sound, and all those other things I couldnít get to work consistently before. Iíve installed this on an old boat anchor formally known as a PII 350, and though my original intent was to set this up for my 11 year old son Iíve found myself playing with this box more than my Mac. Anyway, enough about all that and on to my real questions.

I came to realize that KDE and Gnome were a bit much for my hardware and have since moved to fluxboxÖand I love it! Finally a desktop I can call my own. There are a few things I donít understand however.

1. Whatís the difference between the app file and startup file? Currently, I have ~/.fluxbox/startup do nothing but set my background, fire up torsmo, and open a transparent aterm. I have nothing in my apps file. Is there a better way to do this? Does it make a differance that I am using KDM as my session manager (my son still likes KDE and its fine for his purposes).
2. Relating to #1, for some reason when I start my session 2 aterms open up and perhaps 2 torsmos as well (though this is harder to tell). Iím calling the startup file from the rootCommand in ~/.fluxbox/init
3. I went to fluxbox because I was under the impression that it had a small footprint and would be better for my machine. However, with just torsmo (or maybe 2 of them) running I have 46% RAM usage on 256mb of RAM. That sounds like a lot to me. Is it?

Thanks in advice for any help. Below is some more info that may be helpful.

kernel 2.6.1-11-686 (I thinkÖwriting this from work)
standard fluxbox package form Debian unstable.
nVidia TNT2 with 686 drivers
P2 350
256 Mb RAM
no desktop icons and no dockapps

Thanks
 
Old 05-13-2005, 01:02 PM   #2
NoobieDoobieDo
Member
 
Registered: Oct 2004
Distribution: Debian 4.0
Posts: 65

Rep: Reputation: 15
Hi,

On your RAM issue.

Reboot the computer, go into KDE use top or whatever and note the mem usage.

Reboot the computer, go into Fluxbox, repeat above steps.

It's a larger Window Manager, but you may want to also check out icewm. It has some good config tools u can download like, icewm control panel.

I used Blackbox , Fluxbox, FVWM(?), Gnome, KDE, XFCE and prefer KDE and Icewm the most.

Good luck
 
Old 05-13-2005, 01:26 PM   #3
gbhil
Member
 
Registered: Jan 2005
Location: /dev/input/chair0
Distribution: Slackware, Gentoo, Vector, Roll-your-own-with-GNU binutils
Posts: 174

Rep: Reputation: 30
1. /startup is an actual script that will allow you to pass other shell options during startup, while /apps only lists applications to start.

2. Remove the call to startup from ~/.fluxbox/init. You're already using the startup file to run fluxbox. Lots of way to get fluxbox up and running, but it sounds like your distro/session manager/etc is doing it the correct way.

3. Verify that torsmo is not reading cached ram. Run the top command and look at how your ram is being used.
 
Old 05-13-2005, 02:53 PM   #4
AltUlster
LQ Newbie
 
Registered: Apr 2005
Location: Buckle, BibleBelt, USA
Distribution: Debian Sarge
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by gbhil
1. /startup is an actual script that will allow you to pass other shell options during startup, while /apps only lists applications to start.

2. Remove the call to startup from ~/.fluxbox/init. You're already using the startup file to run fluxbox. Lots of way to get fluxbox up and running, but it sounds like your distro/session manager/etc is doing it the correct way.

3. Verify that torsmo is not reading cached ram. Run the top command and look at how your ram is being used.
1. ok, thanks

2. Ok, should I replace the the call for startup at rootCommand with the fbsetbg command that is currently in startup and put the two apps in ~./fluxbox/apps?

3. Thanks I'll try that when I get home.

NoobieDo, Thanks. I tried iceWM, and the default them had a windoze start button complete with flag so I uninstalled it, KDE is to bloated, and XFCE I just didn't like. So far Fluxbox and Enlightenment seem to be more my style.


Thanks again for your replies.
 
Old 05-13-2005, 04:17 PM   #5
gbhil
Member
 
Registered: Jan 2005
Location: /dev/input/chair0
Distribution: Slackware, Gentoo, Vector, Roll-your-own-with-GNU binutils
Posts: 174

Rep: Reputation: 30
Quote:
Originally posted by AltUlster

2. Ok, should I replace the the call for startup at rootCommand with the fbsetbg command that is currently in startup and put the two apps in ~./fluxbox/apps?

Thanks again for your replies.
You're most welcome!
Here's what I would do - as always, ymmv -

In the rootCommand section of ~/.fluxbox/init I would enter fbsetbg -l . This just tells fbsetbg to use the last wallpaper (which is stored in ~/.fluxbox/lastwallpaper - you might have to create this file if it doesn't exist.)

remove the fbsetbg reference from ~/.fluxbox/startup

It would run fine if thats all you did.

However, you can eliminate the call to ~/.fluxbox/startup completely and save a teeny bit of ram -
Add applications from /startup to the /apps file
Find where your xinit is calling fluxbox to start. (.xinitrc, .Xsession, /etc/X11/xinit/ are good places to start looking). Change the final command from
Code:
exec $HOME/.fluxbox/startup
to
Code:
exec path/to/actual/fluxbox/binary
you can find the correct path to the fluxbox binary from the last uncommented line in ~/.fluxbox/startup

I hope this makes sense, and is helpful
 
Old 05-13-2005, 11:17 PM   #6
AltUlster
LQ Newbie
 
Registered: Apr 2005
Location: Buckle, BibleBelt, USA
Distribution: Debian Sarge
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
In the rootCommand section of ~/.fluxbox/init I would enter fbsetbg -l . This just tells fbsetbg to use the last wallpaper (which is stored in ~/.fluxbox/lastwallpaper - you might have to create this file if it doesn't exist.)

remove the fbsetbg reference from ~/.fluxbox/startup
Did this for now and seemed to work. I'll attempt to the direct call to the binary after I get a little sleep. One thing from your comments concerns me; I didn't have a startup file to begin with after install, I had to create it. Do you mean the init file?

After this change and a reboot I'm down to 27% RAM usage at when Idle. I went ahead and ran top as suggested and have pated the results below. Looks like quite a bit running, but what do I know. Anything there that is a red flag? Thanks


Code:
top - 10:36:03 up 32 min,  2 users,  load average: 0.26, 0.38, 0.36
Tasks:  50 total,   1 running,  49 sleeping,   0 stopped,   0 zombie
Cpu(s):  4.7% us,  2.7% sy,  0.0% ni, 92.7% id,  0.0% wa,  0.0% hi,  0.0%
Mem:    256768k total,   189552k used,    67216k free,    12472k buffers
Swap:   369452k total,        0k used,   369452k free,   106328k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND     
 2954 root       5 -10 69980  33m  43m S  5.6 13.4   3:04.55 XFree86     
 3490 dylan     15   0 25424  14m  23m S  1.0  5.6   0:02.40 kedit       
 3499 dylan     15   0 24920  12m  23m S  0.0  4.8   0:01.75 kdeinit     
 3492 dylan     21   0 22748 9904  21m S  0.0  3.9   0:00.63 kdeinit     
 3497 dylan     16   0 22052 9260  21m S  0.0  3.6   0:00.06 kdeinit     
 3495 dylan     15   0 22036 8768  21m S  0.0  3.4   0:00.03 kdeinit     
 3475 dylan     15   0 21108 7340  11m S  0.0  2.9   0:01.43 artsd       
 2814 hal       16   0  5840 4348 3020 S  0.0  1.7   0:00.88 hald        
 3395 dylan     16   0  6764 3732 5732 S  0.3  1.5   0:07.34 fluxbox     
 2931 dylan     15   0  3244 1868 2536 S  0.0  0.7   0:06.03 famd        
 3482 dylan     16   0  3564 1820 3092 S  0.3  0.7   0:00.29 aterm       
 2869 Debian-e  16   0  5136 1720 4760 S  0.0  0.7   0:00.00 exim4       
 3483 dylan     16   0  3012 1648 2676 S  0.0  0.6   0:00.03 bash        
 2898 root      18   0  3468 1496 3092 S  0.0  0.6   0:00.00 sshd        
 2802 root      15   0  2452 1464 1344 S  0.0  0.6   0:00.41 klogd       
 3384 root      16   0  3132 1288 2724 S  0.0  0.5   0:00.01 kdm         
 3481 dylan     16   0  3360 1156 3164 S  0.0  0.5   0:00.02 torsmo      
 3488 dylan     16   0  2064 1036 1852 R  0.7  0.4   0:00.51 top         
 2809 messageb  15   0  2092  996 1928 S  0.0  0.4   0:00.00 dbus-daemon 
 2935 root      18   0  2376  920 2204 S  0.0  0.4   0:00.00 rpc.statd   
 3424 dylan     16   0  2988  912 2644 S  0.0  0.4   0:00.00 ssh-agent   
 2879 lp        18   0  2464  884 2272 S  0.0  0.3   0:00.00 lpd         
 2817 root      16   0  2556  868 2120 S  0.0  0.3   0:00.01 dirmngr     
 2306 root      16   0  2376  856 2164 S  0.0  0.3   0:00.00 dhclient    
 2799 root      16   0  2260  816 2092 S  0.0  0.3   0:00.04 syslogd     
 2875 root      20   0  2240  728 2084 S  0.0  0.3   0:00.00 inetd       
 2941 root      16   0  1756  712 1576 S  0.0  0.3   0:00.00 cron        
 2947 root      16   0  2528  712 2352 S  0.0  0.3   0:00.00 kdm         
 2938 daemon    19   0  1684  628 1520 S  0.0  0.2   0:00.00 atd         
    1 root      16   0  1504  508 1352 S  0.0  0.2   0:00.65 init        
 2971 root      16   0  1500  484 1336 S  0.0  0.2   0:00.00 getty       
 2979 root      16   0  1500  484 1336 S  0.0  0.2   0:00.00 getty       
 2980 root      16   0  1500  484 1336 S  0.0  0.2   0:00.00 getty       
 2981 root      16   0  1500  484 1336 S  0.0  0.2   0:00.00 getty       
 2982 root      16   0  1500  484 1336 S  0.0  0.2   0:00.00 getty       
 2983 root      16   0  1500  484 1336 S  0.0  0.2   0:00.00 getty       
  351 root      13  -4  1492  460 1336 S  0.0  0.2   0:00.10 udevd       
 2311 daemon    16   0  1612  460 1440 S  0.0  0.2   0:00.01 portmap     
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0 
    3 root       5 -10     0    0    0 S  0.0  0.0   0:00.00 events/0    
    4 root       5 -10     0    0    0 S  0.0  0.0   0:00.01 khelper     
   22 root       5 -10     0    0    0 S  0.0  0.0   0:00.03 kblockd/0   
   44 root      20   0     0    0    0 S  0.0  0.0   0:00.00 pdflush     
   45 root      15   0     0    0    0 S  0.0  0.0   0:00.12 pdflush
 
Old 05-14-2005, 10:42 AM   #7
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
linux will use all the ram it can, without having to touch the swap file, and it will realize when something isn't being used and dump that from ram to free ram up for another program. it's not unusual for linux to use a lot of ram at any one time.

also if you look at your top stats, you'll notice you have 50 processes started, but only one is running with 49 asleep. thats totally normal, and you're idling at 92%, which means your processor isn't being used all that much. this looks pretty normal to me.

if you look at mine below, i'm using 50% of my ram...and zip of my swap. linux handles ram more efficiently, so it makes better use of it.

.top - 10:45:52 up 42 min, 1 user, load average: 0.10, 0.08, 0.01
Tasks: 55 total, 2 running, 53 sleeping, 0 stopped, 0 zombie
Cpu(s): 0.3% user, 0.7% system, 0.0% nice, 99.0% idle
Mem: 507364k total, 250464k used, 256900k free, 30184k buffers
Swap: 982760k total, 0k used, 982760k free, 135620k cached



Last edited by detpenguin; 05-14-2005 at 10:49 AM.
 
Old 05-14-2005, 09:32 PM   #8
gbhil
Member
 
Registered: Jan 2005
Location: /dev/input/chair0
Distribution: Slackware, Gentoo, Vector, Roll-your-own-with-GNU binutils
Posts: 174

Rep: Reputation: 30
Quote:
Originally posted by AltUlster
Did this for now and seemed to work. I'll attempt to the direct call to the binary after I get a little sleep. One thing from your comments concerns me; I didn't have a startup file to begin with after install, I had to create it. Do you mean the init file?
I meant the ~/.fluxbox/startup file. Having to create one for any user that existed on the system before you installed fluxbox is normal. A sample should be in /etc/skel/.fluxbox for new users, but running flux for the first time is sometimes (often ?) buggy.


Quote:
Anything there that is a red flag? Thanks

Code:
 3490 dylan     15   0 25424  14m  23m S  1.0  5.6   0:02.40 kedit       
 3499 dylan     15   0 24920  12m  23m S  0.0  4.8   0:01.75 kdeinit     
 3492 dylan     21   0 22748 9904  21m S  0.0  3.9   0:00.63 kdeinit     
 3497 dylan     16   0 22052 9260  21m S  0.0  3.6   0:00.06 kdeinit     
 3495 dylan     15   0 22036 8768  21m S  0.0  3.4   0:00.03 kdeinit     
 3475 dylan     15   0 21108 7340  11m S  0.0  2.9   0:01.43 artsd
If you want to cut back on used RAM do yourself a favor - install another text editor! 24.2% of your used RAM is from kde processes as shown above, and likely kedit spawned them all. Other than that, everything looks perfect as detpengiun said. Everyone is playing nice and nothing is hitting your CPU
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 ram upgrade issues ricklerre Linux - Hardware 2 10-01-2005 06:47 AM
Slackware Linux RAM/Memory Issues Darvocet Slackware 6 05-25-2005 03:16 PM
RAM issues w/ Mandrake 10.1 Palamides Mandriva 10 01-31-2005 07:11 AM
Memory / Ram issues...please help.. elstupidos Slackware 2 01-16-2005 11:21 PM
RAM issues... elluva Linux - Hardware 5 05-24-2004 09:36 AM


All times are GMT -5. The time now is 06:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration