LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-21-2011, 04:39 PM   #1
looop
Member
 
Registered: Oct 2011
Location: Denmark
Distribution: Slackware - Mac OS X Lion - RedHat 6 - MS Win 2003 server - A/UX - FreeBSD - FreeNAS - pfsense
Posts: 75

Rep: Reputation: Disabled
Fluxbox add rootCommand to init


Hey I am new in heir.
But not new to linux, but I am quit green using Fluxbox.
So I want to add following commands to the init file:
fbsetbg -l /Pictures/slackware.jpg
setxkbmap dk

I thought I should add this to the init file:
session.screen0.rootCommand: fbsetbg -l /Pictures/slackware.jpg
session.screen0.rootCommand: setxkbmap dk

But when I reboot the system, the lines does not be execute am I do something wrong?
 
Old 10-21-2011, 05:20 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,597

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Hi,

First you need to setup your wallpaper running:
Code:
fbsetbg -f /Pictures/slackware.jpg
and then use just:
Code:
session.screen0.rootCommand: fbsetbg -l
Have a look at fbsetbg manpage for more options

Regards
 
Old 10-21-2011, 05:32 PM   #3
looop
Member
 
Registered: Oct 2011
Location: Denmark
Distribution: Slackware - Mac OS X Lion - RedHat 6 - MS Win 2003 server - A/UX - FreeBSD - FreeNAS - pfsense
Posts: 75

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bathory View Post
Hi,

First you need to setup your wallpaper running:
Code:
fbsetbg -f /Pictures/slackware.jpg
and then use just:
Code:
session.screen0.rootCommand: fbsetbg -l
Have a look at fbsetbg manpage for more options

Regards
That is right, but it does not work
 
Old 10-21-2011, 05:47 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,597

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Please define "but it does not work".
What happens when you run "fbsetbg -f /path/to/file" from xterm? Do you see the wallpaper? Does the file ~.fluxbox/lastwallpaper gets created?
 
Old 10-21-2011, 05:53 PM   #5
looop
Member
 
Registered: Oct 2011
Location: Denmark
Distribution: Slackware - Mac OS X Lion - RedHat 6 - MS Win 2003 server - A/UX - FreeBSD - FreeNAS - pfsense
Posts: 75

Original Poster
Rep: Reputation: Disabled
Sorry, yes
fbsetbg -f /Pictures/slackware.jpg and yes ~/.fluxbox/lastwallpaper get created but when I reboot it does not "reload" the wallpaper
 
Old 10-21-2011, 06:37 PM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,597

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
And what happens if you run "fbsetbg -l" from xterm? Do you get your wallpaper?

You may try to use the overlay feature that does the same thing.
Edit ~/.fluxbox/overlay and use:
Code:
background: aspect
background.pixmap: /Pictures/slackware.jpg
and see if it works this way
 
Old 10-21-2011, 06:38 PM   #7
looop
Member
 
Registered: Oct 2011
Location: Denmark
Distribution: Slackware - Mac OS X Lion - RedHat 6 - MS Win 2003 server - A/UX - FreeBSD - FreeNAS - pfsense
Posts: 75

Original Poster
Rep: Reputation: Disabled
if I run fbsetbg -l yes I get the wallpaper i want
 
Old 10-21-2011, 10:03 PM   #8
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 11,661
Blog Entries: 12

Rep: Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894
Rather than trying to answer your question directly, I suggest that you check out the Fluxbox wiki section on backgrounds.

It will answer your questions thoroughly.

The Fluxbox wiki is an excellent resource.
 
Old 10-22-2011, 03:23 AM   #9
looop
Member
 
Registered: Oct 2011
Location: Denmark
Distribution: Slackware - Mac OS X Lion - RedHat 6 - MS Win 2003 server - A/UX - FreeBSD - FreeNAS - pfsense
Posts: 75

Original Poster
Rep: Reputation: Disabled
I have used the fluxbox wiki, I always check that first, but it can't solved the problem :\
 
Old 10-22-2011, 04:10 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,597

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Quote:
Originally Posted by looop View Post
I have used the fluxbox wiki, I always check that first, but it can't solved the problem :\
Did you try to set the wallpaper in the ~/.fluxbox/overlay?
 
Old 10-22-2011, 06:21 AM   #11
looop
Member
 
Registered: Oct 2011
Location: Denmark
Distribution: Slackware - Mac OS X Lion - RedHat 6 - MS Win 2003 server - A/UX - FreeBSD - FreeNAS - pfsense
Posts: 75

Original Poster
Rep: Reputation: Disabled
yes
 
Old 10-22-2011, 11:49 AM   #12
clifford227
Member
 
Registered: Dec 2009
Distribution: Slackware 14
Posts: 282

Rep: Reputation: 64
Quote:
Originally Posted by looop View Post
session.screen0.rootCommand: fbsetbg -l /Pictures/slackware.jpg
The way I set the wallpaper in Fluxbox is this:

'session.screen0.rootCommand: fbsetbg -l' (without the path to the .jpg) in the Init file

Then you need a program to display the wallpaper, I use Esetroot, which is a part of Eterm (but there is a slackbuild for Esetroot at Slackuilds.org, if your using Slack). You can use feh or some other prog, but I couldnt get the aspect to display properly with feh.

Then, in '~/.fluxbox', you need to create a file called' lastwallpaper', with the following:

Code:
wpsetters Esetroot
$aspect $full|/home/user/.fluxbox/backgrounds/pic.jpg|:0.0
backgrounds being the place you put your wallpapers.

Also!

There is a special wallpaper option for the Fluxbox menu file, I have this line in the menu to change wallpapers easily:

Code:
[wallpapers]   (~/.fluxbox/backgrounds) {fbsetbg -u Esetroot -a}
put some wallpapers in ~/.fluxbox/backgrounds', and they should automatically show up in the fluxbox wallpaper sub-menu. If you set the wallpaper through the menu, it should stick on reboot. Works for me.

Last edited by clifford227; 10-22-2011 at 12:09 PM.
 
Old 10-22-2011, 07:24 PM   #13
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 11,661
Blog Entries: 12

Rep: Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894
What happens when you run "fbsetbg -i"?

Oh, I took a look at your original post:

Quote:
fbsetbg -l /Pictures/slackware.jpg
In init or startup, it should be

Code:
fbsetbg -l ~/Pictures/slackware.jpg
or

Code:
fbsetbg -l /home/[username]/Pictures/slackware.jpg
 
Old 10-23-2011, 05:36 AM   #14
looop
Member
 
Registered: Oct 2011
Location: Denmark
Distribution: Slackware - Mac OS X Lion - RedHat 6 - MS Win 2003 server - A/UX - FreeBSD - FreeNAS - pfsense
Posts: 75

Original Poster
Rep: Reputation: Disabled
@frankbell thanks mate it work
and thanks to all who helped
 
Old 10-23-2011, 07:53 PM   #15
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 11,661
Blog Entries: 12

Rep: Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894Reputation: 2894
Quote:
Originally Posted by looop View Post
@frankbell thanks mate it work
and thanks to all who helped
Cool. Glad I could help and I should have caught that the first time around.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fluxbox maximizes under tasbar--init settings are correct though pgb205 Linux - General 4 07-24-2009 10:33 PM
I have fluxbox but don't have fbsetbg, and I can only set BG from the init file Mr_Shameless Linux - Desktop 2 03-11-2007 03:25 AM
Slackware rootCommand: doesnt work hosler Linux - Software 7 04-04-2006 04:28 PM
fluxbox init overwritten in every restart. xushi Slackware 3 07-09-2005 03:31 PM
rootCommand: won't set background in flux joesbox Linux - General 0 02-09-2004 03:14 PM


All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration