LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2002, 06:44 AM   #1
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Rep: Reputation: 15
Floppy : I/O error


I've searched the forum (nothing worked) and found some unsolved problems.
I'd like to see more examples of /etc/fstab configuration about floppy & supermount.
Could anyone send his "floppy" line ?
Mine is
-> /dev/fd0 /mnt/floppy supermount user,exec,fs=vfat,dev=/dev/fd0 0 0
My cdrom was happy with :
-> /dev/hdd /mnt/cdrom supermount user,exec,fs=iso9660,dev=/dev/cdrom,ro 0 0

Last edited by j-charles; 03-17-2002 at 04:41 PM.
 
Old 03-01-2002, 10:00 AM   #2
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
Here's mine for Mandrake.

/mnt/cdrom /mnt/cdrom supermount fs=iso9660,dev=/dev/cdrom 0 0

/mnt/cdrom2 /mnt/cdrom2 supermount fs=iso9660,dev=/dev/cdrom2 0 0

/mnt/floppy /mnt/floppy supermount fs=vfat,dev=/dev/fd0 0 0

Curious as to why you want them?
 
Old 03-02-2002, 06:39 AM   #3
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Original Poster
Rep: Reputation: 15
I just con't read anything on my floppy!
-> i/o error
 
Old 03-17-2002, 04:52 PM   #4
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Original Poster
Rep: Reputation: 15
As I said before, I can't read anything from my floppy. I did try with those lines in /etc/fstab and here are the results :

1)
/dev/fd0 /mnt/floppy supermount user,exec,fs=vfat,dev=/dev/fd0 0 0
-> [input/output error]
2)
/dev/fd0 mnt/floppy vfat user,exec 0 0 (even if I add sync, iocharset=..., or codepage=... wich is the default configuration)
-> [unknown device : /dev/fd0]

hope the last line shed some light on the problem
 
Old 03-17-2002, 05:41 PM   #5
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
Usually mandrake does a good job of setting up the automount (from my experience). I'm not sure why you keep getting the I/O error.

You may want to try the floppy you are mounting (you do have a floppy in the drive?) on another machine which is already setup and works. Other than that you will have to look up mounting manually.
 
Old 03-17-2002, 07:21 PM   #6
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Check to see if the /dev/fd0 file exists. Do a ls /dev/fd* and see what you get.
 
Old 03-22-2002, 05:16 AM   #7
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Original Poster
Rep: Reputation: 15
floppy i/o :

1) /dev/fd0 exists

2) my computer doesn't even look at the floppy ! (no led (light) turned on)
and I still get an i/o error.
 
Old 03-22-2002, 07:09 AM   #8
panjas51
LQ Newbie
 
Registered: Mar 2002
Posts: 10

Rep: Reputation: 0
hello jean-charles

Well I got the same,

What I did to slove it:

- In the fstab:

I just kept everything by default. (including the iso part.)

do you have the same thing with root?
 
Old 03-22-2002, 12:03 PM   #9
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
Are you sure the floppy is even mounted?

Try "df -h" and see what you get.

Also, try "mdir a:" and see what happens.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Floppy I/O Error naimslim89 Linux - Hardware 0 04-13-2005 02:48 PM
floppy install error bjuhn Slackware - Installation 1 02-22-2005 09:39 AM
Just installed Fedora, fatal error when it looks for floppy, i have no floppy Zieroth Linux - Software 18 07-19-2004 07:42 PM
Help: RH9 and error in floppy jeguilloal Red Hat 2 12-09-2003 05:53 PM
floppy error isobel Linux - General 2 01-04-2003 04:29 PM


All times are GMT -5. The time now is 06:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration