LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-03-2005, 02:32 PM   #1
daverutt
LQ Newbie
 
Registered: Jan 2005
Distribution: mandrake 10.0
Posts: 19

Rep: Reputation: 0
Flashing Grub Cursor after attempted dual boot


I don't seem to have any luck with this dual booting malarky

here's my set-up

Asus pundit-r barebones case, 1 gb crucial pc3200 RAM, Celeron D 2.4ghz cpu, 120gb maxtor SATA Drive and Nec DVD drive.

I'm running windows 2000 on it in two partitions, C: drive of 20gb and D: drive of 100gb.

I recently got a copy of Suse 9.2 professional after failed attempts to dual boot Mandrake 10. Started the installation of Suse, and basically left it to it's own devices to install, didn't change the partitioning or boot loader.

When i came back to it after about 15 mins all there was on the screen was the word GRUB with a flashing cursor next to it.

i read on a different thread that GRUB tries to load from the MBR of the primary IDE master device (which in my case is the CD-ROm Drive, the hard drive being the serial ATA Master device in the bios)

Would changing the jumpers on the cd-rom drive to make it the slave device help at all?

Or is there something that I'm missing?

cheers for any help
 
Old 05-03-2005, 02:58 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
First thing to do is boot. you should locate the grub.conf file with the find command.

find /grub/grub.conf
or
find /boot/grub/grub.conf

This will print out a partition in form of (hd0,0) or so.

Then just run root (hd0,0) (depending on what the result was, make changes.

This should all go without errors.

then run kernel /kernel (press TAB to get options)
or
kernel /boot/kernel (press TAB to get the options)

then run
initrd /initrd (press TAB)
or
initrd /boot/initrd (press TAB)

The right ones are the ones, that do not produce errors.

Once you have run all these without errors (might take some changing from you) Just experiment, you cant mess anything.

Press TAB a lot of times after every command you type, to give you more options.

Ok, so let's say you got through without errors. Just type boot and press ENTER and away you go to Linux.

Once in linux. login as root and let us know

Try to post your fdisk -l results and /boot/grub/grub.conf file contents.
 
Old 05-03-2005, 03:03 PM   #3
daverutt
LQ Newbie
 
Registered: Jan 2005
Distribution: mandrake 10.0
Posts: 19

Original Poster
Rep: Reputation: 0
i'll try it out

expect more questions from me though!

cheers
 
Old 05-03-2005, 05:19 PM   #4
daverutt
LQ Newbie
 
Registered: Jan 2005
Distribution: mandrake 10.0
Posts: 19

Original Poster
Rep: Reputation: 0
right i tried to do what you said but to be perfectly honest i really don't understand it

all i'm getting whenever i turn on the computer is GRUB and a flashing cursor

I managed to boot into Suse via the installation disc, but that's not really practical and I can't get into windows at all

anyway to completely remove the linux installation, restore it back to just windows and start again?

 
Old 05-03-2005, 06:42 PM   #5
beagle2
Member
 
Registered: Aug 2004
Location: Aberdeen Scotland
Distribution: elive,sidux,xp,pclinuxos super gamer, mandriva 2007
Posts: 417

Rep: Reputation: 30
All is not lost hopefully - get a linux live cd of some kind and you can access your linux partitions and boot/grub/grub.conf and post the results here. Knoppix is superb but its a 700mb download so dsl is an excellent alternative at around 50mb. You say you can boot into suse with the installation disc so maybe thats a live cd, i dont know suse at all. Anyway with any luck the situation aint totally hopeless.
 
Old 05-03-2005, 09:36 PM   #6
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
at the grub prompt

config /boot/grub/menu.lst

if that fails try below

root (hd0,x)
kernel /boot/vmlinuz-xxxx root=/dev/hdax
initrd /boot/initrd-xxx
boot

hit return after each of those commands

I dont know what partition you install your distro to so I cant supply the x's like the guy said above use tab to complete entrys. I'll explain how grub counts the partitions. grub starts counting at 0 so

/dev/hda1 would be (hd0,0) in grub /dev/hda2 would be (hd0,1) in grub.


Last edited by Boow; 05-03-2005 at 09:41 PM.
 
Old 05-04-2005, 04:59 AM   #7
daverutt
LQ Newbie
 
Registered: Jan 2005
Distribution: mandrake 10.0
Posts: 19

Original Poster
Rep: Reputation: 0
I can't seem to type anything at the GRUB prompt, all it does is sit there flashing. I tried changing the boot loader to Lilo and that did the same thing.

Sorry to be an uber-newbie but where would I run fdisk, do I need to be logged into linux and open a command window for it, or can i run it from the rescue mode on the installation disc

I'm pretty sure that the linux program is in /dev/hda7, which i suppose would be hd0,6 for GRUB

I've managed to get back into windows by putting in my windows 2000 installation cd and running the rescue mode with the fixmbr command, though now I don't seem to even be able to see my linux installation

Is there any chance that the problem could be to do with where on the drive the linux os was installed? I had my hard drive split into 2 partitions for windows,and the Suse install resized my D Drive and put it there, there wouldn't be problems due to the 1024 boot cylinder limit because of this would there?

very very stuck indeed

Last edited by daverutt; 05-04-2005 at 05:08 AM.
 
Old 05-04-2005, 05:43 AM   #8
Chromezero
Member
 
Registered: Nov 2004
Location: Arizona
Distribution: Slackware, RHEL, others
Posts: 470

Rep: Reputation: 40
Just a thought here, but is your hard drive set to "LBA" mode in your bios? I had a similar problem some time ago after building a new system. I discovered that in my bios, my HD was set to auto by default. After I changed it to "LBA", everything worked fine.
 
Old 05-04-2005, 05:45 AM   #9
daverutt
LQ Newbie
 
Registered: Jan 2005
Distribution: mandrake 10.0
Posts: 19

Original Poster
Rep: Reputation: 0
I did check this but the only options I seem to have in my BIOS are auto or disabled for the LBA

Last edited by daverutt; 05-04-2005 at 05:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
just flashing cursor on boot eTitus Fedora - Installation 0 04-12-2005 10:05 AM
grub (blinking cursor) - won't boot php4u Fedora - Installation 2 04-04-2005 11:23 AM
GRUB gives a flashing cursor and freezes leemoreau Red Hat 4 12-30-2004 07:59 AM
Attempted dual boot WinXP and RedHat 9 - Login Problems Otaking Linux - Newbie 2 04-05-2004 10:36 AM
How to echo a flashing cursor? paleogryph Programming 4 10-15-2003 02:09 PM


All times are GMT -5. The time now is 12:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration