LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-13-2004, 11:27 AM   #1
Zaius
Member
 
Registered: Jan 2004
Location: Canada
Posts: 68

Rep: Reputation: 15
flash plugin won't install


i've got bad luck with plugins.. flash player seems easy enough.. just cp the flashplayer.xpt and libflashplayer.so into the mozilla/plugins folder... but nope it doesn't work. i also tried doing it with ln -s.. and still nothing... am i missing something here? mozdev.org says that i need libstdc++ (libstdc++-libc6.2-2.so.3) present.. how do i check what version i have?
 
Old 01-13-2004, 11:45 AM   #2
gurdib
Member
 
Registered: Jan 2004
Posts: 33

Rep: Reputation: 15
quickest would be 'locate libstdc++'

see what gives and if it is >= than what you need.

G.
 
Old 01-13-2004, 11:49 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
please tell us what actually happens.... "it doesn't work" isn't too insightful
 
Old 01-13-2004, 12:17 PM   #4
Zaius
Member
 
Registered: Jan 2004
Location: Canada
Posts: 68

Original Poster
Rep: Reputation: 15
/usr/share/doc/libstdc++-devel-3.3.2 (and all files/folders within it)
/usr/lib/gcc-lib/i386-redhat-linux/3.3.2/libstdc++.a
/usr/lib/gcc-lib/i386-redhat-linux/3.3.2/libstdc++.so
/usr/lib/libstdc++.so.5.0.5
/usr/lib/libstdc++.so.5
/home/james/compat-libstdc++-7.3-2.96.118.i386.rpm

that last one is what i d/loaded to update it if need be.

what i mean by 'it doesn't work' is that it doesn't show up in the Mozilla 'Help / About Plug-ins' and when i go to a page that requires flash it says that i don't have the flash plugin and subsequently the site does not load everything properly.
 
Old 01-13-2004, 12:24 PM   #5
Zaius
Member
 
Registered: Jan 2004
Location: Canada
Posts: 68

Original Poster
Rep: Reputation: 15
fixed it.. apparently Fedora core 1 doesn't come with this 'newer' version of libstdc++.. interesting.. all well.. it works great!
 
Old 01-13-2004, 12:27 PM   #6
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I've got the same problem with Mozilla-1.4 on Slack 9.1. I can't load ANY plugins into it. I've tried MPlayer, Plugger 5.0, and even Mozilla-1.4 plugins--nothing shows up in the folder. I've tried to cp the files directly to the folder as well, still nothing shows up. When I downloaded Mozilla-1.5 it worked, but then everything else was screwed up that depended on Mozilla (Galeon, Epiphany, et. al.) because they were looking in the wrong locations. I tried to direct them to the correct locations but no matter what I did I either got problems with MOZILLA_FIVE_HOME or another file (can't recall exactly what it was ATM). I exported MOZILLA_FIVE_HOME and the other path (again can't recall) correctly, but still the other progs couldn't function at all and I still got the errors. I have no idea what causes it and why Mozilla-1.4 seems to have so many problems with plugins. Hopefully you'll get the help you need and this thread will be of use to others with similar issues.
 
Old 01-14-2004, 03:56 PM   #7
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I've got libstdc++-libc6.2-2.so.3 loaded on my system and I still can't get the plugins to work in Mozilla-1.4.

HOWEVER, I downloaded Mozilla Firebird (awesome btw) and installed all my plugins to the /usr/local/lib/MozillaFirebird/plugins directory and everything works as it is supposed to.

So, if anyone else is having this issue, check out Firebird as it's 10x faster than Mozilla anyway. :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install macromedia flash plugin skie_knite007 Linux - Software 4 03-17-2005 04:58 PM
How can I install Flash plugin for Mozilla1.4 chinaundead Mandriva 9 03-05-2004 06:13 AM
Install Flash plugin for Galeon Browser ejennings_98 Linux - Software 1 02-22-2004 09:29 PM
cant install FLASH plugin UKMan Linux - Newbie 6 06-09-2003 04:50 AM
mozilla flash plugin install malix Linux - Software 2 10-13-2002 07:13 PM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration