LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-22-2008, 04:19 AM   #1
L_Jenkins
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core 6
Posts: 21

Rep: Reputation: 15
flash not working in Firefox 3... Fedora 9 KDE 4


according to yum flash is installed fine...

Code:
[root@localhost ~]# yum install flash-plugin
Loaded plugins: refresh-packagekit
fedora                                                        | 2.4 kB     00:00
updates                                                       | 2.3 kB     00:00
adobe-linux-i386                                              |  951 B     00:00
Setting up Install Process
Parsing package install arguments
Package flash-plugin-9.0.124.0-release.i386 already installed and latest version
Nothing to do
[root@localhost ~]# /usr/lib/flash-plugin/setup
[root@localhost ~]# yum install firefox
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Package firefox-3.0.1-1.fc9.x86_64 already installed and latest version
Nothing to do
I read somewhere that it might not work if firefox is installed in some weird location but it seems to fine where it is. When I do aboutlugins flash doesn't show up on the list. I ran /usr/lib/flash-plugin/setup and got no error messages. I am stumped, whats the problem? Thanks in advance.
 
Old 07-22-2008, 04:30 AM   #2
emi_ramo
Member
 
Registered: Apr 2007
Location: Barcelona, Spain
Distribution: Debian, KUbuntu
Posts: 213

Rep: Reputation: 36
Flash won't run on a 64bit machine until you put it into a 32bit virtual machine: you'll need either ia32 or linux32 libraries and, for sure, run firefox over 32 bit, not 64!!

That's adobe's (internal) problem and the reason why I nearly hate them and I don't work with Flash: I'm a webdesigner, but this is a very nasty compatibility issue adobe's not going to correct.

You can try installing flock (not for the entire system, just for your user) and copying flash libraries to its plugin directory. That is my solution to watch youtube on my amd64.

emi
 
Old 07-22-2008, 06:32 AM   #3
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Try googling Nspluginwrapper ,lets you run x86 plugins on a x86_64 machine.
Works for me!
Regards
The trooper.
 
Old 07-22-2008, 07:35 PM   #4
L_Jenkins
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core 6
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by the trooper View Post
Try googling Nspluginwrapper ,lets you run x86 plugins on a x86_64 machine.
Works for me!
Regards
The trooper.
Thanks man, works great!

(edit) Logging in today flash doesn't seem to be working anymore. It is still installed but doesn't show up when I aboutlugins. I don't think I did anything, maybe firefox updated by itself, I am not sure. The nspluginwrapper is still working, or at least shows up on the aboutlugins. Any help would be great.

Last edited by L_Jenkins; 07-25-2008 at 08:08 PM.
 
Old 07-26-2008, 02:21 AM   #5
L_Jenkins
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core 6
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by L_Jenkins View Post
Thanks man, works great!

(edit) Logging in today flash doesn't seem to be working anymore. It is still installed but doesn't show up when I aboutlugins. I don't think I did anything, maybe firefox updated by itself, I am not sure. The nspluginwrapper is still working, or at least shows up on the aboutlugins. Any help would be great.
Ok I am having problems trying to fix this, I tried to remove the flash plugin and re-install it but I am having some problems doing it. I am obviously doing something wrong:

Code:
[root@localhost flash]# rpm -i flash-plugin-9.0.124.0-release.i386.rpm
        package flash-plugin-9.0.124.0-release.i386 is already installed
[root@localhost flash]# rpm -e flash-plugin-9.0.124.0-release.i386.rpm
error: package flash-plugin-9.0.124.0-release.i386.rpm is not installed
nspluginwrapper is working fine, but flash isn't showing up as being installed. Any help would be great.
 
Old 07-26-2008, 10:49 AM   #6
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
I am a little confused as to how you are doing things....
To start you were using the package manager:

Code:
root@localhost ~]# yum install flash-plugin
Loaded plugins: refresh-packagekit
fedora                                                        | 2.4 kB     00:00
updates                                                       | 2.3 kB     00:00
adobe-linux-i386                                              |  951 B     00:00
Setting up Install Process
Parsing package install arguments
Package flash-plugin-9.0.124.0-release.i386 already installed and latest version
Nothing to do
[root@localhost ~]# /usr/lib/flash-plugin/setup
[root@localhost ~]# yum install firefox
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Package firefox-3.0.1-1.fc9.x86_64 already installed and latest version
Nothing to do
And now it would appear you are trying to install an RPM package manually:

Code:
root@localhost flash]# rpm -i flash-plugin-9.0.124.0-release.i386.rpm
        package flash-plugin-9.0.124.0-release.i386 is already installed
[root@localhost flash]# rpm -e flash-plugin-9.0.124.0-release.i386.rpm
error: package flash-plugin-9.0.124.0-release.i386.rpm is not installed
Have you downloaded the package separately from the package manager?
Maybe this where the confusion is?
Try:

Code:
rpm -q flash-plugin
To see if the package is installed.
I would usually try to use the package manager for this sort of task.
Post if you need more help.
Regards.
The trooper
 
Old 07-26-2008, 06:37 PM   #7
L_Jenkins
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core 6
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by the trooper View Post

Have you downloaded the package separately from the package manager?
Maybe this where the confusion is?
Try:

Code:
rpm -q flash-plugin
To see if the package is installed.
I would usually try to use the package manager for this sort of task.
Post if you need more help.
Regards.
The trooper
Initially I tried to install the flash rpm from adobe manually with the rpm command, but that didn't work. Later I found out that I needed nspluginwrapper to make flash work with x86_64 and after I installed that manually with rpm's I think it didn't work at that point, and then I think I tried to use yum to install everything. I did something right and it actually worked for a day or so.

Now, nspluginwrapper shows up as a plugin but flash doesn't.

Code:
[root@localhost]# rpm -q flash-plugin
flash-plugin-9.0.124.0-release.i386
Not sure what the problem was, I was just trying to remove everything and install it again. Help would be greatly appreciated.
 
Old 07-27-2008, 03:24 AM   #8
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Code:
root@localhost]# rpm -q flash-plugin
flash-plugin-9.0.124.0-release.i386
This tells you that the package is installed.
Have you tried to remove it with Yum?
When i did this with Debian,i installed ia-32libs-gtk and nspluginwrapper via the package manager.
Then i installed the flash-plugin with the package manager.

It may be worth removing nspluginwrapper as well,and start again just using Fedora's package manager.
I think Livna is the multimedia repository,make that accessible to yum.
To sum up remove nspluginwrapper, and the flash plugin(rpm or yum)
Enable the Livna repository.
Install ia-32libs-gtk and nspluginwrapper with yum
Then install the flash plugin with yum.
It is generally good practice to use the package management system where possible.Only manually install packages if they are not available through a repository or if you need or want to compile from source.

Post how you get on.
Regards.
The trooper
 
Old 07-27-2008, 05:04 PM   #9
L_Jenkins
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core 6
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by the trooper View Post

It may be worth removing nspluginwrapper as well,and start again just using Fedora's package manager.
I think Livna is the multimedia repository,make that accessible to yum.
To sum up remove nspluginwrapper, and the flash plugin(rpm or yum)
Enable the Livna repository.
Install ia-32libs-gtk and nspluginwrapper with yum
Then install the flash plugin with yum.
It is generally good practice to use the package management system where possible.Only manually install packages if they are not available through a repository or if you need or want to compile from source.

Post how you get on.
Regards.
The trooper
I added the livna repository but I can't find ia-32libs-gtk anywhere. I removed the flash plugin and nspluginwrapper and added them but flash is still a no go.
 
Old 07-28-2008, 08:09 AM   #10
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Did some googling and found the following howto specifically for Fedora:

http://www.linuxheadquarters.com/how.../flash64.shtml

One more thought,Fedora 6 is quite old now so there will be a lot less packages available than for the current distribution.
It may be an idea to update to the latest version.
Sorry i can't be of more help!
Regards.
The trooper.
 
Old 07-31-2008, 12:25 AM   #11
L_Jenkins
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core 6
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for your help! I finally figured out what was wrong. I am not sure what auto-updated, either firefox or fedora, but it was autoupdating nspluginwrapper to the "newer" and "unstable" 1.1 version, which screwed everything up. Hopefully I can prevent this in the future. I don't know why it updates to a development snapshot but oh well, at least now I know... on to fixing audio in flash now! Thanks for the help.
 
Old 07-31-2008, 01:54 PM   #12
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Glad to hear you got it sorted in the end!
Regards.
The trooper.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound isn't working in Flash in Firefox in Fedora 9 nadavvin Linux - Desktop 4 07-17-2008 02:02 PM
attempted to manually install flash player for firefox in KDE fedora 9 mbvpixies78 Linux - Newbie 3 05-26-2008 06:29 PM
Sound not working with flash plugin for firefox vital_101 Linux - Software 2 08-01-2006 01:26 PM
help getting flash working in fedora 5 firefox. extendedping Linux - Software 2 07-01-2006 03:25 AM
Flash working on Mozilla, not on Firefox Maxwell Rain Linux - Software 1 07-17-2004 05:24 PM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration