LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-28-2003, 06:30 PM   #1
DGath
LQ Newbie
 
Registered: Jun 2003
Posts: 18

Rep: Reputation: 0
First time user can't get linux to boot. Locks on ETH0


Everything for RH9 installed with no problems and I've done two installs with the same results. The first install I used the default network settings and the second install I configured them manually. It goes through the bootloader just fine, and while it's initializing all the stuff, it continually gets stuck on...

Updating /etc/fstab [ok]
Setting network parameters: [ok]
Bringing up loopback interface: [ok]
Bringing up interface eth0: _

... and it freezes. A friend had this same problem but it loaded after about 5 minutes, but I let it sit there all day while at work, so about 8 hours and it never did anything. If you want to know I'm going though a linksys router with DHCP enabled o the router firmware and a cable modem internet connection from my cable company.

I'm doing another install right now with no ethernet connection settings enabled, hopefully this will work, but I'll definately need an ethernet connection at some point so does anyone know what's wrong?
 
Old 06-28-2003, 07:05 PM   #2
DGath
LQ Newbie
 
Registered: Jun 2003
Posts: 18

Original Poster
Rep: Reputation: 0
OK, well it worked after disabling the ethernet device eth0 and I'm in the gui now. So now the question is how do I enable that device, and not have my system hang everytime it restarts. If I enable it and it doesn't end up working,, basically I'm screwed and I'll have to restart because I won't be able to get back into the gui to disable it again, right?
 
Old 06-28-2003, 07:27 PM   #3
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
what ethernet card are you using perhaps it must be enabled in the kernel?
 
Old 06-28-2003, 08:36 PM   #4
DGath
LQ Newbie
 
Registered: Jun 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Hah, well it's built into my Dell Dimension Motherboard. It's a 3Com card though. I'd find out the exact model and stuff but I'm reinstalling linux once again.

If I go into the network settings I can enable the network card and everything works fine. I found out that when it says "Type I to enter interactive setup" during boot, I can tell it not to start the network stuff, I can boot, and later enable the network card, and everything works fine.

So yeah, just a pain in the ass that I wish I could make work.
Also, since this is my first time using Linux, is it rather unstable? I've had two sessions, each lasting about 5 minutes before the system freezes. Obviously that's not typical, but is Linux prone to crashing more than say... '98 SE? I had pretty good luck with that OS.
 
Old 06-28-2003, 08:39 PM   #5
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Very strange. It knows you got a network card cos it's asking you how you want it setup, you tell it dhcp it bombs out. Unless you got some weird network card try giving it a static IP Linksys probalby something like:


IP 192.168.1.100
Gateway 192.168.1.1
DNS whatever your DNS servers are

Although you shouldn't have to

Nope - RH9 is very stable......cdrom automount is a bit dodgy, only time I've found it suspect is with asmn windows clonemessenger which has to be kicked out now and again when it dies.

Last edited by Looking_Lost; 06-28-2003 at 08:42 PM.
 
Old 06-29-2003, 01:19 AM   #6
networqs
LQ Newbie
 
Registered: Jun 2003
Distribution: redhat
Posts: 2

Rep: Reputation: 0
eth0 startup

To answer your question you can enable and disable eth0 with this command /etc/rc.d/init.d/network restart this restarts your networking and initalizes the adapter generallt when eth0 hangs its because one of two things is happening on it can't get an ip and it keeps querying or second the driver you are using is not correct and it can initialize the hardware nic card try using tulip its generally a all purpose network card driver or if you can download the right driver for the card

to disable eth0 type /etc/eth0 down this will also shut it down

Hope this helps

Regards

Networqs
 
Old 06-29-2003, 10:41 AM   #7
DGath
LQ Newbie
 
Registered: Jun 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Well linux ran fine until I enabled eth0, and then it was only a few minutes before it crashed. So for whatever reason, it just does not like my ethernet card. Since it's built into my mobo, I just had to disable it in my BIOS. Since cards are only about $10 now I think I'll just buy one since I have plenty of PCI slots left too.

Don't know exactly why it has such a problem with it. For future reference in case anyone stumbles upon this same problem later on. I have a Dell Dimension 8100 P4 with the lan integrated.
 
Old 06-29-2003, 10:52 AM   #8
networqs
LQ Newbie
 
Registered: Jun 2003
Distribution: redhat
Posts: 2

Rep: Reputation: 0
linksys works really well with linux that's the type of network card I would recommend
 
Old 06-29-2003, 02:11 PM   #9
len
Member
 
Registered: Jun 2003
Distribution: slackware 14
Posts: 140

Rep: Reputation: 15
you should do some google searches on the specific NIC that you plan on buying, as some are problematic w/ linux. i've read that the linsys w/ the dec tulip chipset is recommended pretty highly. intel, and 3com chipsets are supposed to be good. some say the realtec chipsets are crappy, but seem to work well, and get id'd well. the realtec 8139, or the realtec 8100 series built into mb's seems to be good (at auto detection, and working). i have some older intel eepro 100b NIC's, and they are problematic- the newer are supposed to be good though.

i think that the netgear NIC's have different chipsets w/ the different model #'s, and even vary within the same series model #'s- after i read that after doing some google queries, i just avoided- too much of a crapshoot.

probably can't go wrong w/ linksys (most of the google searches returned that linux user's love the 'tulip' chipset- so it's good)- i just wonder when intel will discontinue the tulip chipset (hope they don't), as they own the rights to it from dec- something like a 3yr manufacturing obligation, after which they would do whatever w/ it (smart if they rename it, and just keep it).


a lot of the cheap NIC's on sale use the realtec 8139/ realtec 8139 clones though (and they work in linux).

you might even want to get a NIC that has a socket in it, as it will take a boot-rom, that can be configured to boot from lan (server farm prospects)- one of the variables that i consider, as things get swapped around and reconfigured- should that option ever get utilized, it is then there ready to go. just a thought though.

Last edited by len; 06-29-2003 at 02:15 PM.
 
Old 06-29-2003, 02:28 PM   #10
len
Member
 
Registered: Jun 2003
Distribution: slackware 14
Posts: 140

Rep: Reputation: 15
btw, there are two type of linksys ethernet cards available- if i remember correctly one will have the boot rom socket, and the other won't- get the one w/ the boot-rom socket. i think that it's that one that has the "tulip" chipset.
 
Old 06-29-2003, 05:48 PM   #11
cropcircle
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Red Hat Linux 9, FreeBSD 4.8, Knoppix 3.2
Posts: 182

Rep: Reputation: 30
DGath, can you post the output of "/sbin/lspci" on your Linux machine?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting eth0 at boot time ? Antonius Linux - Newbie 1 01-19-2005 07:27 PM
My linux locks up all the time. RHLinuxGUY Linux - General 7 12-23-2004 06:57 AM
eth0 causes looooong boot time mrsolo Linux - Software 10 11-07-2004 09:29 PM
howto disable eth0 at boot time rydogg Linux - Newbie 2 06-16-2003 09:33 AM
How to not init eth0 at boot time aldaeron Linux - Networking 4 08-07-2002 07:30 PM


All times are GMT -5. The time now is 11:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration