LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2009, 03:33 PM   #1
pr0n
LQ Newbie
 
Registered: May 2009
Posts: 13

Rep: Reputation: 0
first linux machine, ifconfig wireless issues


I've spent the last week reading up on linux networking tools and stuff and I've got some of the basics down.

What I'm trying to do is learn to analyze networks I'm starting at my workplace (computer repair shop) I'm using Ubuntu 9.04 (Jaunty Jackalope) the drivers are all whatever got automatically installed and seem to work perfectly for normal operation. the machine is an ASUS W2V notebook. the software is Wireshark, formerly known as ethereal.

the problem: my network tools GUI is showing hundreds of packets being received but none of them make it to wireshark (I haven't changed any filters anywhere) I think that my problem is that for some reason my wireless card has an IPv6 address assigned to it and I cannot change/alter/edit/delete/nullify it in any way no matter what I do and I think that the packets might be getting dropped because they don't match the IP. I've been reading and I understand that I need to have a null IP like 0.0.0.0 or in ipv6 ::1 or something of the sort and currently the address is stuck at fe80:blah:blah:blah

here is the error I get when trying to change the address

Code:
sudo ifconfig eth1 inet6 add <any valid ipv6>
siocsifaddr: Cannot assign requested address
can anyone help?
Thanks in advance


//edit: changing IPv4 address works flawlessly

Last edited by pr0n; 05-30-2009 at 04:04 PM.
 
Old 05-30-2009, 05:01 PM   #2
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Couple of things for Wireshark. You will need an ipv4 address. But I have not used IPV6 yet. so this is the first time I have seen this problem. But also make sure that if you want to see other peoples traffic you have a switch that can do port mirroring or you will need to do an arp cache poison.

To check for IPV6 type in the following
Code:
cat /proc/sys/net/ipv6/conf/all/disable_ipv6
0 = enabled
1 = disabled

if you see it enabled then do the following
Code:
sudo vim /proc/sys/net/ipv6/conf/all/disable_ipv6
change it to a 1 then :wq to save and quit.


I also saw some things about disabling it in the menu.lst or somewhere in grub.
 
Old 05-30-2009, 05:36 PM   #3
pr0n
LQ Newbie
 
Registered: May 2009
Posts: 13

Original Poster
Rep: Reputation: 0
to be honest I've tried and tried and tried more things than can remember to disable ipv6 but I read on another forum that in this version of ubuntu it's coded into the kernel rather than loaded in it's own package and cannot be disabled without compiling the kernel. I have read of someone that tried changing that 1 to a 0 (can't remember what finally worked) and after reboot it just goes right back and I've also read that that setting is only a returned value for browsers to refer to and doesn't actually function as a toggle. but I will try it.

results:
initial return value was 0
I couldn't get VIM to work it came up with a blank terminal with squigglies down the side and I can't type anything.
I tried
Code:
sudo 1 > /proc/.../disable_ipv6
and it returned permission denied.

would it be better for me to try a different distro? maybe a earlier version of ubuntu without the ipv6 built in?

Last edited by pr0n; 05-30-2009 at 05:40 PM.
 
Old 05-30-2009, 05:48 PM   #4
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
I would not. I would try to figure out how to disable it. I will have a ubuntu machine up soon so I will hopefully be of use and reply back with an answer. Currently all I have is a pcbsd machine
 
Old 05-30-2009, 05:59 PM   #5
pr0n
LQ Newbie
 
Registered: May 2009
Posts: 13

Original Poster
Rep: Reputation: 0
something else that might be useful info. my wired adapter doesn't EVER get a ipv6 address. but I connected to a university wi-fi and just let it auto assign everything. maybe it assigned an ipv6 address and once it gets one it just doesn't wanna let it go?
ifconfig eth1 returns both a ipv4 and ipv6 address assigned to the wireless

Last edited by pr0n; 05-30-2009 at 06:03 PM. Reason: meh
 
Old 05-30-2009, 06:45 PM   #6
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 516

Rep: Reputation: 177Reputation: 177
farslayer has a couple of links about disabling ipv6 in post #6 here.

I know it is Debian, but I would think that it would also work in Ubuntu.
 
Old 05-30-2009, 06:54 PM   #7
shpenat
Member
 
Registered: Dec 2008
Distribution: LFS
Posts: 95

Rep: Reputation: 21
Quote:
Originally Posted by pr0n View Post

I tried
Code:
sudo 1 > /proc/.../disable_ipv6
and it returned permission denied.
Is it a typo, or did you really used that? Correct should be
Code:
sudo echo 1 > /proc/.../disable_ipv6
 
Old 05-30-2009, 07:31 PM   #8
pr0n
LQ Newbie
 
Registered: May 2009
Posts: 13

Original Poster
Rep: Reputation: 0
nope not a typo but I tried it again with the correct way you listed and I get the same exact error

bash: /proc/.../disable_ipv6: permission denied
 
Old 06-01-2009, 12:39 PM   #9
pr0n
LQ Newbie
 
Registered: May 2009
Posts: 13

Original Poster
Rep: Reputation: 0
fixed: the connection has to have a valid ipv4 address (in use) before you can assign an ipv6 address
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linux box to talk to 98se machine and wireless ap s0ulburn26 Linux - Server 2 09-23-2007 09:19 AM
ifconfig reports wrong mac address and wireless doesn't work blackdragonblood Linux - Wireless Networking 7 04-15-2006 01:08 PM
Need help spoofing MAC address, ifconfig down seems to remove wireless card sicc Linux - Wireless Networking 0 11-30-2004 03:42 AM
Best wireless card for linux/windows machine 83K5 Linux - Wireless Networking 2 08-20-2004 01:19 PM
Looking for Wireless Network Card for Linux Machine MatthewASmith79 Linux - Hardware 4 06-18-2004 12:04 PM


All times are GMT -5. The time now is 10:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration