LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-19-2005, 10:58 AM   #16
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15

my sound works 100% in windows
so im pretty sure this is only a setup issue
draksound tells me what driver i am using
and its snd-emu10k1 [ALSA]

aumix and kmix look fine
lspcidrake reports: snd-emu10k1: creative labs|emuj10k2 audigy audio processor |MULTIMEDIA PROCESSPOR| (vender:1102 device 0004 subv:1102 subd:2002)
lspci reports: 02:09.0 Multimedia audio controller: SB Creative Labs Audigy (rev 04)

trying to play the sound from the console said that file and folder didnt exist
 
Old 11-19-2005, 12:11 PM   #17
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
probably not relevant http://www.mandrake.tips.4.free.fr/c...ration101.html
Just put that here because it has some ref to modprobe.conf, we may need to look into that

With konqueror try to locate some wav files
With MCC install play (if it is still there) if you got time

With draksound try to select driver snd-emu10k2 (if this exists)
otherwise use snd-emu10k1

What files are you trying to play?

Post (being root)

grep sound-slot /etc/modules.conf
/sbin/lsmod | grep snd
/sbin/chkconfig --list sound
/sbin/chkconfig --list alsa
aumix -q
/sbin/fuser -v /dev/dsp

BUT see http://qa.mandriva.com/show_bug.cgi?id=15652 where
In KDE Control center, go to Sound -> Sound system
uncheck [ ] disable sound server ....
in [Hardware] tab, check that ALSA is selected, apply and click on the sound
test.
In kmix check that digital output is disabled/unchecked
In Kmix I had to move the Master Output to Maximum and in Switches I had to
click on the Audigy Analog/Digi switch.
 
Old 11-19-2005, 12:46 PM   #18
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
With konqueror try to locate some wav files
i found 5 wav files in /usr/share/sounds
Quote:
With MCC install play (if it is still there) if you got time
i couldnt find any packages with that name

Quote:
With draksound try to select driver snd-emu10k2 (if this exists)
otherwise use snd-emu10k1
i couldnt find snd-emu10k2, there was a snd-emu10k1x though

Quote:
What files are you trying to play?
startup3.wav
pop.wav
mdvstartup.wav
shutdown1.wav
question.wav

they looked like they were playing just fine, i just couldnt hear anything


Quote:
Post (being root)

grep sound-slot /etc/modules.conf
/sbin/lsmod | grep snd
/sbin/chkconfig --list sound
/sbin/chkconfig --list alsa
aumix -q
/sbin/fuser -v /dev/dsp
i do not understand how i am supposed to pout this in the console
it gave me a file not found error with each one

Quote:
BUT see http://qa.mandriva.com/show_bug.cgi?id=15652 where
In KDE Control center, go to Sound -> Sound system
uncheck [ ] disable sound server ....
in [Hardware] tab, check that ALSA is selected, apply and click on the sound
test.
In kmix check that digital output is disabled/unchecked
In Kmix I had to move the Master Output to Maximum and in Switches I had to
click on the Audigy Analog/Digi switch.
there was no option to uncheck the disable sound server in sound system
i changed to ALSA and clicked on sound test and it did nothing
the switch for digital output was unchecked

Last edited by Xtife; 11-19-2005 at 12:48 PM.
 
Old 11-20-2005, 03:43 PM   #19
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15
bump

gah, linux is alot harder then i thought it would be
it takes less then a week to setup sound
 
Old 11-21-2005, 02:37 AM   #20
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
Quote:
i do not understand how i am supposed to pout this in the console
Type su (to become root in a console). Then the commands should run.

Sounds good that you have enabled alsa.
Keep to this snd-emu10k1 driver.

I am sorry the sound is not fixed yet. I know it is frustrating.
My theory is that it looks complicated at first, but this is to make
people learn a bit the inside of the OS.

Enabling alsa was a good move
Keep paying these wav files (do you use amarok to play them?)

Have you got a second audio card (onboard?)
 
Old 11-22-2005, 03:47 PM   #21
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15
np, no rush im not really planning to use linux as my main OS anytime soon
just wanted to learn how ot use it if i ever decide to in the future

i use amarok, and i dont have an onboard sound card

ill punch in those commands then
is there a way for me to copy+paste what it spits out?
i dont really feel like typing it all lol
 
Old 11-22-2005, 06:07 PM   #22
cormack
Member
 
Registered: Oct 2005
Location: Scotland, UK
Distribution: Kubuntu 9.10, ubuntu 8.04.2 server
Posts: 156

Rep: Reputation: 30
i have a sound problem like that in suse. full windowz support but none in linux. What window manager u using? i use KDE and that doesnt start my alsa sound on boot. Gnome does. so if u using KDE or even Flux, open a konsole and su password
the /etc/init.d/alsasound restart. Then close all sound apps, kaffeine mplayer juk amarok etc. then again as su /etc/init.d/alsasound restart then open a sound app, i use juk, and hopefully it will work.
Well that will seem quite stupid if it doesnt work but that a problem i have and thats how i get my sound working.

Ryan
 
Old 11-23-2005, 04:42 AM   #23
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
good point, another syntax is (once root)
service alsasound restart
or because it is mandy maybe just
service sound restart

you can also redo a configuration by typing
alsaconf

>>cut and paste
Select with the mouse the output in the terminal (left click all the time and select)
then go to firefox,
right click paste, or just press middle button of mouse
 
Old 11-23-2005, 04:16 PM   #24
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15
i still can not get any of those commands to work

i think i may give up on linux it was worth a try anyways
its just not worth the effort if im not oing to use this full time
 
Old 11-23-2005, 05:30 PM   #25
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
for these commands you need to be root
by typing
su
then the password

Did you try that?

Courage
 
Old 11-23-2005, 05:31 PM   #26
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15
i was already root to begin with it seems haha
ya they still dont work even in root
 
Old 11-24-2005, 02:43 AM   #27
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
sorry to make you go the keyboard way with the frustration that comes with it sometimes
So you are root

Type just ls (then enter)
Does it work?

Type just lsmod
Does it work?

if yes what about

lsmod | grep -i snd
then
lsmod | grep -i sound
 
Old 11-24-2005, 03:31 PM   #28
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15
i punched that in and got this
that paste thing helps big time haha

lsmod | grep -i snd =

snd_seq_dummy 3524 0
snd_seq_oss 33024 0
snd_seq_midi_event 6880 1 snd_seq_oss
snd_seq 51504 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 50368 0
snd_mixer_oss 17952 1 snd_pcm_oss
snd_emu10k1 119972 2
snd_rawmidi 21312 1 snd_emu10k1
snd_seq_device 7884 5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi
snd_ac97_codec 85180 1 snd_emu10k1
snd_pcm 83812 4 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_timer 22596 3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc 9384 2 snd_emu10k1,snd_pcm
snd_util_mem 4256 1 snd_emu10k1
snd_hwdep 7936 1 snd_emu10k1
snd 48644 14 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_codec, snd_pcm,snd_timer,snd_hwdep
soundcore 8256 1 snd

lsmod | grep -i sound =

soundcore 8256 1 snd
 
Old 11-25-2005, 03:12 AM   #29
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
/sbin/lsmod | grep snd
That looked good. You have learned something lots actually
Look good we now know you have the driver in memory

What about?

grep sound-slot /etc/modules.conf
chkconfig --list sound
chkconfig --list alsa
aumix -q
fuser -v /dev/dsp


If you want do know about these command you can type
man grep
man fuser
etc
 
Old 11-25-2005, 03:37 PM   #30
Xtife
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Original Poster
Rep: Reputation: 15
it wont let me post the info it spat out
siad i had to many images in it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hardware questions gravy Linux - Newbie 11 11-26-2005 03:17 PM
Hardware Questions k1ll3r_x Linux - Hardware 5 01-13-2005 06:56 PM
Have a few hardware questions PNGaaron Linux - Hardware 1 04-09-2004 12:31 AM
Hardware questions that_girl Linux - Newbie 1 04-06-2002 09:56 PM
Few hardware questions :) monolithix Linux - Newbie 1 04-13-2001 08:10 AM


All times are GMT -5. The time now is 10:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration