LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2004, 04:50 PM   #1
l1fe
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Rep: Reputation: 0
firefox won't start :(


Basically to install Firefox I did the following:

init 3, startx, ran the installer, installed into /usr/local/mozilla/firefox/ and everything seemed to work fine...

I then init 5, log back in as a normal user and when I try /usr/local/mozilla/firefox/firefox I get the following error:

*** loading the extensions datasource
Xlib: connection to ":0.0" refused by server
Xlib: XDM authorization key matches an existing client!

(firefox-bin:6228): Gtk-WARNING **: cannot open display:

Anyone know why this is? Or I create a soft link to /usr/local/mozilla/firefox/firefox and then when I click on it, the cursor looks like it's working but then nothing.

Any help would be appreciated...
 
Old 06-29-2004, 05:06 PM   #2
Systematic
Member
 
Registered: May 2004
Location: Mechanicsburg, PA
Distribution: Mainly Slackware, but test run various different distros.
Posts: 77

Rep: Reputation: 15
i found this on the justlinux forum.. not sure if it will help you or not... i dont think your issue is with firefox though.

Quote:
Thanks for the replies. I finally fixed the problem by combining all the advice I got from here. Here are the steps I followed:

1. As a normal user do a xhost + to allow anyone to connect to the local display.
2. become root using su -
3. Do an export DISPLAY=:0.0
4. Run the program
5. Grin like an idiot when it finally workes

I added export DISPLAY=:0.0 to root's .bashrc to allow it to always use the current display.
Thanks for the help.

- Suramya
the posting i grabbed that from for your reference is ... http://www.justlinux.com/forum/showt...hreadid=129320

Hope that helps.
 
Old 06-29-2004, 05:22 PM   #3
l1fe
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Original Poster
Rep: Reputation: 0
well that fixed the error message, although now I just get an infinite loop of "*** loading the extensions datasource"...and the shortcut doesn't work either. Thanks for the help though! That was some nice knowledge that I can no store away
 
Old 06-29-2004, 05:40 PM   #4
l1fe
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Just for more information, I can run the shortcut as root, but for obvious reasons, I don't want to always be logged in as root to be able to browse the net with my favorite browser. I really cannot figure out why I can't run it -_-;;

Oh, and I'm running SuSE 9.1
 
Old 06-29-2004, 05:46 PM   #5
BlueOrb
Member
 
Registered: Feb 2004
Distribution: Debian 3.1 "sarge"
Posts: 31

Rep: Reputation: 15
its something with your X Windows server refusing anything but root. when you are on this, are you or someone else logged in as root? cuz it says the auth key for X is in use..... you might want to check your x screen permissions
 
Old 06-29-2004, 06:35 PM   #6
l1fe
LQ Newbie
 
Registered: Jun 2004
Posts: 10

Original Poster
Rep: Reputation: 0
The auth key stuff has been fixed for now, but as I mentioned, I cannot run firefox regardless of this issue being resolved.
 
Old 06-29-2004, 09:39 PM   #7
Systematic
Member
 
Registered: May 2004
Location: Mechanicsburg, PA
Distribution: Mainly Slackware, but test run various different distros.
Posts: 77

Rep: Reputation: 15
when you installed it, did you install it while you were logged in as root.. have you checked the perms on the firefox folder.. may need to chown it so that your regular users can use it.. (thats a shot in the dark though)
 
Old 07-14-2004, 10:29 PM   #8
seland
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
Wink try this

Because of missing registration features in firefox 0.9.x you have
to start firefox as root the first time after installation.

If you get a message like
-----8<------------------snip--------------8<--------------
Xlib: connection to ":0.0" refused by server
Xlib: XDM authorization key matches an existing client!
----->8------------------snap-------------->8--------------

you have to disable the X authorization with command
'xhost +' and startup firefox.
After the initial startup you can close your X session
again by 'xhost -' and you should be able to start firefox
from now on without problems.
 
Old 07-29-2004, 04:09 PM   #9
DFossmeister
LQ Newbie
 
Registered: Jan 2003
Location: Richmond, VA
Distribution: Redhat 7.1-RHEL 4r2, Gentoo
Posts: 15

Rep: Reputation: 0
Talking firefox 0.9.1 and Fedora Core 2

I had all the same problems with loading extensions, and no fixes that I found worked. This included the RedHat site.

What I did finally that did work is:

install normally as root
watch it launch firefox the first time.
cp -R /root/.mozilla /home/mydir/
chown -R me.me /home/mydir/.mozilla

then it magically worked.

The problem for me seemed to be that it was trying to create directories and file in the /usr/lib/firefox directory where I had installed the app. However, as a normal non-privileged user, I did not have write permissions there.

DFossmeister
http://nonotagain.com/ - its whats for dinner!
 
Old 07-29-2004, 04:44 PM   #10
Corona4456
Member
 
Registered: Jul 2004
Distribution: SuSE 9.1
Posts: 66

Rep: Reputation: 15
I use SuSE 9.1 and installed firefox 0.9.1 without any problems... the directory I installed it to was /usr/local/firefox. Try this and see if it works:

chmod -R a+rx <firefox dir> and see if that helps

Last edited by Corona4456; 07-29-2004 at 04:46 PM.
 
Old 01-25-2006, 11:33 PM   #11
gary_wv
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
I had the same error after installing Firefox on my Debian system. I installed as root (using feta install mozilla-firefox). It worked as root, but not as another user.

Anyway, I found a simple solution that worked, after trying a few that didn't:

As the non-root user:

xhost +localhost

then try running firefox... twice. The second time and forever after, it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox won't start, no error Xandor Linux - Software 2 10-05-2005 05:04 PM
Can't start Firefox Ruben2 Debian 3 05-14-2005 05:15 AM
Firefox won't start rael_kid Linux - Newbie 6 03-19-2005 03:14 AM
Start firefox alb1954 Feather 3 10-03-2004 03:27 AM
How to start firefox? Daunted Linux - Software 26 10-02-2004 04:49 AM


All times are GMT -5. The time now is 07:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration