LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-21-2006, 06:41 AM   #1
anilbh
Member
 
Registered: Oct 2005
Location: India
Distribution: Proud User Fedora FC5/ Fedora 7 /Ubunt 7.10
Posts: 188

Rep: Reputation: 30
firefox profile ?


When firefox starts up I get a a box asking me to click on the profile to use .
Within firefox there is no mention of any profile . In Mozilla there is a switch-profile option... Is this fine ? Can switch the dialog box off ?
 
Old 02-21-2006, 08:53 AM   #2
Dtsazza
Member
 
Registered: Oct 2005
Location: Oxford, UK
Distribution: Debian Etch (w/ dual-boot XP for gaming)
Posts: 282

Rep: Reputation: 30
It sounds like Firefox didn't shut down cleanly at some time. Firefox does in fact have profiles, but unless you tell it to, it won't ask you about them and will just use the default one. However, when it's running it "locks" the profile to prevent two different instances of the browser both trying to change it at once - so that if you start up a separate instance of the browser (not just a new window!) this profile won't be available (as it's locked) and it will ask you which profile you want to use. When Fx exits, it removes the lock file, letting other instances use that profile again; so if it doesn't shut down properly, that profile stays locked and Fx gets confused on startup.

To solve this problem, you need only delete the lock file (which, by the way, is completely safe and side-effect-less):
Code:
rm ~/.mozilla/firefox/{random characters}.default/lock
(obviously replace '{random characters}' with the actual string - use ls or autocomplete to find it)
 
Old 02-21-2006, 09:53 AM   #3
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Rep: Reputation: 30
preform

Code:
killall mozilla-firefox
killall firefox
and re start firefox! ;]
 
Old 02-21-2006, 11:41 PM   #4
anilbh
Member
 
Registered: Oct 2005
Location: India
Distribution: Proud User Fedora FC5/ Fedora 7 /Ubunt 7.10
Posts: 188

Original Poster
Rep: Reputation: 30
Exclamation

And this has been happening for a long time .
Thank you
 
Old 02-22-2006, 03:05 AM   #5
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Rep: Reputation: 30
you succeded?
 
Old 02-22-2006, 09:31 PM   #6
anilbh
Member
 
Registered: Oct 2005
Location: India
Distribution: Proud User Fedora FC5/ Fedora 7 /Ubunt 7.10
Posts: 188

Original Poster
Rep: Reputation: 30
Talking

Yes . With a few problems . I deleted the one with .default and one with my name too . I finally got rid of it by clicking on "Don't ask at startup " Now I cannot get it back
 
Old 02-23-2006, 10:38 AM   #7
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Rep: Reputation: 30
I don't think it was necsery to delete it, I really though killall wouldhave been enough.

not sure though :S
 
Old 02-23-2006, 11:42 AM   #8
anilbh
Member
 
Registered: Oct 2005
Location: India
Distribution: Proud User Fedora FC5/ Fedora 7 /Ubunt 7.10
Posts: 188

Original Poster
Rep: Reputation: 30
I tried killall too . I dont think that worked...
 
Old 02-25-2006, 10:03 PM   #9
anilbh
Member
 
Registered: Oct 2005
Location: India
Distribution: Proud User Fedora FC5/ Fedora 7 /Ubunt 7.10
Posts: 188

Original Poster
Rep: Reputation: 30
Angry

Now I want to get back to the profile choice . The reason ... many things set up in a profile have vanished . Also the folders in Thunderbird . Of course it does not take much time to set that up . But I would like things back with the least work .
 
Old 02-25-2006, 10:05 PM   #10
anilbh
Member
 
Registered: Oct 2005
Location: India
Distribution: Proud User Fedora FC5/ Fedora 7 /Ubunt 7.10
Posts: 188

Original Poster
Rep: Reputation: 30
Question

Quote:
Originally Posted by Dtsazza
It sounds like Firefox didn't shut down cleanly at some time. Firefox does in fact have profiles, but unless you tell it to, it won't ask you about them and will just use the default one. ....
To solve this problem, you need only delete the lock file (which, by the way, is completely safe and side-effect-less):
Code:
rm ~/.mozilla/firefox/{random characters}.default/lock
(obviously replace '{random characters}' with the actual string - use ls or autocomplete to find it)
How does one tell Firefox to use profiles ?
The reason is that I lost some settings in Thunderbird , including the filters.

Last edited by anilbh; 02-26-2006 at 08:56 PM.
 
Old 02-27-2006, 12:34 AM   #11
anilbh
Member
 
Registered: Oct 2005
Location: India
Distribution: Proud User Fedora FC5/ Fedora 7 /Ubunt 7.10
Posts: 188

Original Poster
Rep: Reputation: 30
Thumbs up

Found the answer to this one.
If you want to activate/reactivate profiles . Look for the profiles.ini file in Thunderbird / Firefox directories . And set

StartWithLastProfile=0 ( Case sensitive ).

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
firefox complains about my profile being in use renna Linux - Software 4 02-02-2005 01:53 PM
Firefox - default profile in use stonecrest Linux - Software 3 11-13-2004 05:24 PM
profile problem in firefox taoweijia Linux - Software 2 07-16-2004 12:10 AM
Create Profile in Firefox raysr Linux - Software 6 05-01-2004 06:50 AM
Firefox profile object Fedora 2 02-18-2004 12:15 AM


All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration