LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-24-2013, 12:39 AM   #1
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Rep: Reputation: Disabled
firefox launcher doesn't show icon on panel bar of slackware but launcher still there


In Slackware 14.0, KDE, after upgrade, firefox launcher on the panel bar doesn't show icon. the launcher is still there but just plane and blank.
I can click on it to start up firefox.

This is a very small trivial but I don't wanna relegate Slackware for little nagging flaw.
so I want to fix it.

I removed firefox launcher from panel and create new one.
(run firefox and right click on its icon on panel and check on "Show A Launcher When Not Running")
Note that when firefox is running, icon is appearing on the panel.
then I close firefox, icon on the panel bar disappear.
but launcher is still there.
what is happening?

Last edited by mshlinux; 04-24-2013 at 03:29 AM.
 
Old 04-24-2013, 04:41 AM   #2
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
this little thing nagging me, eating my energy and throwing away my times.
many hours have been wasted to see again the little firefox icon on the kde panel of slackware.
but it is still missing.

Why does Slackware give me something nagging in every little pace?
Is it because I am stupid? Or other wise, what?

I dream to boast my friends how I can work with the most vanilla linux distribution and
how it is stable and simple.

But at this moment, I have realized that the day I can be proud with slackware is still far far far away....
 
Old 04-24-2013, 05:30 AM   #3
mddesai
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch
Posts: 479

Rep: Reputation: 132Reputation: 132
i too did get the same problem. but my distro is CentOS. i resolved the problem by changing to some other theme, and once theme is changed, i changed back to the original theme again. the problem is gone.

but don't know if it works for Slackware....

Last edited by mddesai; 04-24-2013 at 05:40 AM.
 
Old 04-24-2013, 10:45 AM   #4
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
yes, I tried it, but doesn't work.
thank you for your post.

---------- Post added 04-24-13 at 10:45 AM ----------

this little bug shitting meeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
 
Old 04-24-2013, 02:34 PM   #5
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Ubuntu 14.04
Posts: 545

Rep: Reputation: 130Reputation: 130
Have you tried going through the KDE menu, and right clicking Firfox and selecting the entry to have it on your task bar? It always has worked for me.
 
Old 04-24-2013, 04:33 PM   #6
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Slack14_64_Multilib
Posts: 3,076
Blog Entries: 4

Rep: Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745
switch themes.
 
Old 04-24-2013, 10:56 PM   #7
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Original Poster
Rep: Reputation: Disabled
I got a solution, I'm not very sure it is root and proper or not though.

Before I ran "slackpkg upgrade-all", Konqueror was default web browser.
I couldn't remove its launcher icon permanently from the panel because it is default web browser.
(Konqueror launcher icon appear again after reboot, although it was previously removed from panel)
But I usually used firefox putting its launcher icon on the panel.
(without setting as default)
This was the situation before I run "slackpkg upgrade-all".

When I ran upgrade, it upgraded firefox from the version 15.something to 20.0.
The point is here,
it seems that firefox took up as default web browser in upgrade process.
But it was possibly in improper way.
So, the system still knows the default web browser is Konqueror.
But, on the panel, the default browser is firefox.
That's why, after reboot, the panel appears with a blank at the place of default browser.
But a launcher is there without icon so that I can click on it to start up firefox.

Ok! my solution is this:
go to System Setting > Default Application > Web Browser and chech on "in the following browser".
and then chose "mozilla-firefox" in the box below.
then click on "apply" button and reboot system.
after reboot process, okkkkk! the panel appears with the firefox icon at the place of default browser.
that's all I did.
My tech knowledge is very poor.
So my conclusion may be wrong and
my solution may not be solving the root of the problem.

thank all for help thinking my problem.

Last edited by mshlinux; 04-24-2013 at 11:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to create a desltop launcher and how to add a "show desktop" icon in 12.04 LTS? unixor Ubuntu 4 04-16-2013 09:48 AM
Launcher Problems! Why is there a line through my icons on my launcher? LinuxNoob12 Linux - Newbie 1 10-26-2012 01:37 AM
Want To Restore Quick Launcher Icon For Firefox tb75252 Slackware 1 07-02-2012 07:37 AM
[SOLVED] How do i change the firefox/ice weasel launcher icon, kde Knightron Linux - Newbie 5 10-10-2011 03:02 AM
Shutdown Panel Launcher Icon change SChipS Suse/Novell 3 06-02-2008 05:53 AM


All times are GMT -5. The time now is 08:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration