LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2007, 07:35 PM   #1
Gilrad
LQ Newbie
 
Registered: Feb 2007
Posts: 19

Rep: Reputation: 0
Finally have Linux rolling... How do I get drivers to work?


So after much hardship with Grub (kept getting Error 18 whenever I manually modified the partition table, decided to let Ubuntu handle it and it worked), I finally have Linux up and rolling.

Only problem is... I have no sound, and my screen is stuck at 800x600. For my soundcard (Sound Blaster Audigy 2 ZS), no linux drivers exist, and for my video card (ATI All in Wonder X800), I get the following error message whenever I try to run the auto intaller I downloaded from the site:

"gedit has not been able to detect the character coding.
Please check that you are not trying to open a binary file.
Select a character coding from the menu and try again."


So I'm a total newbie at Linux. If I download drivers made for Linux, shouldn't they run?
 
Old 02-08-2007, 07:51 PM   #2
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
Yes, they should, assuming that both the executable installer you download is set to allow execution, and that your file manager isnt trying to open that binary file as a text file, which it is....

First, change permissions on the file to allow it to be executed, then try again. Permissions is probably somewhere in the "properties" menu when you bring up that menu on the file, right click i think its called?
 
Old 02-08-2007, 07:56 PM   #3
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 42
Since your running ubuntu and me unable to find a .deb package on the ati/amd site for X800 all-in-wonder, i guess you have downloaded the .run file and NOT one of the .rpm files.

If you did download one of the 2 rpm files.. delete them.
If you have downloaded the .run file your ok!

Open up a terminal, cd to wherever the .run file is located.
and type:

sudo sh ./ati-driver-installer-8.32.5.run (press enter).

This will prompt for password, when entering password and pressing enter it'll start the installation! Now a nice GUI will pop-up to aid you in your installation.


For your sound card, i'd suggest checking wether ALSA has been installed, since the card is supported by it.
 
Old 02-08-2007, 08:08 PM   #4
jonnycando
Member
 
Registered: Nov 2006
Location: Virginia
Distribution: OpenSuSE 10.2
Posts: 121

Rep: Reputation: 15
To my knowledge there are no Sound Blaster drivers. But the Alsa drivers support Audigy nearly perfectly. I have one myself, and it was only a matter of tinkering with the settings. See that your package manager has installed them and if not make it do so. THey should function immediately on install.
 
Old 02-08-2007, 08:29 PM   #5
Gilrad
LQ Newbie
 
Registered: Feb 2007
Posts: 19

Original Poster
Rep: Reputation: 0
Okay, it looks like the drivers were installed, but I don't think they were. I am still stuck at 800x600, and whenever I try to launch the ATI control program from my applications menu, I get an error that says "Failed to execute child process "fireglcontrolpanel" (No such file or directory)"

Also, when I tried installing it, I got these errors in the terminal:
cp: cannot stat `x710/usr/X11R6/bin/*': No such file or directory
find: install/usr/bin/fireglcontrolpanel: No such file or directory

edit-In the graphical install screen, I have two options. One is to install the driver on Unknown X Window, the other to generate distribution specific package. I have only tried the first selection, because the second selection goes to a window that is too long for me to be able to see everything in 800x600, and I am unable to scroll or otherwise see all the items on the list.

Last edited by Gilrad; 02-08-2007 at 08:36 PM.
 
Old 02-08-2007, 10:07 PM   #6
Gilrad
LQ Newbie
 
Registered: Feb 2007
Posts: 19

Original Poster
Rep: Reputation: 0
Okay, so I found out that I need to edit xorg.conf in order to get things working. How do I enable access to modify the file?
 
Old 02-08-2007, 10:20 PM   #7
sumguy231
Member
 
Registered: Apr 2004
Location: North America
Distribution: Kubuntu 7.04 - Feisty Fawn
Posts: 296

Rep: Reputation: 30
Quote:
How do I enable access to modify the file?
You need to have root privileges. Run 'gksudo gedit /etc/X11/xorg.conf' and type your password into the prompt to edit it. Be careful, though. I suggest you back it up first.
 
Old 02-08-2007, 10:28 PM   #8
jonnycando
Member
 
Registered: Nov 2006
Location: Virginia
Distribution: OpenSuSE 10.2
Posts: 121

Rep: Reputation: 15
you need to be root to edit it. In terminal type su and then provide the root password. You will be given the root prompt. You then can navigate to /etc/X11 and view and edit the various versions of xorg.conf that are there. There may be several but they all have modified filenames so as not to be confused with the one that boots the Xserver. Whenever you make a new xorg.conf copy your old one first to xorg.conf.todaysdate or something like that so if your new one won't run you can easily go back to square one. You can also try the others in there by renaming them to xorg.conf after you have backed up the one that works as I said. If you have sax2 you can run it and it will autodetect your setup and suggest a base setting which you can accept as is or tweak. Do try that if you have it. And if you use it sax2 will also make a back up of your last xorg.conf, calling it xorg.conf.saxsave or such.

Last edited by jonnycando; 02-08-2007 at 10:30 PM.
 
Old 02-09-2007, 12:29 AM   #9
sumguy231
Member
 
Registered: Apr 2004
Location: North America
Distribution: Kubuntu 7.04 - Feisty Fawn
Posts: 296

Rep: Reputation: 30
Quote:
In terminal type su and then provide the root password.
The OP is using Ubuntu, so 'su' isn't going to work unless they set a root password.
 
Old 02-09-2007, 03:33 AM   #10
biniou
Member
 
Registered: Feb 2007
Location: Belgium
Distribution: Ubuntu (7.04), (B)LFS (6.2), ...
Posts: 105

Rep: Reputation: 15
A quick search in HCL shows that this card work perfectly fine with Linux using driver snd-emu10k1 ...

Check in alsamixer that output is not muted by default ...
 
Old 02-09-2007, 09:49 AM   #11
IndyGunFreak
Senior Member
 
Registered: Aug 2003
Location: Indpls
Distribution: Laptops: Linux Mint 18 XFCE, Debian Jessie XFCE, NAS: OpenMediaVault
Posts: 1,304

Rep: Reputation: 56
Quote:
Originally Posted by Gilrad
So after much hardship with Grub (kept getting Error 18 whenever I manually modified the partition table, decided to let Ubuntu handle it and it worked), I finally have Linux up and rolling.

Only problem is... I have no sound, and my screen is stuck at 800x600. For my soundcard (Sound Blaster Audigy 2 ZS), no linux drivers exist, and for my video card (ATI All in Wonder X800), I get the following error message whenever I try to run the auto intaller I downloaded from the site:

"gedit has not been able to detect the character coding.
Please check that you are not trying to open a binary file.
Select a character coding from the menu and try again."


So I'm a total newbie at Linux. If I download drivers made for Linux, shouldn't they run?
Can't help with your sound problem, but in the thread below, follow Redeye2's instructions, that helped me with the resolution problem.... Probably won't fix your driver issue either, but I've never bothered installing the ATI driver for my video card, and all works perfectly.

http://www.linuxquestions.org/questi...d.php?t=495248

IGF

Last edited by IndyGunFreak; 02-09-2007 at 09:52 AM.
 
Old 02-09-2007, 04:03 PM   #12
jonnycando
Member
 
Registered: Nov 2006
Location: Virginia
Distribution: OpenSuSE 10.2
Posts: 121

Rep: Reputation: 15
Quote:
Originally Posted by sumguy231
The OP is using Ubuntu, so 'su' isn't going to work unless they set a root password.
Hmm, did not know Ubuntu was so loose with it's rules. Oh well.
 
Old 02-09-2007, 06:13 PM   #13
sumguy231
Member
 
Registered: Apr 2004
Location: North America
Distribution: Kubuntu 7.04 - Feisty Fawn
Posts: 296

Rep: Reputation: 30
Quote:
Hmm, did not know Ubuntu was so loose with it's rules. Oh well.
It's not 'loose' per se, but just uses sudo by default with no root password and one sudoer. I don't own a Mac, but if I remember correctly, it's like the Mac OS X security model.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Swiss developers start rolling Your Own Linux Distribution LXer Syndicated Linux News 0 08-25-2006 04:21 PM
Finally got the nvidia drivers working! BinJajer LinuxQuestions.org Member Success Stories 2 02-11-2006 03:55 AM
I finally got it to work but... Rick069 Fedora 1 09-27-2005 07:31 AM
Finally got MySQL to work...BUT! Kyl3 Slackware 4 07-09-2004 01:01 PM
finally got the ATI drivers working in 9.2... trey85stang Mandriva 2 12-01-2003 12:46 PM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration