LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-26-2006, 08:16 PM   #1
Misfit138
Member
 
Registered: Mar 2006
Location: Jersey
Distribution: Arch
Posts: 38

Rep: Reputation: 15
Filesystem mounted as read-only? Why? How?


Neither my grub/menu.lst nor my fstab seem to be in error (as far as I can tell) but I got a forced FSCK, (after 39 boots)and it fails because my filesystem is mounted as read only.
I am not sure what is telling it to mount as read only, though, any ideas? On boot up I see a message like 'kinit mounting readonly', and when I change it back (mount -n -o remount,rw /) and reboot, I see a message scrolling down saying that it is being re-mounted as read only again!
What am I doing wrong?

here is my fstab (note-I had to change hdc1 to 0 0 to get around the forced fsck temporarily)

# /etc/fstab: static file system information
#
# <file> <dir> <type> <options> <dump> <pass>
none /dev/pts devpts defaults 0 0
none /dev/shm tmpfs defaults 0 0

/dev/cdrom /mnt/cd iso9660 ro,user,noauto,unhide 0 0
/dev/dvd /mnt/dvd udf ro,user,noauto,unhide 0 0
/dev/fd0 /mnt/fl vfat user,noauto 0 0

/dev/hdc1 / ext3 defaults 0 0
/dev/hdc2 swap swap defaults 0 0
/dev/sda1 /mnt/hd1 auto user 0 0

here is my menu.lst

# (0) Arch Linux
title Arch Linux
root (hd0,0)
kernel /boot/vmlinuz26 root=/dev/hdc1 vga=773
initrd /boot/kernel26.img

I remember after my initial system update, I got a kernel panic error, but got around it by changing initrd.img to kernel26.img....could this be related?

Last edited by Misfit138; 11-26-2006 at 09:18 PM.
 
Old 11-26-2006, 08:58 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
i dont use grub but youll notice in the second last line of your menu.lst at the end of the line is 'ro' for, i assume read-only. maybe change that?
i dont remember the boot process but i know it starts as read only then remounts it read-write.. can you be more specific about what is the problem? ie error messages? does the system not fully boot?
 
Old 11-26-2006, 09:23 PM   #3
Misfit138
Member
 
Registered: Mar 2006
Location: Jersey
Distribution: Arch
Posts: 38

Original Poster
Rep: Reputation: 15
Well, i can get around it by pressing ctrl-D, but I am uncomfortable leaving it alone since the fsck tells me there's something wrong, I guess. I have had fsck on my other linux boxes and they never fail for being 'mounted as read-only'....so I was wondering where the configuartion setting for this might be located, and if I might be able to tweak it so that it passes the fsck..? I know I must have done SOMETHING wrong, but I just don't know what.

BTW- I took out the 'ro' from my /boot/grub/menu.lst, but it still complains.
 
Old 11-26-2006, 09:31 PM   #4
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
again never used grub--do you have to run a command after you change its configuration for it to use this new configuration, as needed with lilo?

would you be able to download a small live cd such as DSL (50mb) or other and mount it read-write and do fsck on it then?
 
Old 11-26-2006, 09:50 PM   #5
Misfit138
Member
 
Registered: Mar 2006
Location: Jersey
Distribution: Arch
Posts: 38

Original Poster
Rep: Reputation: 15
Well, the system seems fine, I just don't know where else to look.

The exact error is this:

fsck failed. Please repair manually and reboot. Please note that the root file system is currently mounted read-only.
To remount it read-write:

# mount -n -o remount,rw /

CONTROL-D will exit from this shell and REBOOT the system.
 
Old 11-26-2006, 10:02 PM   #6
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,133

Rep: Reputation: 320Reputation: 320Reputation: 320Reputation: 320
The fsck program should never fail because the filesystem is mounted read-only. In fact, it's a really bad idea to run fsck on a writeable filesystem so it pretty much has to be mounted read only or not mounted at all for a safe fsck.

It sounds like the automatic fsck done by init is failing. After it falls to the shell and making sure the root filesystem is indeed mounted read only try running:

fsck -C /dev/hdc1

(assuming hdc1 is your root partition as posted above).

This will hopefully complete successfully and you can type "init 3" to get back up to full mulriuser mode with the filesystems mounted read-write.
 
Old 11-27-2006, 06:27 AM   #7
Misfit138
Member
 
Registered: Mar 2006
Location: Jersey
Distribution: Arch
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by btmiller
The fsck program should never fail because the filesystem is mounted read-only. In fact, it's a really bad idea to run fsck on a writeable filesystem so it pretty much has to be mounted read only or not mounted at all for a safe fsck.

It sounds like the automatic fsck done by init is failing. After it falls to the shell and making sure the root filesystem is indeed mounted read only try running:

fsck -C /dev/hdc1

(assuming hdc1 is your root partition as posted above).

This will hopefully complete successfully and you can type "init 3" to get back up to full mulriuser mode with the filesystems mounted read-write.
Took a while, but yeah, it worked! Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I have: Root has Read-Write, user has read only for the boot filesystem? xmrkite Linux - Software 6 10-16-2008 04:31 AM
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 12:17 PM
Mounted as Read-only filesystem (fat32) on fc4 robinp Fedora 4 04-21-2006 07:24 AM
NFS: a mounted to b, b mounted to c, c can't read a? Steve Cronje Linux - Networking 9 10-25-2004 09:51 AM
Fs mounted in Read Only , Read Write Mode benjaminrtz Linux - General 2 07-31-2002 02:52 AM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration