LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-12-2011, 01:02 AM   #1
prepian
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Rep: Reputation: Disabled
Thumbs up Filename problems


I am a newbie.
I have just recently started using Lucid Lynx. I have files created in Windows 98 and later which I still need to access. Some of of the files have extended Latin characters in them, like tilde and cedillas. Examples of the filenames are:

Do˝a_Clara.doc
Fašade.doc

When listed in Thunar, the filename becomes

Do�a_Clara.doc
Fa�ade.doc

This presents a problem because I sometimes need to access the same files from a Windows machine.

If I rename the files in Thunar (or any Linux file browser), the filename becomes unreadable in Windows.

If say I rename a file in Thunar to read as Do˝a in Linux
when accessed in Windows explorer it becomes - Do├▒a

I know that my final option is to remove all European characters in my filenames.
I want to know if there is a solution to this.
And also why it happens.

I would appreciate any help this.

Thank you.
 
Old 07-12-2011, 03:12 AM   #2
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Hi Prepian and welcome to this forum.

Unfortunately I don't know the answer to your problem, but have you tried adding locales to your installation? I'm not familiar with Lucid Lynx (is that an Ubuntu version?) so can't tell you how.

Try starting a new thread asking about installing different locales.

Tom
 
Old 07-12-2011, 05:13 AM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Cˇrdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
If the files live in a fat or ntfs volume, the key is mounting it using the correct encoding settings. What kind of fs is it, then?
 
Old 07-12-2011, 10:32 PM   #4
prepian
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you for replying

@ tommyttt - Lucid Lynx is the 2010 release of Ubuntu

@ i92guboj - I'm accessing files in ntfs and fat32. Part of my hard disk is in ntfs & fat32 and my back-up external disk is in fat32. How do I set the encoding settings when mounting? The external drive mounts when I plug it in - and I just begin to use it. I think your reply is getting me nearer to the solution
 
Old 07-13-2011, 02:38 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,957

Rep: Reputation: Disabled
The built in disk is mounted using the directives in /etc/fstab. For the basic information how this is handled read
Code:
man fstab
man mount
the latter with particular reference to the mount options for fat / ntfs file systems.

The external disk is another thing again. I suppose it is an USB drive. Those are handled by udev. Again a lot to read:

http://www.reactivated.net/writing_udev_rules.html
http://gentoo-wiki.com/HOWTO_Customizing_UDEV
http://linuxcommand.org/man_pages/udev8.html
http://ftp.kernel.org/pub/linux/util...tplug/udev-FAQ

HTH
 
Old 07-13-2011, 04:19 AM   #6
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Cˇrdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Quote:
Originally Posted by prepian View Post
@ i92guboj - I'm accessing files in ntfs and fat32. Part of my hard disk is in ntfs & fat32 and my back-up external disk is in fat32. How do I set the encoding settings when mounting? The external drive mounts when I plug it in - and I just begin to use it. I think your reply is getting me nearer to the solution
The man page for mount is the first thing you should be reading. Specially the mount options for vfat (and more specifically "iocharset" and "codepage") and those for ntfs ("nls" and "utf8"). However, for ntfs you should be using ntfs3g instead of the in-kernel ntfs driver, which will probably fix all your problems.

Once you can mount the fs by hand (using the mount command) and everything is ok, it is time to start looking at how your distro automounts the volumes, and see how we can change the default mount options.
 
Old 07-13-2011, 09:32 AM   #7
prepian
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
again thank you for the replies. I will start reading up on the links sent by JZL240I-U

I guess I'll have to get my hands wet. I've just mainly used Lucid Lynx out of the box and been hapy about it.
 
Old 07-13-2011, 09:33 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,957

Rep: Reputation: Disabled
Quote:
Originally Posted by prepian View Post
...
I guess I'll have to get my hands wet
...
Good for you . Learning is fun. Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Special chars on filename problems with Centos and Apache jmandrak Linux - General 6 07-21-2009 08:37 PM
Change name of backup file in ext3 from filename~ to .filename~ Libu Linux - General 2 07-21-2008 10:29 PM
Convert static library (Filename.a) to dynamic shared object (filename.so) afx2029 Linux - Software 4 08-17-2007 07:07 AM
rsync and FAT32 problems (filename case-sensitive) apachedude Linux - Software 5 01-21-2006 08:20 PM
change uploaded files from filename.avi to filename.avi.html like www.rapidshare.de latheesan Linux - Newbie 3 06-16-2005 05:33 AM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration