LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2005, 11:13 AM   #1
ditch*
Member
 
Registered: Jul 2004
Posts: 50

Rep: Reputation: 15
file-system compatible with Linux/Windows


Hej!


I have Win2000 and VectorLinux installed on my computer.

And I need to have a drive that both systems recognise.

Right now I have an 8.5 GB drive that has FAT 32 as its filesystem.

It works well with Windows, but I can't do anything with it on Linux.


... When I mount the drive on linux, I can see all the files on the drive, but I can't execute them. I can't move them either. And I can't put anything onto the drive.


the command I use (as a superuser) is:

mount -t vfat /dev/hda2 /mnt/windows



So is the filesystem totally incompatible?
- And I should reformat the drive and use a totally different FS

Or do I have to play around with Linux first and get away with not messing with the drive itself

Or should I just simply format the drive as FAT 32 in Linux. And then hope that Windows recognises it?


Thanks !!

Grisha.



PS: The error message I get in Linux when I try to do something with the files on that drive is: File system not supported

PPS: When I open the drive, the folders are not recognised as directories, but rather like other files.
 
Old 03-03-2005, 11:24 AM   #2
Stealth870
Member
 
Registered: Dec 2004
Posts: 57

Rep: Reputation: 15
Thats strange, iirc Fat32 is perfectly compatible with both. It must be something with mounting then. I know Knoppix is able to edit my FAT32 USB key, and so can Windows
 
Old 03-03-2005, 11:28 AM   #3
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
Hello,

This set up is perfectly possible - I have the same thing on my pc and it runs fine...

Can i see your /etc/fstab?

show me yours and I'll show you mine....

Seriously, It sounds like there might be a problem with the formatting of the drive or the way Linux is addressing it.

I'm not sure why you can't write to it - but it may have something to do with the umask setting on your system - don't forget FAT32 can't have permissions (genius!!!).

Code:
/dev/hda9        /fat-e           vfat        auto,gid=100,umask=000   1   0
That's mine - as you can see it gives everyone open access to the partition. I don't really need the gid=100 (group ID) do I. But I guess don't fix what's not broken...

Anyway, I suspect it's not that - but i wanted to eliminate it.........


Other than that is the FAT32 file system properly supported in your Kernel? I guess so or you would not even be able to see the files - but check it out if you formatted the disk yourself..........
 
Old 03-04-2005, 02:28 AM   #4
ditch*
Member
 
Registered: Jul 2004
Posts: 50

Original Poster
Rep: Reputation: 15
... I have just realised that, weirdly enough, I can mount my FAT 32 USB flash-disk in both Linux and Windows...

anyway, here goes /etc/fstab:

# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system> <mount point> <type> <options> <dump> <pass>
#
# dump(8) uses the <dump> field to determine which file systems need
# to be dumped. fsck(8) uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# This is a root linux ext2 partition:
/dev/hda4 / ext2 defaults,errors=remount-ro 0 1

# This is a linux ext2 partition:
#/dev/hda2 /mnt/linux ext2 defaults 0 2

# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/fd0 /mnt/floppy subfs fs=vfat:ext2,rw 0 0
#/dev/fd1 /mnt/floppy auto defaults,noauto,user 0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
#/dev/hdd /mnt/ls120 auto defaults,noauto,user 0 0

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de /mnt/nfs nfs defaults 0 0

# proc file system:
proc /proc proc defaults 0 0
none /sys sysfs defaults 0 0


# Unix98 devpts filesystem:
none /dev/pts devpts gid=5,mode=666 0 0

# Shared memory filesystem:
#none /var/shm shm defaults 0 0
# Basic USB filesystem
usbdevfs /proc/bus/usb usbdevfs defaults,noauto 0 0

# For dos partition use type 'msdos'.
# For win95/98 fat16 or FAT32 partition use type 'vfat'.

# The 'sw' option indicates that the swap partition is to be activated
# with 'swapon -a'.
/dev/hda3 none swap sw 0 0

# Swap file:
#/swap none swap sw 0 0

/dev/cdrom /mnt/cdrom subfs fs=auto,user,ro 0 0



Thanks !!!
 
Old 03-04-2005, 02:42 AM   #5
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
Well, I'm so glad i use slackware. What kind of file is that :-S

I presume it's SuSE.

Anyway, it's pretty clear that there is no mention of your FAT32 partition in /etc/fstab....

Add this line to your /etc/fstab
Code:
/dev/hda2        /mnt/windows           vfat        auto,gid=100,umask=000   1   0
Then run mount -a

Does that make any difference.....
 
Old 03-04-2005, 08:33 AM   #6
ditch*
Member
 
Registered: Jul 2004
Posts: 50

Original Poster
Rep: Reputation: 15
YES !

It works !

Thank you ever so much !

Best,

Grisha.
 
Old 03-04-2005, 08:35 AM   #7
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
Okay that's good.

I hope you understand why....

Umask sets default permissions - 000 translates to 777

You're /etc/fstab file wasn't set up properly basically........
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
File system for both Windows and Linux nonoitall Linux - Newbie 6 11-16-2005 11:33 AM
opening linux file system files in windows 95?? timefortea General 6 08-26-2005 01:28 PM
Access linux file system from windows.... johncsl82 Linux - Newbie 2 06-19-2004 10:16 AM
viewing windows XP file system through linux aymbpc Linux - Newbie 3 08-31-2003 07:41 PM
Linux File System & Windows atko Linux - Newbie 3 02-07-2003 03:20 AM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration