LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2012, 08:31 AM   #1
nsblenin
LQ Newbie
 
Registered: Aug 2012
Posts: 4

Rep: Reputation: Disabled
File owner nobody


Hello

I'm using a ssh to access to a server hosting. I wanted to delete some directories but I realized that i could not delete some files because the owner of those file is "nobody". I wanted to change the owner using chown but I have no permission to do this:


-rw-r--r-- 1 nobody nobody 0 Jun 16 2010 shipped.txt
-rw-r--r-- 1 nobody nobody 493 Jun 16 2010 test.html
-rw-r--r-- 1 nobody nobody 72 Jun 16 2010 test.txt
-rw-r--r-- 1 nobody nobody 1634 Jun 16 2010 voucher.html
-rw-r--r-- 1 nobody nobody 421 Jun 16 2010 voucher.txt
-jailshell-3.2$ rm voucher.txt
rm: remove write-protected regular file `voucher.txt'? y
rm: cannot remove `voucher.txt': Permission denied
-jailshell-3.2$ chown s10889c1 voucher.txt
chown: changing ownership of `voucher.txt': Operation not permitted
-jailshell-3.2$

Should I contact with the administration staff? Thank you
 
Old 08-10-2012, 09:21 AM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,580
Blog Entries: 14

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
Is this an NFS mount? Run "df -h ." on the directory the files are in to see what it is mounted from. If you see an IP or hostname followed by a colon then it is an NFS mount. With NFS the filesystem has to be exported to explicitly allow root to do things - by default root isn't allowed to do things.

If it is an NFS mount and you have access to the system shown before the colon by hostname or IP you should login to that system and delete the files there. Also it is possible that a NON-root user login on the host on which you became root DOES have the ability to delete files. You might want to try a NON-root login instead of root.
 
Old 08-10-2012, 09:28 AM   #3
nsblenin
LQ Newbie
 
Registered: Aug 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
-rw-r--r-- 1 nobody nobody 421 Jun 16 2010 voucher.txt
-jailshell-3.2$ fd -h
-jailshell: fd: command not found
-jailshell-3.2$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 996M 660M 284M 70% /lib
/dev/root 996M 660M 284M 70% /sbin
/dev/root 996M 660M 284M 70% /opt
/dev/root 996M 660M 284M 70% /lib64
/dev/root 20G 11G 7.7G 59% /usr/lib
/dev/root 20G 11G 7.7G 59% /usr/lib64
/dev/root 20G 11G 7.7G 59% /usr/sbin
/dev/root 20G 11G 7.7G 59% /usr/share
/dev/root 20G 11G 7.7G 59% /usr/bin
/dev/root 20G 11G 7.7G 59% /usr/man
/dev/root 20G 11G 7.7G 59% /usr/X11R6
/dev/root 20G 11G 7.7G 59% /usr/kerberos
/dev/root 20G 11G 7.7G 59% /usr/libexec
/dev/root 20G 11G 7.7G 59% /usr/local/bin
/dev/root 20G 11G 7.7G 59% /usr/local/share
/dev/root 20G 11G 7.7G 59% /usr/local/Zend
/dev/root 20G 11G 7.7G 59% /usr/local/IonCube
/dev/root 20G 11G 7.7G 59% /usr/include
/dev/root 20G 11G 7.7G 59% /usr/local/lib
/dev/root 30G 21G 7.1G 75% /var/spool
/dev/root 30G 21G 7.1G 75% /var/lib
/dev/root 30G 21G 7.1G 75% /var/cpanel
/dev/root 20G 11G 7.7G 59% /usr/local/cpanel/Cpanel
/dev/root 30G 21G 7.1G 75% /var/run
/dev/root 30G 21G 7.1G 75% /var/log
/dev/root 996M 150M 795M 16% /tmp
/dev/root 4.0G 128K 4.0G 1% /dev
/dev/root 996M 660M 284M 70% /bin
/dev/root 20G 11G 7.7G 59% /usr/local/apache/domlogs
/dev/root 996M 660M 284M 70% /etc/mail
/dev/root 481G 393G 64G 87% /home/s10889c1

It seems not to be an NFS mount

Last edited by nsblenin; 08-10-2012 at 09:31 AM.
 
Old 08-10-2012, 09:30 AM   #4
Mr. Alex
Senior Member
 
Registered: May 2010
Distribution: No more Linux. Done with it.
Posts: 1,238

Rep: Reputation: Disabled
nsblenin, wrap your code up with forum tags. It's annoying when people paste code as is.

EDIT:
nsblenin, not quote. Code.

Last edited by Mr. Alex; 08-10-2012 at 10:00 AM.
 
Old 08-10-2012, 09:50 AM   #5
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,580
Blog Entries: 14

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
You left out the dot.

Code:
df -h .
Also try:
Code:
cat /etc/mtab
 
Old 08-10-2012, 10:17 AM   #6
nsblenin
LQ Newbie
 
Registered: Aug 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Code:
-rw-r--r-- 1 nobody nobody  421 Jun 16  2010 voucher.txt
-jailshell-3.2$ df -h .
Filesystem            Size  Used Avail Use% Mounted on
/dev/root             481G  393G   64G  87% /home/s10889c1
 
Old 08-10-2012, 10:18 AM   #7
nsblenin
LQ Newbie
 
Registered: Aug 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Code:
-jailshell-3.2$ cat /etc/mtab
/dev/root /lib virtfs defaults 0 0
/dev/root /sbin virtfs defaults 0 0
/dev/root /opt virtfs defaults 0 0
/dev/root /lib64 virtfs defaults 0 0
/dev/root /usr/lib virtfs defaults 0 0
/dev/root /usr/lib64 virtfs defaults 0 0
/dev/root /usr/sbin virtfs defaults 0 0
/dev/root /usr/share virtfs defaults 0 0
/dev/root /usr/bin virtfs defaults 0 0
/dev/root /usr/man virtfs defaults 0 0
/dev/root /usr/X11R6 virtfs defaults 0 0
/dev/root /usr/kerberos virtfs defaults 0 0
/dev/root /usr/libexec virtfs defaults 0 0
/dev/root /usr/local/bin virtfs defaults 0 0
/dev/root /usr/local/share virtfs defaults 0 0
/dev/root /usr/local/Zend virtfs defaults 0 0
/dev/root /usr/local/IonCube virtfs defaults 0 0
/dev/root /usr/include virtfs defaults 0 0
/dev/root /usr/local/lib virtfs defaults 0 0
/dev/root /var/spool virtfs defaults 0 0
/dev/root /var/lib virtfs defaults 0 0
/dev/root /var/cpanel virtfs defaults 0 0
/dev/root /usr/local/cpanel/Cpanel virtfs defaults 0 0
/dev/root /var/run virtfs defaults 0 0
/dev/root /var/log virtfs defaults 0 0
/dev/root /tmp virtfs defaults 0 0
/dev/root /dev virtfs defaults 0 0
/dev/root /bin virtfs defaults 0 0
/dev/root /usr/local/apache/domlogs virtfs defaults 0 0
/dev/root /etc/mail virtfs defaults 0 0
/dev/root /home/s10889c1 virtfs defaults 0 0
none /proc proc rw 0 0
-jailshell-3.2$
 
Old 08-10-2012, 11:53 AM   #8
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,580
Blog Entries: 14

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
mtab shows your filesystem type is virtfs. That appears to be some sort of virtual or jailed filesystem on a quick check.

Unfortunately I've not worked with that fs type. You might want to do a web search for "virtfs nobody" to see what it shows you.

You may also have man pages for it on the system. Type "man -k virtfs" to see which, if any, man pages exist then review the ones found.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Owner of a directory different than file owner problems Guardian-Mage Linux - Server 4 04-24-2009 11:26 AM
Display by File Name, File Size, and File Owner using ls akeenabawa Linux - Newbie 9 08-15-2008 03:21 PM
File owner and File group locked - root deiphage Linux - Hardware 5 02-05-2005 02:30 PM
file permissions and file owner won't change Nadim Slackware 5 11-29-2003 07:03 PM


All times are GMT -5. The time now is 09:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration