LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-26-2012, 02:26 PM   #1
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Rep: Reputation: Disabled
fglrx - Display is offset and obscured by black border


Hello!

I have been having some problems setting up fglrx on my Debian installation with "Wheezy sources". The resolution is correctly set to 1920x1080 on both monitors, and if I print screen the entire desktop area is displayed in the resulting image properly. On the monitors, I am having two problems:

1. When displayed on my monitors (vs screenshot) there is a black border framing each display which contains actual space I can move my mouse in. The space exists, it just isn't being drawn onscreen.
2. My screen begins at the top left hand corner of the black border. So even if I can get the rest of the display to be rendered - A significant portion of the screen would be offset to the bottom right of my monitors
I don't suppose that any of you have encountered similar problems in the past? I have run into a similar issue with these monitors under windows - the full screen was shown in the box, and I was able to use an overscan setting. Perhaps it has something to do with these monitors being connected via HDMI vs DVI?

Oh! And I cannot seem to be able to use aticonfig --tv-overscan=on either. Actually I started using amdcccle after a couple of hours of trial and error from the command line - that is how the current xorg.conf was created. Oh - I also have not recompiled it from source to enable 3D. I was hoping to see if I could get it running first.

Here is my /etc/X11/xorg.conf file:

Code:
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "off"
EndSection

Section "InputClass"
	Identifier      "Mouse Remap"
	MatchProduct    "Saitek Cyborg R.A.T.7 Mouse"
	MatchDevicePath "/dev/input/event*"
	Option	    "ButtonMapping" "1 2 3 4 5 6 7 8 9 10 11 12 0 0 0"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	Option	    "Primary" "false"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	Option	    "RightOf" "Monitor0"
	Option	    "Primary" "False"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	VertRefresh  60.0 - 60.0
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-1"
	VertRefresh  60.0 - 60.0
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "0-DFP9"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "Disable" "false"
	Option	    "PreferredMode" "1920x1080"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
EndSection

Section "Monitor"
	Identifier   "0-DFP11"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "Disable" "false"
	Option	    "PreferredMode" "1920x1080"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "1920 0"
	Option	    "Rotate" "normal"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	Option	    "Centermode" "on"
	Option	    "OpenGLOverlay" "on"
	Option	    "Capabilities" "0x00000800"
	Option	    "TVStandard" "VIDEO"
	Option	    "Monitor-DFP9" "0-DFP9"
	Option	    "Monitor-DFP11" "0-DFP11"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-1"
	Driver      "fglrx"
	Option	    "Monitor-DFP11" "0-DFP11"
	BusID       "PCI:1:0:0"
	Screen      1
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Virtual   3840 1920
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-1"
	Device     "aticonfig-Device[0]-1"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "true"
	Option	    "RENDER" "true"
EndSection
 
Old 11-26-2012, 03:00 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,565

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
Have you tried without the Xorg.conf? Not hugely needed these days. You can stick the video stuff in /etc/X11/xorg.conf.d

Anything of interest in there already?

How did you install fglrx? Package, or .run file?
 
Old 11-26-2012, 03:26 PM   #3
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks For the reply BusinessKid!

I haven't tried going without the xorg.conf since I installed fglrx - but beforehand it was running at an improper resolution(everything was stretched horizontally), with a cloned dual monitor setup, and I still had the black border but everything appeared within the border so it was workable. Gnome's Display tool could not detect my monitors so I couldn't tweak anything through there.

--------------------------------------------------------

I installed fglrx from terminal. (12-6.1)
Code:
aptitude install fglrx-driver fglrx-control
then CTRL+ALT+F2, made myself SuperUser
Code:
/etc/init.d/gdm3 stop
modprobe -r radeon drm
aticonfig --initial --screen-layout=right
startx
(I actually have about 18 temporary files from my trials of different settings from the cli, but that's what I finished with lol)

finally:
Code:
 su
amdcccle
and I tweaked the settings from in there. I actually just make a picture in gimp to try to demonstrate the problem - I just need to mess around with the plugins in chromium, it doesn't seem to want to keep photobucket onscreen once it has loaded...

-----------------------------------------------------------------------------

As for the contents of xorg.conf

the only things I really need in there are:

-section for my non-standard mouse
Code:
Section "InputClass"
	Identifier      "Mouse Remap"
	MatchProduct    "Saitek Cyborg R.A.T.7 Mouse"
	MatchDevicePath "/dev/input/event*"
	Option	    "ButtonMapping" "1 2 3 4 5 6 7 8 9 10 11 12 0 0 0"
EndSection
-fglrx does not let me load xcompmgr without:

Code:
Section "Extensions"
	Option	    "Composite" "true"
	Option	    "RENDER" "true"
EndSection
 
Old 11-26-2012, 06:22 PM   #4
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
Holy Cow! I have a Solution!!!

The problem is caused by the hdmi out. Apparently there are some TVs that will not display the entire screen when you hook up a computer to it, so as part of the driver ATI included an underscan option --> resizing the viewable section of your screen. I found this on the ubuntu forums, and the poster apparently found it on phoronix:

the only issue with it is that the file seems to reset itself on boot - which means I guess it is being generated by another file. I'm going to try writing a script that makes the changes to the file, and restarts my Xsession on boot!



http://ubuntuforums.org/showthread.php?t=960904&page=2

Quote:
've been grappling with this problem as well, for a couple of days. Much googling has finally uncovered this at the Phoronix forums:

http://www.phoronix.com/forums/showt...t=10073&page=4

After messing about for a bit, I've figured out a more direct way of solving this.

You need to change the Persistent Configuration Store (PCS) database, which fortunately is a flat file.

First, make a backup of the pcs database, as so:

Code:
sudo cp /etc/ati/amdpcsdb /etc/ati/amdpcsdb.backup
Next, edit the file /etc/ati/amdpcsdb as so:

Code:
sudo nano /etc/ati/amdpcsdb
See the attached file fragments below. The lines you need to add are in red. Make sure you put them under the right sections!

Code:
AMDPCSDBV1
[AMDPCSROOT/SYSTEM/MCIL]
PXACAutoSwitch=V0
PXDCAutoSwitch=V0
CVRULE_CUSTOMIZEDMODESENABLED=V1
DFP_AddHDTVPixelFormats=V2
DALLinuxSupport=V1
DALNonStandardModesBCD=R1400105000000060179213440000006018001440000000601856139200000060160012000000 00601280076800000060144009000000006012800960000000601680105000000060
DALRULE_ADDNATIVEMODESTOMODETABLE=V1
DALRULE_ALLOWMONITORRANGELIMITMODESCRT=V0
DALRULE_DYNAMICMODESUPPORT=V1
DALRULE_GetLCDFakeEDID=V1
DALRULE_GetTVFakeEDID=V1
DALRULE_NOFORCEBOOT=V1
DALRULE_POWERPLAYDISREGARDDISPLAY=V1
DALRULE_RESTRICTDISPLAYSBASEDONPANELRES=V0
DALRULE_REGISTRYACCESS=V1
GCORULE_FlickerWA=V1
GCORULE_LCDValidatePixelClkOnly=V1
GXOM5XDisableLaneSwitch=V1
R6LCD_RETURNALLBIOSMODES=V1
TVEnableOverscan=V1
UvdEnabled=V1
Gxo50HzTimingSupport=V1
Gxo24HzTimingSupport=V1
Gxo2530HzTimingSupport=V1
DigitalHDTVDefaultUnderscan=V0
Scroll down further until you find:

Code:
[AMDPCSROOT/SYSTEM/DDX]
OGLFMTA2R10G10B10Enable=V0
EnableRandR12=SFALSE
The first part is turning off the Underscan default, as given in the earlier Phoronix link. The second part is disabling the RandR, since it wouldn't work otherwise ... or maybe it would. Give it a try without. I didn't actually try it that way.

Anyway, hope that helped.

gier


And just in case anyone else is having problems with FGLRX dual monitor setups, this is the relevant section of the xorg.config that I used.

Code:
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "off"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	Option	    "Primary" "false"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	Option	    "RightOf" "Monitor0"
	Option	    "Primary" "False"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	VertRefresh  60.0 - 60.0
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-1"
	VertRefresh  60.0 - 60.0
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "0-DFP9"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "Disable" "false"
	Option	    "PreferredMode" "1920x1080"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
EndSection

Section "Monitor"
	Identifier   "0-DFP11"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "Disable" "false"
	Option	    "PreferredMode" "1920x1080"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "1920 0"
	Option	    "Rotate" "normal"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	Option	    "Centermode" "on"
	Option	    "OpenGLOverlay" "on"
	Option	    "Capabilities" "0x00000800"
	Option	    "TVStandard" "VIDEO"
	Option	    "Monitor-DFP9" "0-DFP9"
	Option	    "Monitor-DFP11" "0-DFP11"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-1"
	Driver      "fglrx"
	Option	    "Monitor-DFP11" "0-DFP11"
	BusID       "PCI:1:0:0"
	Screen      1
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Virtual   3840 1920
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-1"
	Device     "aticonfig-Device[0]-1"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

## So that I can use xcompmgr

Section "Extensions"
	Option	    "Composite" "true"
	Option	    "RENDER" "true"
EndSection
 
Old 11-26-2012, 08:32 PM   #5
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
I wrote a script that writes the additions to /etc/ati/amdpscdb on startup. Before applying this, you should probably read the following:

What you should know before doing this:

Code:
man update-rc.d
Linux uses run levels in which it starts programs as the computer boots.

0 --> when the computer shuts down
s or 1 --> when the computer boots
2,3,4,5 --> different run levels (you can see which programs boot in each in /etc/rc2.d/,/etc/rc3.d/, /etc/rc4.d/ etc...
6 --> a reboot

if you wanted to jump straight to a run level you can use the command telinit 3, telinit5 etc.

Note that apparently distrobutions can choose to have programs run at different run levels. I cannot remember the man page that I read this in. sorry.
Explanation:
In Debian 6.3 - FGLRX runs it's first script in run level 2.
I assumed that this is where it generates /etc/ati/amdpcsdb
so I added a script that runs at that run level (actually I was impatient and made it start at 2,3,4,and 5)
the script looks for the line:

Gxo50HzTimingSupport=V1/Gxo50HzTimingSupport=V1
and adds
DigitalHDTVDefaultUnderscan=V0
to the next line

check your amdpcsdb to make sure that line exists, if it does not, choose another line under the same heading (the part in brackets)



Instructions:

-
Code:
cd /etc/init.d
-
Code:
nano fglrxfix
- enter the following:
Code:
	# FGLRX underscan fix
	#-----------------------------

sed 's/Gxo50HzTimingSupport=V1/Gxo50HzTimingSupport=V1\nDigitalHDTVDefaultUnderscan=V0/g' </etc/ati/amdpcsdb>wpbuffer	
sudo cp wpbuffer /etc/ati/amdpcsdb
sudo rm wpbuffer

exit0
-
Code:
chown root fglrxfix
#makes root owner of fglrxfix
-
Code:
chmod 4755 fglrxfix
#makes fglrxfix executable as su

-
Code:
update-rc.d fglrxfix start 20 2 3 4 5 .
#makes fglrxfix run on startup (basically)

-you're done
This seems like a giant pain in the ass, but it's waaaaaaaaaaaaaay better than having to exit and restart the xserver every time you log in. This method works with multiple monitors.

Cheers folks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ATI catalyst 10.7 black border on 13.1 tmfizzle Slackware 3 08-05-2010 04:19 AM
Starterbar: remove black border? nick1 Linux - Software 1 08-26-2006 01:23 AM
TV screen has large black border KopiX Linux - Software 1 01-15-2005 05:00 PM
Black border around UT2004 sharpie Linux - Games 3 07-30-2004 04:03 AM
A one-inch black border on my screen Colonel Panic Linux - General 4 09-19-2001 04:00 PM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration