LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-07-2005, 04:10 AM   #1
robot2051
LQ Newbie
 
Registered: Aug 2005
Location: PERTH!!!!! WA!!!!! Wheeeeeeeeeeeee
Posts: 6

Rep: Reputation: 0
Few question with my laptop_Toshiba Satelite 4300 Pro


Hmm.. this is my first post in this forum so.... Hi to Everyone first ^^
ANyhow... let's go straight to the point:
I'm using Ubuntu v5.4 with kernel: 2.6.10-5-386 , gcc version 3.3.5 (Ubuntu run on Debian base by the way)
Anyhow, here is my problemS ^^ :

- My laptop is running pretty slow so i checked the cpuinfo in /proc/ and dmesg and found out that it's running at 310 Hz (the CPU) while my CPU's actual speed is P3 700MHz. Can i change this configuration to match with my CPU speed?

-If i'm going to upgrade my memory from 64 to... say , 256, would it automatically change the setting or i have to do it manually?

-when i set up Ubuntu, I accidently let it created 2 partition by it's own (didn't have much time yanno? T_T) and now i'm running with 180 MB SWAP, and the rest is Primary partition using... ext3. Can someone tell me how to creat a... SWAP file (i remember i read some article about this but... couldnt remember...>.<) ???

-I'm planning to Install Linux from Scratch (LFS) on my laptop but i ran out of free space(well actually i didn't have any T_T) I tried to see if cfdisk have option to defrag "/" and then take out some free space but i couldn't find any option like that... can someone tell me how to take out about 2G from my previous partition without damage my data or my old system?

-I suck at complile files as well cause i dunno anything... so.. hmm.. i got this program and tried to ./configure it but it came out with this error:

loading cache ./config.cache
dialog not found!
Please read the documentation!!!

-I installed Xircom network card (pcmcia card) into my laptop and it worked damn fine!!! However... i installed Netgear WG511v2 wireless card into it and nothing happened, even the log in /var/message didn't say anything about new device that is installed... or error message... The card didn't light up or anything. I thought it's hard ware faulty so i went to the shop and got the new card but same thing happened T_T what should i DOOOO???

ANyway,... that's hell lots of questions... if you guys could help any of them, i would be very appriciate
thank you for your time and consideration

San T

PS: oh ya, 1 more thing : I used cfdisk to delete and create partition on my thumbdrive (i planned to install Linux from scratch on it since i couldn't do anything to the harddrive)
then i got this partition table:
name Flags Part Type FS type Label Size(MB)
sda1 Boot Primary Linux 99.8
sda5 Logical Linux 31.20

I planned to use sda5 as swap and sda1 as primary. Will 31.2 is enough to run an operating system and does it need to be bigger than memory itself?? ^^
 
Old 08-07-2005, 09:04 PM   #2
zhy2111314
Member
 
Registered: Aug 2005
Location: China
Distribution: redhat(Fedora Core)->Debian Sid->Slackware
Posts: 91

Rep: Reputation: 15
Re: Few question with my laptop_Toshiba Satelite 4300 Pro

Quote:
- My laptop is running pretty slow so i checked the cpuinfo in /proc/ and dmesg and found out that it's running at 310 Hz (the CPU) while my CPU's actual speed is P3 700MHz. Can i change this configuration to match with my CPU speed?
thought you should reconfigure your system configuration
Quote:
-If i'm going to upgrade my memory from 64 to... say , 256, would it automatically change the setting or i have to do it manually?
thought it doesnt matter whether you upgrade your memory or degrade your memory for your system
Quote:
-when i set up Ubuntu, I accidently let it created 2 partition by it's own (didn't have much time yanno? T_T) and now i'm running with 180 MB SWAP, and the rest is Primary partition using... ext3. Can someone tell me how to creat a... SWAP file (i remember i read some article about this but... couldnt remember...>.<) ???
make swap file like this:
Code:
dd if=/dev/zero of=/swap bs=BLOCK_SIZE count=COUNT
mkswap /swap COUNT
swapon /swap
and modify your /etc/fstab to make the /swap active when you boot your system every time:
Code:
#/etc/fstab
.....
/swap swap swap defaults 0 0
Quote:
-I'm planning to Install Linux from Scratch (LFS) on my laptop but i ran out of free space(well actually i didn't have any T_T) I tried to see if cfdisk have option to defrag "/" and then take out some free space but i couldn't find any option like that... can someone tell me how to take out about 2G from my previous partition without damage my data or my old system?
thought see more details about cfdisk or fdisk under Linux Environment
Quote:
-I suck at complile files as well cause i dunno anything... so.. hmm.. i got this program and tried to ./configure it but it came out with this error:

loading cache ./config.cache
dialog not found!
Please read the documentation!!!
First read the documentation like readme.txt etc.
Quote:
-I installed Xircom network card (pcmcia card) into my laptop and it worked damn fine!!! However... i installed Netgear WG511v2 wireless card into it and nothing happened, even the log in /var/message didn't say anything about new device that is installed... or error message... The card didn't light up or anything. I thought it's hard ware faulty so i went to the shop and got the new card but same thing happened T_T what should i DOOOO???
thought you should recompile your kernel by adding wireless card into it
Quote:
PS: oh ya, 1 more thing : I used cfdisk to delete and create partition on my thumbdrive (i planned to install Linux from scratch on it since i couldn't do anything to the harddrive)
then i got this partition table:
name Flags Part Type FS type Label Size(MB)
sda1 Boot Primary Linux 99.8
sda5 Logical Linux 31.20

I planned to use sda5 as swap and sda1 as primary. Will 31.2 is enough to run an operating system and does it need to be bigger than memory itself?? ^^ [/B]
if it isnot enough ,just make a swap file like i have mentioned but i thought it's enough for the 99.8M of Primary

Hope to help

zhy2111314
 
Old 08-08-2005, 01:34 AM   #3
robot2051
LQ Newbie
 
Registered: Aug 2005
Location: PERTH!!!!! WA!!!!! Wheeeeeeeeeeeee
Posts: 6

Original Poster
Rep: Reputation: 0
Smile

Thx mate ^^ The swap file works awesome!!! ^^ it's alll thank to you
hmm.. anyhow, i dunno how to reconfigure my configuration, where could i do it? could anyone tell me more specific? I;m noob yano ^^
hmm.. about the ./configure, i followed the instruction in the INSTALL files that is:
./setup.sh && make install
but it also came up with the : dialog not found
i guess the package is damaged , i will try to download it again or older version and see what happen
when i installed Ubuntu, i put into the pcmcia slot straight away my netgear wireless card, apparently it didn't recognise or did anything to it and i'm not sure how to recomplile the kernel ^^
anyhow, great help my friend
thanks a lot
San T
 
Old 08-08-2005, 01:59 AM   #4
zhy2111314
Member
 
Registered: Aug 2005
Location: China
Distribution: redhat(Fedora Core)->Debian Sid->Slackware
Posts: 91

Rep: Reputation: 15
I didnot use Ubuntu,so i dunno the commnd to reconfigure your system
and what soft did you compile ? Maybe that's the problem of your system.
you can put the ./setup.sh here for referrence
 
Old 08-08-2005, 08:33 AM   #5
robot2051
LQ Newbie
 
Registered: Aug 2005
Location: PERTH!!!!! WA!!!!! Wheeeeeeeeeeeee
Posts: 6

Original Poster
Rep: Reputation: 0
Talking

Oh,... it's just a infared program call lirc but it's ok now after i downloaded the older version ^^ GUess the file was corrupted some how
ANyway, i think the biggest problem that i'm facing with right now is my CPU speed ^^ it's running at 300Hz and can recognise that it's P3 but i'm pretty sure my toshiba satelite 4300 pro's speed is 700Hz. I wonder if the cpuinfo in /proc/ or the dmesg is the right place to see the cpu's information? cause that's where i got the value of 300Hz from
Oh ya.. also, my netgear card... it's still having trouble... Do you think the old pcmcia slot use higher voltage than the newer (by any chance?) that destroyed that... sensitive type of card? ^^ well.. obviously this is a stupid question since my Xircom ethernet card work fine but this is the second netgear card(same version) that doesn't work on my nor recognise on my system... and after that, i tried to set it up into my friend's computer (which is using windows XP), it doesn't work as well.. so... i came to a conclusion that my card is spoiled by my pcmcia card (apparently his laptop already had a built in wireless card, would it be ok to set up another one? (in XP) )
thanks for your time mate
San T
 
Old 08-08-2005, 11:38 AM   #6
robot2051
LQ Newbie
 
Registered: Aug 2005
Location: PERTH!!!!! WA!!!!! Wheeeeeeeeeeeee
Posts: 6

Original Poster
Rep: Reputation: 0
Thumbs up

DUDE. finally!!! I was stuck at the end with the dialog not found. though the last message i said i downloaded the previous version and it worked but in reallity it didn't so instead of that i used different programs.(just didn't wanna waste your time too much ) anyhow, today i got online and found the answer on the online manual page of the package (silly me >.<):

http://www.lirc.org/html/install.html#compiling

Well.. just to anyone who doesnt know or might receive the same error, the program that i installed is lirc-0.7.1 and everytime i ran ./setup or ./configure i got this error:
dialog not found

the manual online helped me to understand that in order to complile it smoothly, i need a dialog package(which i neva heard of) but my system doens't have it so here is the suggestion:

If you don't have dialog installed you will have to do it the hard way and give the correct parameters to the
configure script manually. See ./configure --help for a detailed description of the possible parameters. You
will have to at least choose a driver with the --with-driver=X option.
and it works awesome!! ^^

anyway.. now i only have those 2 big problems, the CPU and the Netgear card!! Way to go!!!! ^^
San T
 
Old 08-08-2005, 01:32 PM   #7
robot2051
LQ Newbie
 
Registered: Aug 2005
Location: PERTH!!!!! WA!!!!! Wheeeeeeeeeeeee
Posts: 6

Original Poster
Rep: Reputation: 0
I posted similar topic like this on the laptop section in forum
hopefully i will get answers soon
thx buddy
 
Old 08-08-2005, 09:05 PM   #8
zhy2111314
Member
 
Registered: Aug 2005
Location: China
Distribution: redhat(Fedora Core)->Debian Sid->Slackware
Posts: 91

Rep: Reputation: 15
First, Congratulations to u
and I have heard dialog before, I thought it's the reason when I saw the error message, but I didnot make sure of it, so I didnot say it out but, so the manual is important,isnot it?
CPU and Netgear Card I thought maybe the reason is the kernel, it didnot support the hardware of your laptop,so you can put out your kernel version here and the detail of your cpu and netgear card,hope to find the answer of your problem.

good to you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba Satellite 4300 Pro T_T problemo robot2051 Linux - Laptop and Netbook 0 08-08-2005 01:30 PM
Satelite Internet Connection odinfromvalhalla Linux - Networking 2 06-26-2005 08:08 AM
Toshiba Satellite PRO 4300 Modem drivers.. madh52 Linux - Laptop and Netbook 4 12-28-2004 05:28 AM
satelite receiver software? kalleanka Linux - Software 0 06-06-2004 08:58 AM
Fedora Core on Satellite Pro 4300 hangs up when its starting w/ LAN card inserted. takaki Linux - Networking 2 03-29-2004 11:02 PM


All times are GMT -5. The time now is 05:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration