LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2004, 03:39 PM   #1
infamous41md
Member
 
Registered: Mar 2003
Posts: 804

Rep: Reputation: 30
few problems with slack and terminals


1)in aterm, i am unable to use 'Ctrl-l' to clear my screen. whenever i push it, the current line gets reprinted and that's it. it works on all other terminals.
2)when i do ls -al > file, and then do 'less file' or 'vi file', it seems that all of the ascii color escapce sequences are being printed to the output file.
3)hmm there was some other one but i seemed to have 4got
thanks.
 
Old 01-11-2004, 07:55 PM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
2) add '--color=none' when you redirect to remove the codes or set 'less' to be '-R' or '-r' and it will translate the codes properly. These can be set in your bash configs if you want them to be permanent.

Not sure I've experienced #1.

-- To add examples:

LESS="-MR";export LESS
alias ls='ls -F --color=always'

or

alias ls='blah blah --color=none'

Last edited by slakmagik; 01-11-2004 at 07:58 PM.
 
Old 01-11-2004, 10:52 PM   #3
infamous41md
Member
 
Registered: Mar 2003
Posts: 804

Original Poster
Rep: Reputation: 30
thanks.
 
Old 01-12-2004, 08:04 PM   #4
infamous41md
Member
 
Registered: Mar 2003
Posts: 804

Original Poster
Rep: Reputation: 30
anyone else have an idea on the first question? what program is grabbing 'Control l' when i push it? i have fluxbox running, and i tried to catch it in my keybindings file, but it won't work with 'Ctrl l'.
 
Old 01-12-2004, 08:27 PM   #5
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I think it goes into the hideous jungle of termcap. For some bizarre reason (my terms are all screwed up) aterm sets $TERM to 'rxvt' and my Ctrl-L works. But I tried setting it to 'aterm' and, sure enough, Ctrl-L quit working. So it's an ugly fix and may have unwanted consequences (other keys may start acting differently) but 'aterm -tn rxvt' (or 'xterm') and maybe it'll do okay. If it does, alias aterm to that or whatever other config method you'd like. If not, just set it back and see if you have better luck understanding termcap/terminfo than I did.
 
Old 01-12-2004, 10:29 PM   #6
infamous41md
Member
 
Registered: Mar 2003
Posts: 804

Original Poster
Rep: Reputation: 30
thank you SOOOOOOOOOO much. this has been driving me off the wall. now im going to check out termcap i guess for a real fix. when i was running redhat it was automagically working somehow....
 
Old 01-12-2004, 11:39 PM   #7
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I know the feeling. I've had several keys not cooperate at various times and it's one of the more frustrating and annoying things around. If you do figure out the termcap thing, please post back with a tutorial.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2 problems:terminals and networking rsouflaki Fedora 0 01-02-2005 09:21 AM
Terminals - spying on local terminals with ssh BeatRyder Linux - Software 5 10-21-2004 01:47 AM
Slack 9.1 problems Mr.Kex Slackware 19 03-08-2004 04:59 PM
Problems with text displaying in Terminals (Suse 8.1) mzu Linux - Distributions 1 04-13-2003 07:05 AM
a few problems in slack 8.1 Jingles Slackware 10 09-27-2002 10:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration