LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-24-2010, 12:36 PM   #1
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Rep: Reputation: 21
Unhappy fedora update problem


I was trying to install vlc in fedora 12 and got the following error.

--> Missing Dependency: libcdio.so.10(CDIO_10) is needed by package vlc-core-1.0.5-2.fc12.i686 (rpmfusion-free-updates)
Error: Missing Dependency: libcdio.so.10 is needed by package vlc-core-1.0.5-2.fc12.i686 (rpmfusion-free-updates)
Error: Missing Dependency: libcdio.so.10(CDIO_10) is needed by package vlc-core-1.0.5-2.fc12.i686 (rpmfusion-free-updates)
 
Old 03-24-2010, 01:20 PM   #2
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
Search in

Quote:
rpm.pbone.net
 
Old 03-24-2010, 01:32 PM   #3
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 136

Rep: Reputation: 20
how do you install vlc? with yum? or use package manager?
 
Old 03-24-2010, 01:36 PM   #4
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by z99 View Post
how do you install vlc? with yum? or use package manager?
Yes, I install mplayer,vlc,xine,xmms all by yum on my box.

If any dependency problem search in rpm.pbone.net
 
Old 03-24-2010, 01:51 PM   #5
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 136

Rep: Reputation: 20
using yum,it will install all the dependencies automatically,so i think there would be no dependencies problem through yum?
i'm new so if i am wrong just tell me please,thanks
 
Old 03-24-2010, 02:03 PM   #6
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
No still some dependency problem after using yum,

Use some third party repositories for install through yum.

check this page for vlc

http://www.videolan.org/vlc/download-fedora.html
 
Old 03-25-2010, 04:44 AM   #7
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Original Poster
Rep: Reputation: 21
I tried it using yum and I have gone already gone through that link using the rpmfusion-free updates repos, still I got this error.
I haven't worked with fedora earlier, other distros usually take care of all the dependencies by themselves, also if I install some other software like adobe flash player it gives the same error message.
 
Old 03-25-2010, 09:49 AM   #8
Fred Caro
Member
 
Registered: May 2007
Posts: 999

Rep: Reputation: 166Reputation: 166
yum

I am guessing but 'yum' must be related to 'rpm' which is highly descriptive in it's function so you might have to layout your install in more detail than you might have to with say 'apt-get'.

Fred.
 
Old 03-25-2010, 10:15 AM   #9
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 136

Rep: Reputation: 20
what is your repo?
 
Old 03-25-2010, 10:53 AM   #10
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by z99 View Post
what is your repo?
I use epel,rpmforge and rpm.pbone repos for my RHEL .
 
Old 03-25-2010, 10:57 AM   #11
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 136

Rep: Reputation: 20
according to error (rpmfusion-free-updates),
i think,install rpmfusion repo then try,maybe it could help!
 
Old 03-26-2010, 07:42 AM   #12
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Original Poster
Rep: Reputation: 21
well I have rpmfusion-free-updates repo installed, even when I try yum update I get the same error message.]
fedora-rawhide.repo
rpmfusion-free-updates.repo
fedora.repo
rpmfusion-free-updates-testing.repo
fedora-updates.repo
rpmfusion-nonfree-rawhide.repo
fedora-updates-testing.repo
rpmfusion-nonfree.repo
rpmfusion-free-rawhide.repo
rpmfusion-nonfree-updates.repo
rpmfusion-free.repo
rpmfusion-nonfree-updates-testing.repo

I have all these files installed in my repos directory.
 
Old 03-27-2010, 05:15 PM   #13
Fred Caro
Member
 
Registered: May 2007
Posts: 999

Rep: Reputation: 166Reputation: 166
yum

Your problem maybe sorted by a recently added 'patch' for yum and rpm. Do the usual and update yum/rpm restart and look for software, in my case it returned the above and once done it returned 55 updates and yum,rpm ran more smoothly.

Fred.
 
Old 03-28-2010, 06:52 AM   #14
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Original Poster
Rep: Reputation: 21
It still doesn't work only the errors changed,now it gives a dependency problem on some other packages.

-> Finished Dependency Resolution
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpm.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
anaconda-14.2-1.fc14.i686 from rawhide has depsolving problems
--> Missing Dependency: fcoe-utils >= 1.0.12-2.20100323git is needed by package anaconda-14.2-1.fc14.i686 (rawhide)
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpm.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
Error: Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
Error: Missing Dependency: fcoe-utils >= 1.0.12-2.20100323git is needed by package anaconda-14.2-1.fc14.i686 (rawhide)
Error: Missing Dependency: librpm.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

any suggestions??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello and a problem after an update on Fedora kenhow LinuxQuestions.org Member Intro 3 07-24-2008 02:32 AM
problem update fedora 6 prince amir Linux - Desktop 1 11-15-2006 11:16 PM
I have problem to update with the update function under fedora core 2 babyboss Fedora 4 08-10-2005 08:34 AM
Update problem Fedora 3 gsxruk Linux - Software 1 03-10-2005 07:00 PM
Fedora update font problem Peter2004 Fedora 1 08-27-2004 09:44 PM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration