LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-08-2006, 01:49 PM   #1
kalnaren
LQ Newbie
 
Registered: Dec 2005
Location: Ontario, CA
Distribution: SimplyMEPIS
Posts: 22

Rep: Reputation: 15
Fedora Speed questions -really slow


I recently installed Fedora Core 5 (x86_64 version), but I find the operating system horribly slow. Fedora 4 never ran very fast for me, but 5 is even more sluggish. It takes forever to boot (havn't timed it, but from the time I select it in GRUB till I'm looking at the fully loaded desktop it's probably in the ballpark of 2-4 minutes), and opening applications is very slow. Internet surfing is also incredebly sluggish (I almost feel like I'm on dial-up).
Does FC5 run really slow for anyone else? And does anyone know any ways I can optimise it? I'm pretty new to linux.

My compy specs:
Athlon 64 3200+
2048Mb DDR400 PC3200
256Mb Radeon X800GT PCI-e

Linux is installed in a 10Gb partition; 150 for boot, 2000 for swap, and 7750 for root.
 
Old 04-08-2006, 04:15 PM   #2
ctkroeker
Senior Member
 
Registered: May 2005
Location: Paraguay
Posts: 1,565
Blog Entries: 1

Rep: Reputation: 50
A good start would be too disable all the services you don't need and also eye-candy. If it's still slow or sluggish I'd suggest getting a different distro. I use Ubuntu (Xubuntu) on a machine that has 1/8th's of the specs you do and it's hardly sluggish at all.
Post back here after you try the first things I suggested.
 
Old 04-09-2006, 04:27 PM   #3
WhiskeyTangoFoxtrot
Member
 
Registered: Oct 2005
Location: Windsor, Ontario, Canada
Distribution: Fedora Core 5,4,3 & Ubuntu 6.06, 8.10
Posts: 403
Blog Entries: 1

Rep: Reputation: 30
i dont know if this helps but as a fedora user i had a similiar problem with FC3 once. i had done several installs of FC3 on my machince and this one install seemed a bit messed uo because everything was extremely slow. apps would load up very slowly and it was painfull !

now this was a while ago and i dont remember the exact cause. it was either a) because i had changed the systems name from localhost.localdomain to something else and it affected the entire sys. soretd it out by changing the comps name back to localhost.localdomain or b) i had dissabled some services in the service configuration and i solved this by reactivating them. i think it might have been the service "readahead" or something.

i know this most probably wont help but its something u can tick off the list. and btw, i use FC5 on my 5 year old Toshiba PIII laptop with 256MB ram and its running like a charm with eyecandy and all the works and heres a screenie to prove it http://img102.imageshack.us/img102/3...shot7dn.th.jpg so with ur powerfull configuration i think lowering the eye-candy wont make much of a difference.

Last edited by WhiskeyTangoFoxtrot; 04-09-2006 at 04:29 PM.
 
Old 04-09-2006, 09:26 PM   #4
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
It sounds like a prob with dhcp client or /etc/resolv.conf.
If you don't have your ISP as the search ans 1st 2 lines in the latter, it may default to searching your local box/lan before going onto the net to find sites...
Also, if you have any net related services coming up before DNS has settled, it will wait for DNS (bind) to timeout.
 
Old 04-10-2006, 05:41 PM   #5
kalnaren
LQ Newbie
 
Registered: Dec 2005
Location: Ontario, CA
Distribution: SimplyMEPIS
Posts: 22

Original Poster
Rep: Reputation: 15
I installed the Apache webserver (xampp) for something I had to do fro school, and it 'fixed' an apparent error in the /etc/hosts file...linux seems to magically work much faster now. I don't get it, but whatever. It no longer takes 4 minutes to load up, and programs seem to load somewhat faster (though still more sluggish than what I think they should be running at)
 
Old 04-10-2006, 08:31 PM   #6
WhiskeyTangoFoxtrot
Member
 
Registered: Oct 2005
Location: Windsor, Ontario, Canada
Distribution: Fedora Core 5,4,3 & Ubuntu 6.06, 8.10
Posts: 403
Blog Entries: 1

Rep: Reputation: 30
Hmmm.....it might just around have been something to do with the computer's network name........
 
Old 04-25-2006, 11:53 AM   #7
zzeepphhoo
LQ Newbie
 
Registered: Apr 2006
Distribution: Fedora 4
Posts: 4

Rep: Reputation: 0
Thumbs up Slow internet, DNS lookup

New distros like fedora 2-5 have Ipv6 turned on by default. IpV6 is a new DNS lookup that few servers use. This means that if the site you are trying to access in not listed on Ipv6, a 30 second timeout immeditately happens. It should be disabled. Also, Some other DNS servers miss the first few requests from linux machines. The default timeout is 5 seconds, so this could cause up to another 15 second delay. Step by step fix is as follows:
1. Log out of Fedora
2. Log in as root
3. enter your root password (the root password you entered when you installed fedora)
4. Click on "Home" or "My Computer"
5, Click on "Filesystem" or use up arrow to navigate to etc folder.
6. go to resolv.conf file. (not a folder, but a file located at the end of the files in your etc folder)
7. Insert this line at the bottom of the file: option timeout:1
8. Save the file
9. Go to etc/modprobe.conf file. Insert these lines at the bottom of the file:
alias ipv6 off
alias net-pf-10 off
10. Save the file.
11. Reboot your machine
12. Enjoy the SPEED!

Registered Linux User: #415505

Last edited by zzeepphhoo; 04-30-2006 at 03:53 PM.
 
Old 05-05-2007, 03:00 AM   #8
hidepenny
LQ Newbie
 
Registered: May 2007
Location: Melbourne, Australia
Distribution: Fedora Core 6
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by zzeepphhoo
New distros like fedora 2-5 have Ipv6 turned on by default. IpV6 is a new DNS lookup that few servers use. This means that if the site you are trying to access in not listed on Ipv6, a 30 second timeout immeditately happens. It should be disabled. Also, Some other DNS servers miss the first few requests from linux machines. The default timeout is 5 seconds, so this could cause up to another 15 second delay. Step by step fix is as follows:
1. Log out of Fedora
2. Log in as root
3. enter your root password (the root password you entered when you installed fedora)
4. Click on "Home" or "My Computer"
5, Click on "Filesystem" or use up arrow to navigate to etc folder.
6. go to resolv.conf file. (not a folder, but a file located at the end of the files in your etc folder)
7. Insert this line at the bottom of the file: option timeout:1
8. Save the file
9. Go to etc/modprobe.conf file. Insert these lines at the bottom of the file:
alias ipv6 off
alias net-pf-10 off
10. Save the file.
11. Reboot your machine
12. Enjoy the SPEED!

Registered Linux User: #415505
thanks for that, and it has previously worked for me to speed fedora up!
however i just recently re-installed fedora and it now no longer works because network manager always wipes out the resolv.conf file and i'm unable to make the option timeout:1 change permanent.

please help

Thanks
 
Old 05-05-2007, 09:39 PM   #9
hidepenny
LQ Newbie
 
Registered: May 2007
Location: Melbourne, Australia
Distribution: Fedora Core 6
Posts: 15

Rep: Reputation: 0
thx guys i got it.

if ipv6 is disabled when you create your network connection during installation then there's no need to put those statements as the config file for ipv6 simply just doesn't exist

all you gota check if u can ping www.google.com from terminal is disabling firefox ipv6 dns lookup in about:config!

cool.... take me about 6 fedora installation to figure this out!
 
Old 05-07-2007, 09:14 AM   #10
kalnaren
LQ Newbie
 
Registered: Dec 2005
Location: Ontario, CA
Distribution: SimplyMEPIS
Posts: 22

Original Poster
Rep: Reputation: 15
Wow this thread isn't dead yet :P Anyways, I solved the problem in Fedora 5 -turns out it just didn't like my DHCP server in res. I hooked up a router and everything worked fine.
 
Old 03-25-2008, 04:37 AM   #11
paulpeterj
LQ Newbie
 
Registered: Jul 2006
Posts: 1

Rep: Reputation: 0
Thumbs up

great idea
 
  


Reply

Tags
dns, fedora, internet, ipv6, modprobe, speed


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow ripping speed solar1951 Linux - Hardware 11 01-06-2007 10:24 PM
download speed too slow sharadshankar Linux - Networking 1 03-24-2006 04:25 AM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
Gprs Speed Too Slow nemesis1492 Linux - Hardware 0 08-22-2003 10:16 AM
a slow work speed kiru Linux - Newbie 5 04-09-2003 04:14 PM


All times are GMT -5. The time now is 05:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration