LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Fedora Speed questions -really slow (http://www.linuxquestions.org/questions/linux-newbie-8/fedora-speed-questions-really-slow-433081/)

kalnaren 04-08-2006 12:49 PM

Fedora Speed questions -really slow
 
I recently installed Fedora Core 5 (x86_64 version), but I find the operating system horribly slow. Fedora 4 never ran very fast for me, but 5 is even more sluggish. It takes forever to boot (havn't timed it, but from the time I select it in GRUB till I'm looking at the fully loaded desktop it's probably in the ballpark of 2-4 minutes), and opening applications is very slow. Internet surfing is also incredebly sluggish (I almost feel like I'm on dial-up).
Does FC5 run really slow for anyone else? And does anyone know any ways I can optimise it? I'm pretty new to linux.

My compy specs:
Athlon 64 3200+
2048Mb DDR400 PC3200
256Mb Radeon X800GT PCI-e

Linux is installed in a 10Gb partition; 150 for boot, 2000 for swap, and 7750 for root.

ctkroeker 04-08-2006 03:15 PM

A good start would be too disable all the services you don't need and also eye-candy. If it's still slow or sluggish I'd suggest getting a different distro. I use Ubuntu (Xubuntu) on a machine that has 1/8th's of the specs you do and it's hardly sluggish at all.
Post back here after you try the first things I suggested.

WhiskeyTangoFoxtrot 04-09-2006 03:27 PM

i dont know if this helps but as a fedora user i had a similiar problem with FC3 once. i had done several installs of FC3 on my machince and this one install seemed a bit messed uo because everything was extremely slow. apps would load up very slowly and it was painfull !

now this was a while ago and i dont remember the exact cause. it was either a) because i had changed the systems name from localhost.localdomain to something else and it affected the entire sys. soretd it out by changing the comps name back to localhost.localdomain or b) i had dissabled some services in the service configuration and i solved this by reactivating them. i think it might have been the service "readahead" or something.

i know this most probably wont help but its something u can tick off the list. and btw, i use FC5 on my 5 year old Toshiba PIII laptop with 256MB ram and its running like a charm with eyecandy and all the works and heres a screenie to prove it http://img102.imageshack.us/img102/3...shot7dn.th.jpg so with ur powerfull configuration i think lowering the eye-candy wont make much of a difference.

chrism01 04-09-2006 08:26 PM

It sounds like a prob with dhcp client or /etc/resolv.conf.
If you don't have your ISP as the search ans 1st 2 lines in the latter, it may default to searching your local box/lan before going onto the net to find sites...
Also, if you have any net related services coming up before DNS has settled, it will wait for DNS (bind) to timeout.

kalnaren 04-10-2006 04:41 PM

I installed the Apache webserver (xampp) for something I had to do fro school, and it 'fixed' an apparent error in the /etc/hosts file...linux seems to magically work much faster now. I don't get it, but whatever. It no longer takes 4 minutes to load up, and programs seem to load somewhat faster (though still more sluggish than what I think they should be running at)

WhiskeyTangoFoxtrot 04-10-2006 07:31 PM

Hmmm.....it might just around have been something to do with the computer's network name........

zzeepphhoo 04-25-2006 10:53 AM

Slow internet, DNS lookup
 
New distros like fedora 2-5 have Ipv6 turned on by default. IpV6 is a new DNS lookup that few servers use. This means that if the site you are trying to access in not listed on Ipv6, a 30 second timeout immeditately happens. It should be disabled. Also, Some other DNS servers miss the first few requests from linux machines. The default timeout is 5 seconds, so this could cause up to another 15 second delay. Step by step :newbie: fix is as follows:
1. Log out of Fedora
2. Log in as root
3. enter your root password (the root password you entered when you installed fedora)
4. Click on "Home" or "My Computer"
5, Click on "Filesystem" or use up arrow to navigate to etc folder.
6. go to resolv.conf file. (not a folder, but a file located at the end of the files in your etc folder)
7. Insert this line at the bottom of the file: option timeout:1
8. Save the file
9. Go to etc/modprobe.conf file. Insert these lines at the bottom of the file:
alias ipv6 off
alias net-pf-10 off
10. Save the file.
11. Reboot your machine
12. Enjoy the SPEED! :D

Registered Linux User: #415505

hidepenny 05-05-2007 02:00 AM

Quote:

Originally Posted by zzeepphhoo
New distros like fedora 2-5 have Ipv6 turned on by default. IpV6 is a new DNS lookup that few servers use. This means that if the site you are trying to access in not listed on Ipv6, a 30 second timeout immeditately happens. It should be disabled. Also, Some other DNS servers miss the first few requests from linux machines. The default timeout is 5 seconds, so this could cause up to another 15 second delay. Step by step :newbie: fix is as follows:
1. Log out of Fedora
2. Log in as root
3. enter your root password (the root password you entered when you installed fedora)
4. Click on "Home" or "My Computer"
5, Click on "Filesystem" or use up arrow to navigate to etc folder.
6. go to resolv.conf file. (not a folder, but a file located at the end of the files in your etc folder)
7. Insert this line at the bottom of the file: option timeout:1
8. Save the file
9. Go to etc/modprobe.conf file. Insert these lines at the bottom of the file:
alias ipv6 off
alias net-pf-10 off
10. Save the file.
11. Reboot your machine
12. Enjoy the SPEED! :D

Registered Linux User: #415505

thanks for that, and it has previously worked for me to speed fedora up!
however i just recently re-installed fedora and it now no longer works because network manager always wipes out the resolv.conf file and i'm unable to make the option timeout:1 change permanent.

please help

Thanks

hidepenny 05-05-2007 08:39 PM

thx guys i got it.

if ipv6 is disabled when you create your network connection during installation then there's no need to put those statements as the config file for ipv6 simply just doesn't exist

all you gota check if u can ping www.google.com from terminal is disabling firefox ipv6 dns lookup in about:config!

cool.... take me about 6 fedora installation to figure this out!:eek:

kalnaren 05-07-2007 08:14 AM

Wow this thread isn't dead yet :P Anyways, I solved the problem in Fedora 5 -turns out it just didn't like my DHCP server in res. I hooked up a router and everything worked fine.

paulpeterj 03-25-2008 03:37 AM

great idea


All times are GMT -5. The time now is 05:10 AM.