LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-07-2008, 11:55 PM   #1
ritam_bkp
Member
 
Registered: Sep 2008
Location: Calcutta,India
Distribution: Fedora 11, OpenSUSE 11.0
Posts: 116

Rep: Reputation: 17
Exclamation fedora problem : "The network has been disconnected"


i have a RealTek Semiconductor Ethernet card (RealTek RTL8168/8111 PCI-E GigabitEthernet NIC ),and D-LINK GLB-502T Modem
when i open System->Admin->Network
and activate my card..there it shows active but at the network applet(that is at the top-right side of the upper task bar) the symbol is disconnected(shows a cross sign in the network icon)..
when i right click that network icon and uncheck and recheck on "Enable netwok" the icon stays disconnected...and this message shows up - "the netwok has been disconnected"....
i use xDSL connection to connect to the internet...when i activate ppp0 along with eth0 at System->Admin->Network ,the internet doess'nt cnnct..

my gateway is 192.168.1.1
my ISP provides dynamic Ip address..to my internet cnnction
my ethernet IP is 192.168.1.2
Netmask - 255.255.255.0
 
Old 10-08-2008, 12:07 AM   #2
indeliblestamp
Member
 
Registered: Feb 2006
Distribution: Fedora
Posts: 341
Blog Entries: 3

Rep: Reputation: 38
You shouldn't need to activate PPP for ADSL connections. Disable it and just keep eth0 activated, you should have connectivity just with that.
After that, try pinging your gateway, a remote ip address like 208.67.222.222, and a domain like google.com. Which ones work?
 
Old 10-08-2008, 12:37 AM   #3
ritam_bkp
Member
 
Registered: Sep 2008
Location: Calcutta,India
Distribution: Fedora 11, OpenSUSE 11.0
Posts: 116

Original Poster
Rep: Reputation: 17
Exclamation

Quote:
Originally Posted by arungoodboy View Post
You shouldn't need to activate PPP for ADSL connections. Disable it and just keep eth0 activated, you should have connectivity just with that.
After that, try pinging your gateway, a remote ip address like 208.67.222.222, and a domain like google.com. Which ones work?
yah...
but my ADSL is bridge connected
hence i have to dial my internet username and password to connect to the internet
hence i use ppp service..
previously i used ubuntu..
there used to be a command "pppoeconf" which determines my eth0 availability nad requires internet username and password (provided by my isp) to connect to the net..

Here my actual problem is probably my network card is never active..
when i try to activate(after a deactivation), ...this msg is shown "The network has been disconnected"
 
Old 10-08-2008, 12:39 AM   #4
indeliblestamp
Member
 
Registered: Feb 2006
Distribution: Fedora
Posts: 341
Blog Entries: 3

Rep: Reputation: 38
Check out /var/log/messages. The last few lines should show the logs of the card being activated. The part after that should show the error thrown when it gets deactivated. That should help narrow down the problem.
 
Old 10-08-2008, 12:45 AM   #5
ritam_bkp
Member
 
Registered: Sep 2008
Location: Calcutta,India
Distribution: Fedora 11, OpenSUSE 11.0
Posts: 116

Original Poster
Rep: Reputation: 17
is SeLiniux messing with my network???
should i deactivate it???
 
Old 10-08-2008, 01:12 AM   #6
ritam_bkp
Member
 
Registered: Sep 2008
Location: Calcutta,India
Distribution: Fedora 11, OpenSUSE 11.0
Posts: 116

Original Poster
Rep: Reputation: 17
Oct 8 17:07:05 localhost avahi-daemon[2356]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.1.5.
Oct 8 17:07:05 localhost avahi-daemon[2356]: New relevant interface eth0.IPv4 for mDNS.
Oct 8 17:07:05 localhost avahi-daemon[2356]: Registering new address record for 192.168.1.5 on eth0.IPv4.
Oct 8 17:07:12 localhost pppd[3953]: pppd 2.4.4 started by root, uid 0
Oct 8 17:07:12 localhost pppd[3953]: Using interface ppp0
Oct 8 17:07:12 localhost pppd[3953]: Connect: ppp0 <--> /dev/pts/1
Oct 8 17:07:12 localhost pppoe[3954]: PPP session is 3726 (0xe8e)
Oct 8 17:07:16 localhost pppd[3953]: CHAP authentication succeeded: Authentication success,Welcome!
Oct 8 17:07:16 localhost pppd[3953]: CHAP authentication succeeded
Oct 8 17:07:16 localhost pppd[3953]: local IP address 59.93.204.186
Oct 8 17:07:16 localhost pppd[3953]: remote IP address 59.93.192.1


in this log my IP address is 59.93.204.186
but i actually i an bot connected to the internet
when i ping google the following shows up -

[root@localhost ~]# ping www.google.com
ping: unknown host www.google.com
 
Old 10-08-2008, 03:54 AM   #7
indeliblestamp
Member
 
Registered: Feb 2006
Distribution: Fedora
Posts: 341
Blog Entries: 3

Rep: Reputation: 38
Can you paste the output of ifconfig -a? Are eth0 and ppp0 up?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2: Screen Resolution can not change from "800X600" to "1024X 768" suhaimi_sj Fedora - Installation 18 12-17-2009 03:29 AM
Fedora 9 add/remove software griping about "no network connection" but firefox works khbkhb Fedora 2 07-04-2008 02:28 PM
Logged in as "root"/Fedora 8 but get "Operation not permitted" when using "chmod etc gosunlee Linux - Newbie 7 02-10-2008 05:56 AM
sshfs error when mounting "remote host has disconnected" thew00t Linux - Server 3 04-14-2007 06:32 AM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 08:31 AM


All times are GMT -5. The time now is 09:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration