LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-05-2011, 12:55 PM   #1
john_erlandsson
Member
 
Registered: Jul 2009
Location: Sweden
Distribution: Fedora
Posts: 70

Rep: Reputation: 1
Fedora network problems.


Hi!

I am unable to find other computers on my local network from my workstation.
Code:
nmap 192.168.0.*
shows me the workstation and the gateway(192.168.0.1)

My workstation has 2 interfaces: eth0 and eth1. both are checked in the "trusted interfaces" section of system-config-firewall
Network is currently connected to eth1.

If i run the same nmap command from my laptop (also fedora), it outputs everything on the network but my workstation.

The strange thing is that the workstation has functioning internet connection.

Any ideas?


//John
 
Old 02-06-2011, 04:31 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
Need some more info:

ifconfig -a
iptables -L -n

Also from the laptop ..
ifconfig -a

cheers
 
Old 02-06-2011, 04:47 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,829

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
fedora has EVERY and all ports "stealth blocked" by default
nmap should not be able to see them in a basic nmap ???.???.???.*

you might want to read
Code:
nmap --help
-- and --
man nmap
 
1 members found this post helpful.
Old 02-07-2011, 06:31 PM   #4
john_erlandsson
Member
 
Registered: Jul 2009
Location: Sweden
Distribution: Fedora
Posts: 70

Original Poster
Rep: Reputation: 1
Thanks for taking an interest.

#ifconfig -a
Code:
eth0      Link encap:Ethernet  HWaddr 00:1E:8C:74:6B:61  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:19 

eth1      Link encap:Ethernet  HWaddr 00:1E:8C:74:70:FA  
          inet addr:192.168.0.77  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:8cff:fe74:70fa/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16549 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12953 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19596136 (18.6 MiB)  TX bytes:1620486 (1.5 MiB)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:17 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:785 (785.0 b)  TX bytes:785 (785.0 b)
#iptables --L -n
Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED 
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     ah   --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     esp  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           state NEW udp dpt:500 
ACCEPT     udp  --  0.0.0.0/0            224.0.0.251         state NEW udp dpt:5353 
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           state NEW udp dpt:631 
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           state NEW udp dpt:137 
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           state NEW udp dpt:138 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22 
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited 

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED 
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited 

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
Left the laptop in my workshop today, but it uses wlan0 and when I last checked it had IP: 192.168.0.8. If that helps.


//John
 
Old 02-09-2011, 04:22 AM   #5
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
Looks like it should work ... try 'nmap -sP 192.168.0.1-254'. Are the other machines connected via wireless or wired ?
 
Old 02-11-2011, 09:36 PM   #6
john_erlandsson
Member
 
Registered: Jul 2009
Location: Sweden
Distribution: Fedora
Posts: 70

Original Poster
Rep: Reputation: 1
Nope, nmap still just shows me the gateway.

There are 2 laptops on the network at the moment. Both are connected via wlan0 and can find each other...
I cant connect to them through SSH either.

How does it make a difference if they are using wireless?
Could the gateway separate the wired and wireless traffic?

//John

Last edited by john_erlandsson; 02-11-2011 at 09:38 PM.
 
Old 02-12-2011, 07:49 AM   #7
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
Depends on how you plugged it in .. it might be firewalling
 
Old 02-12-2011, 08:25 AM   #8
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,027

Rep: Reputation: 69
Also make sure that you're using the same subnet mask as the other computers on the network.
 
Old 02-12-2011, 08:34 AM   #9
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,027

Rep: Reputation: 69
Also make sure that your workstation is accepting ping requests, otherwise on nmap if it doesn't reply to a ping it will not scan it unless you use the nmap -PN option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 9 network connectivity problems valcansa Fedora 1 10-31-2010 07:12 PM
Fedora 9: Problems after removing Network Manager jdw52 Linux - General 4 09-22-2008 08:38 PM
Fedora 5 Network Problems! Frank Soranno Linux - Networking 2 04-17-2006 12:24 PM
Problems setting network configuration in fedora core 4 stephenwalter Linux - Networking 4 08-24-2005 04:43 AM
Network Driver/Internet problems for Fedora Core 1 Tigger"J" Linux - Newbie 6 04-25-2004 04:38 AM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration