LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2014, 09:46 PM   #1
CGBS
LQ Newbie
 
Registered: Nov 2011
Posts: 3

Rep: Reputation: Disabled
Fedora failing to install glibc-headers


I am trying to install glibc-headers via yum, and it keeps failing:
Code:
error: %pre(glibc-headers-2.18-11.fc20.i686) scriptlet failed, exit status 127
Error in PREIN scriptlet in rpm package glibc-headers-2.18-11.fc20.i686
  Verifying  : glibc-headers-2.18-11.fc20.i686                              1/1 

Failed:
  glibc-headers.i686 0:2.18-11.fc20
I am using Fedora 20 with default repositories fully updated
 
Old 01-17-2014, 12:21 AM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,436
Blog Entries: 6

Rep: Reputation: Disabled
Hi:

Try running-
Code:
yum clean all
Than proceed to install again.

In some cases it was a bug-
https://bugzilla.redhat.com/show_bug.cgi?id=543250

Do you have libgcc?
Ensure that your not missing any libraries.

http://pkgs.org/fedora-20/fedora-x86...86_64.rpm.html
http://rpmfind.net/linux/RPM/fedora/...20.x86_64.html
http://forums.fedoraforum.org/showthread.php?t=84520

Hope that helps-
 
Old 01-17-2014, 03:17 AM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,830

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
also are you REALLY installing the 32 bit " glibc-headers.i686"
the i686" means that it is the 32 bit version and not the 64 bit os version
-- both can be installed but different things use them

running this will install the 64 bit version
Code:
su -
yum install glibc-headers
this will install the 32 bit version
Code:
su -
yum install glibc-headers.i686
but installing the -devel rpm might be a bit better
Code:
su -
yum search glibc
------- then from the output ---
yum install glibc-devel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
urgent question install glibc-headers golestani Linux - Software 11 02-03-2010 09:12 AM
Fedora 11 Install failing python assertion airswit Linux - Hardware 2 09-09-2009 11:31 AM
New Fedora 11 Install failing python assertion airswit Fedora 0 09-06-2009 02:42 PM
Glibc w/ 2.6 headers chbin Slackware 4 04-15-2005 09:06 AM
Fedora Core 2 Install failing during package install Sledge Fedora - Installation 1 06-02-2004 10:23 AM


All times are GMT -5. The time now is 06:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration