LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-11-2006, 02:31 PM   #1
lankydenny
LQ Newbie
 
Registered: Jun 2006
Posts: 17

Rep: Reputation: 0
fedora core 5 and windows xp (two SATA drives), grub won't boot winXP


i'm having trouble with fedora core 5 on the computers we built in my lab. i want to dual boot winXP and fc5 off of two SATA drives. after many tries to even get fc5 to boot, i installed it with the following procedure:
1) removed SATA drive 1, where WinXP was/is installed, then set BIOS to boot off second drive
2) proceeded with fedora installation
3) edited grub with:

title Windows XP
rootnoverify (hd1)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1

4) saved, shut down, and re-plugged the XP drive
5) got to grub, clicked on winXP and got a blank black screen and a sustained beep

i have tried to edit grub.conf a thousand times, switching map around, etc. the one thing that seems to get somewhere other than the beep/black is taking away the chainloader command, but that just goes to an error screen.. i think error 11 (sorry, i'm writing this at home). i have searched and searched for what i can do, and find i must post now before FC5 and grub take away further from my research, hehe.

i can boot windows if i change BIOS settings to boot from HD3 as opposed to HD4 (FC5)
one other thing... neither drive is master or slave, for reasons unbeknownst to me.
okay, thanks. sorry about my vagueness. i'll specify tomorrow.
 
Old 06-11-2006, 03:40 PM   #2
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
It's a little hard to be sure exactly what's going on, but my advice would be to put the Windows drive on the first SATA channel, and Linux on the second. Set your BIOS to boot from the first drive (with Windows on). Then, when installing grub, set it to install to the MBR (i.e. the boot sector of the first drive, which has Windows on it). This should help you avoid having to change the mapping.
 
Old 06-11-2006, 03:55 PM   #3
lankydenny
LQ Newbie
 
Registered: Jun 2006
Posts: 17

Original Poster
Rep: Reputation: 0
installing grub? does that mean i should reinstall linux? because if it boots from the windows hd, there is no option for fedora, it simply goes straight to windows.
 
Old 06-11-2006, 04:09 PM   #4
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Hi

I am not sure why you disconnected your drive to install Fedora, but it appears that grub is installed to the first partition of the fedora drive, Check the BIOS and make sure that the windows drive is primary master, and I assume the next disk will be the secondary master.

Your grub file should then look like this:

title Windows XP
rootnoverify (hd0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +

Grub sees drives as hd0, hd1, hd2, etc... for drive 1, 2, 3 and so one.

When install Fedora, there is no need to disconnect the Windows drive. You simply tell the Fedora installer where to install it, in this case it would have been sdb1 (second primary master SATA drive.) Your Windows installation would not have been affected. You would then install grub to the MBR (Fedora would do that for you during installation.)

Hope this helps

Bob
 
Old 06-11-2006, 04:20 PM   #5
lankydenny
LQ Newbie
 
Registered: Jun 2006
Posts: 17

Original Poster
Rep: Reputation: 0
Right... i should have mentioned that. I went through the installation you described, Bob, but it booted straight to Windows (no grub/fedora option). I know that is a more common problem. Right now, grub is on the fedora disk. The fedora disk is the primary master. What i'm looking for is a way to edit grub.conf so that when i choose windows in the grub menu, it doesn't just beep loudly or return to grub or show an error message. i noticed you put

chainloader +

where i was putting

chainloader +1

is that a typo on your part, or intentional?
 
Old 06-11-2006, 04:21 PM   #6
lankydenny
LQ Newbie
 
Registered: Jun 2006
Posts: 17

Original Poster
Rep: Reputation: 0
thanks for giving me advice, by the way
 
Old 06-11-2006, 04:43 PM   #7
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
sorry. that was a copy and paste typo. I have exactly the same setup as you do (two SATA drives). I have Windows on the primary master and linux on the secondary master. I do not know if this will work you, but I not use the mapping information for Windows. My entry for Windows in grub.conf simply looks like this:

title WinXP
rootnoverify (hd0,0)
chainloader +1

It loads Windows for me just fine. However, if Linux is on the primary, you would have to change the (hd0,0) to (hd1,0).

Hope this helps
 
Old 06-11-2006, 04:51 PM   #8
lankydenny
LQ Newbie
 
Registered: Jun 2006
Posts: 17

Original Poster
Rep: Reputation: 0
thank you very much. i'll try that tomorrow.
something strange though... your grub is installed on your windows drive, on the MBR, correct?
well, i tried that in my first installation. i'm sure it was on the MBR, but it just went straight to windows. any ideas?
 
Old 06-11-2006, 06:11 PM   #9
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Yes, it means the entry in grub was not properly configured for linux. This is my entry for FC in Grub:

title Fedora Core 5
root (hd1,1)
kernel /boot/vmlinuz-2.6.16-2122_FC5 ro root=/dev/sdb1 rhgb quiet
initrd /boot/initrd-2.6.16-FC5.img

If the paramters are correct in grub, it will boot linux fine. If you have a boot floppy (or the install disk) you can boot into linux to adjust the grub conf. file. If you have trouble, post your grub.conf file and we can advise.

Hope this helps

Bob
 
Old 06-11-2006, 06:12 PM   #10
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Yes, it means the entry in grub was not properly configured for linux. This is my entry for FC in Grub:

title Fedora Core 5
root (hd1,1)
kernel /boot/vmlinuz-2.6.16-2122_FC5 ro root=/dev/sdb1 rhgb quiet
initrd /boot/initrd-2.6.16-FC5.img

If the paramters are correct in grub, it will boot linux fine. If you have a boot floppy (or the install disk) you can boot into linux to adjust the grub conf. file. If you have trouble, post your grub.conf file and we can advise.

Hope this helps

Bob
 
Old 06-11-2006, 06:53 PM   #11
lankydenny
LQ Newbie
 
Registered: Jun 2006
Posts: 17

Original Poster
Rep: Reputation: 0
so if i put in the install disk, i do linux rescue and edit grub.conf there?
thanks
 
Old 06-11-2006, 07:08 PM   #12
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,842

Rep: Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823
What you did (originally) was fine - unnecessarily convoluted as mentioned, but fine.
Change the XP entry to rootnoverify(hd1,0) and see how you go.
Presumes XP on first partition - adjust as needed.

You can do this from the grub menu as a test - merely follow the prompt (Highlight and hit "e").

<EDIT> d'oh; fixed up disk reference.

Last edited by syg00; 06-11-2006 at 07:09 PM.
 
Old 06-12-2006, 12:26 PM   #13
lankydenny
LQ Newbie
 
Registered: Jun 2006
Posts: 17

Original Poster
Rep: Reputation: 0
okay, tried

title Windows XP
rootnoverify(hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1

Got Error 13: Invalid or Unsupported Executable format

is grub trying to boot windows and failing because it's ntfs?
 
Old 06-12-2006, 05:21 PM   #14
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Error 13 simply means grub was looking for Linux and got Windows, so you are partly right. It means the mapping is not yet correct. As I suggested in my previous post, why don't you try setting grub for Windows like this:

title WinXP
rootnoverify (hd1,0)
chainloader +1

This simply directs grub to that location on that hard drive. If it does not work, it means the rootnoverify should be (hd0,0). This works fine for me and it should work for you.

Bob
 
Old 06-12-2006, 06:33 PM   #15
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,842

Rep: Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823
@Bob, XP won't boot from a slave without the map directives.

@lankdenny, possibly a vendor recovery partition - that's why I said "adjust as needed".
Try (hd1,1), and if that fails, post the output of this (Linux) command - "fdisk -l" (ell, as in list).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora core 5 and windows xp (two SATA drives) , grub won't boot winXP lankydenny General 4 06-11-2006 03:14 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 02:44 PM
Boot WinXP (on SATA) from GRUB (on PATA?) sbixby Linux - Newbie 3 04-30-2004 11:40 AM
Fedora Core 1 and SATA drives ThatEvoGuy Fedora 2 03-19-2004 11:39 AM
Does Fedora core 2 support Sata drives u165839 Fedora - Installation 1 02-21-2004 02:03 PM


All times are GMT -5. The time now is 12:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration