LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-05-2004, 04:25 PM   #1
MrVorik
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
Fedora Core 2 does not play midi files!


Hello all,

I've been racking my brain on trying to figure out why I can't play midi files on my machine. After doing some research, I've found that really only one card has onboard hardware wave tables for midi and that is the SoundBlaster Live. However I do not have such a card. I'm using my Shuttle gBox cube onboard sound (aka VIA chipset 8233 AC'97). I've been able to play wave files and mp3's with ease (of course after adding the patch to xmms for mp3 support). Though, as soon as I use "kmid" to play a midi file through the terminal window, it states "There are no midi ports".

To remedy this situation, I have ran /usr/sbin/alsaconf, which by the way did not come with fc2. I downloaded a later version of alsa-utils which did come with alsaconf. Alsaconf modified my /etc/modprobe.conf as listed below:

===================================

alias eth0 8139too
alias snd-card-0 snd-via82xx
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.5 ---
alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-via82xx
# --- END: Generated by ALSACONF, do not edit. ---

# Edited to add suppport for midi
# July 5th, 2004 test
#alias snd-card-1 snd-mpu401
#options snd-mpu401 port=0x330 irq=11
#alias sound-service-1-0 snd-mixer-oss
#alias sound-service-1-1 snd-seq-oss
#alias sound-service-1-3 snd-pcm-oss
#alias sound-service-1-12 snd-pcm-oss

# Configure card 1 (second card) as a virtual MIDI card
alias snd-card-1 snd-virmidi
alias sound-slot-1 snd-card-1

==================================
This did nothing to make my computer to be able to play midi files.

I then read several usergroup posting by other individuals, researched alsa's website for the via 82xx configuration and tried a few things. I manually added the entry for "Configure card 1" and "Edited to add support for midi" in attempts to make midi work. The closest thing I've been able to do is to run the command "/sbin/modprobe snd-virmidi". At least after that, kmid thinks I have a midi port. Then when I play midi files it looks like it's playing; I just have no sound. I checked the mixer and everything is up (especially PCM volume which i think is the one for midi as well as mp3/wav).

It seems that everyone is referencing a /etc/modules.conf that does not exist on my machine. It seems that kernel 2.4 has this, but modules in kernel 2.6 are different.

HELP!!! I'm quite disappointed that Fedora out of the box can't play midi. Is this problem more simple than I'm making it to be???

Thanks in advance.
 
Old 07-05-2004, 10:38 PM   #2
spuzzzzzzz
Member
 
Registered: Sep 2003
Location: Australia
Distribution: Gentoo
Posts: 465

Rep: Reputation: 30
Most midi players require hardware support for midi. If you hardware doesn't support it, try using timidity. It plays midi files using the PCM output, so it will work if your sound card can play normal sounds.
 
Old 07-06-2004, 12:13 AM   #3
MrVorik
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the reply spuzzzzz.

Later on today I have discovered the only way to play midi files (as you suggest) is via a software synthesizer such as "Fluidsynth" or "Timidity". I downloaded the timidity source and compiled it with the alsa options in order to run it as an alsa server. After a length process of installing supporting headers and development rpms, I compiled timidity. I was able to get it to run and the system does recognize it as a midi port, however Rosegarden and Kmid still don't work. This audio stuff is way over my head....whew....lol

Plans are to research timidity a bit further to get it working. Since most sound cards don't have hardware for midi sequencing, why doesn't RedHat put a fully configured timidity (or fluidsynth) in Fedora? Doesn't anybody else want to play midi files! =)

I'm learning more and more each day. Maybe by the end of the week I can get Timidity to work.

ps...
I was able to issue the command "timidity -Od filename.mid" and here the midi files from the shell. So at least that works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound with MIDI files in kmid - Fedora Core 4 PeterRJG Linux - Newbie 1 08-06-2005 04:08 AM
Cannot play MIDI files! koolgentoo Linux - Hardware 2 07-24-2005 08:26 AM
I need to play midi files... trey85stang Linux - Software 2 02-27-2005 12:06 PM
How to play MIDI files: needed a MIDI mapper? vharishankar Linux - General 3 12-30-2004 01:12 AM
Cannot play midi files... djib Linux - Laptop and Netbook 1 12-04-2004 08:46 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration