LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2009, 10:51 AM   #1
Dims
Member
 
Registered: Feb 2009
Posts: 151

Rep: Reputation: 15
Fedora 9: time always wrong after reboot


The tyme on my system is always wrong after reboot.

ntpdate time.nist.gov

set correct time. Hence timezone settings are valid.

But after reboot I have wrong time again (12 hours shifted).

Where I can put time.nist.gov as a time server to sync?
 
Old 06-12-2009, 11:20 AM   #2
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Rep: Reputation: 35
tzdata

This sounds possibly like your tzdata files are messed up, or you have not chkconfig'd ntp, so it start up automatically and runs periodically.
 
Old 06-12-2009, 01:28 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
by chance do you also have MS windows installed in a dual boot ??
linux likes to set the computer's clock to UTC and Microsoft sets in to your LOCAL time
 
Old 06-12-2009, 02:37 PM   #4
Dims
Member
 
Registered: Feb 2009
Posts: 151

Original Poster
Rep: Reputation: 15
I have removed all default NTP servers from ntp.conf and inserted *.gov -- and it started to work

Code:
#server 0.fedora.pool.ntp.org
#server 1.fedora.pool.ntp.org
#server 2.fedora.pool.ntp.org
server time.nist.gov
Looks like the time was wrong on one of the server (am/pm mixed).

How to query NTP server?
 
Old 06-12-2009, 02:38 PM   #5
Dims
Member
 
Registered: Feb 2009
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by John VV View Post
by chance do you also have MS windows installed in a dual boot ??
No, no Windows, single OS.
 
Old 06-12-2009, 02:40 PM   #6
Dims
Member
 
Registered: Feb 2009
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by cmnorton View Post
you have not chkconfig'd ntp, so it start up automatically and runs periodically.
You are right, it is off in chkconfig. But why it worked wrong then? Why it was forget my date command effect?
 
Old 06-15-2009, 10:45 AM   #7
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Rep: Reputation: 35
Try config

Try fiddling with the configuration file and running the command manually.
 
Old 07-16-2009, 12:49 AM   #8
wintercarver
LQ Newbie
 
Registered: Mar 2005
Location: san francisco/portland
Posts: 12

Rep: Reputation: 0
This is probably way too late a response, but, check the bottom of this article with regard to setting your hardware clock and the associated comments:
http://www.debianadmin.com/ntp-serve...in-debian.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
syslog time wrong - but date returns the correct time? falc410 Linux - Newbie 5 11-09-2013 05:54 AM
system clock wrong after reboot hank43 Linux - Software 3 03-09-2007 03:50 AM
my time is wrong and calender is also wrong Paxmaster Linux - General 6 12-16-2004 01:46 AM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 04:25 PM
Fedora Core 1 Clock shows the wrong time. mwolff Linux - Newbie 6 04-01-2004 03:03 PM


All times are GMT -5. The time now is 12:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration