LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-24-2008, 04:04 PM   #1
sneaky
Member
 
Registered: Aug 2008
Distribution: Fedora 9 Server
Posts: 51

Rep: Reputation: 15
Fedora 9 phpMyAdmin problems after install


I have installed phpMyAdmin and I can contact the index page but it is just showing the php code and not the GUI.

All help appreciated.

Thanks

Chris
 
Old 08-24-2008, 08:07 PM   #2
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Silly question: are you sure PHP is installed and enabled in your web server?
 
Old 08-24-2008, 08:11 PM   #3
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You will also need to install php-mysql (use package manager or "yum install php-mysql" as root)
 
Old 08-25-2008, 03:47 AM   #4
sneaky
Member
 
Registered: Aug 2008
Distribution: Fedora 9 Server
Posts: 51

Original Poster
Rep: Reputation: 15
mjmwired how would I do/check that, I used the perfect server setup from fedoraproject so I presume so.

billymay that was already upo date and installed but thanks for your reply.

Chris

Last edited by sneaky; 08-25-2008 at 03:52 AM.
 
Old 08-25-2008, 07:56 AM   #5
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
What is the output of:
# rpm -qa | grep 'httpd\|php\|mysql'

You should have at least: mysql-server, php, httpd, php-mysql
If not:
# yum install mysql-server php httpd php-mysql

Then start(or restart) everything:
# /etc/init.d/mysqld restart
# /etc/init./httpd restart

Create a file 'test.php' with the following code:
Code:
<?php
phpinfo();
?>
And place it where Apache can see it (/var/www/html for example)
then load it (http://localhost/test.php for example).
This should show all your PHP setup/configuration.

Last edited by mjmwired; 08-25-2008 at 07:57 AM.
 
Old 08-25-2008, 08:05 AM   #6
sneaky
Member
 
Registered: Aug 2008
Distribution: Fedora 9 Server
Posts: 51

Original Poster
Rep: Reputation: 15
rpm comesback with nothing goes back to the #

yum command goes thru update process - everything is current version and says nothing to do

ran the test.php and just comes back with the text that was typed into test.php.

This is bizarre - I setup the server as per perfect fedora 9 server.

Chris
 
Old 08-25-2008, 10:32 AM   #7
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
If you haven't done the following, try this:

In the httpd.conf file in /etc/apache/ remove the hash mark (#) from before mod-php. Also add to Directory Index: index.php Add .httpd-php .php, to Add Type Application.
 
Old 08-25-2008, 10:53 AM   #8
sneaky
Member
 
Registered: Aug 2008
Distribution: Fedora 9 Server
Posts: 51

Original Poster
Rep: Reputation: 15
The httpd.con file is in the /etc/httpd/conf

couldn't find mod-php in the file

already had index.php in the file.

what is the exact syntax of what I add to application type.

Is it this.

AddType application/.httpd-php .php

Still isn't working.

Thanks

Chris

Last edited by sneaky; 08-25-2008 at 10:55 AM.
 
Old 08-25-2008, 11:27 AM   #9
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Here's the entry copied from my httpd.conf. Not really sure that this is the problem though, looks like you have those entries.

AddType application/x-tar .tgz .httpd-php .php

Do you have the following line in httpd.conf, it's at the bottom of the file?
Include /etc/apache/mod_php.conf
 
Old 08-25-2008, 11:34 AM   #10
sneaky
Member
 
Registered: Aug 2008
Distribution: Fedora 9 Server
Posts: 51

Original Poster
Rep: Reputation: 15
I have made some progress.

In the Perfect server setup if you are using ispconfig you comment out the addtype and a couple of other bits and pieces to disable php. But I haven't been able to install ispconfig but I had commented out the bits and pieces. I have uncommented them and have had success.

It is point 13.1 and the file is /etc/httpd/conf.d/php.conf.

Thanks for the help.

Chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
403 Errors with phpmyadmin on Fedora Core 6 Cold Coffee Linux - Server 3 03-06-2008 04:12 AM
phpmyadmin install problems DigitalFirefly Linux - Server 9 11-18-2007 10:04 AM
phpMyAdmin problems Dsupreeme Linux - Server 1 10-07-2006 09:03 AM
fedora and phpmyadmin fuelinjection Linux - General 4 10-17-2005 09:55 PM
mysql / phpmyadmin & fedora fuelinjection Linux - General 2 06-20-2005 11:28 PM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration