LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-22-2008, 06:24 PM   #1
houndhen
Member
 
Registered: Aug 2006
Location: Alabama
Distribution: pclos, Win 7, Linux lite, Window XP
Posts: 80

Rep: Reputation: 15
fedora 8 sound error but still have sound


Have f8 installed and working great but keep getting sound error right after login. Sound still works but I don't know enough to sort out where the cause of the error originates.

Here is the error message:
Quote:
Error while initializing the sound driver:
device: default can't be opened for playback (Connection refused)
The sound server will continue, using the null output device.
Any suggestions about where to start would be appreciated.
 
Old 01-23-2008, 02:03 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
Quote:
Originally Posted by houndhen View Post
Have f8 installed and working great but keep getting sound error right after login. Sound still works but I don't know enough to sort out where the cause of the error originates.

Here is the error message:


Any suggestions about where to start would be appreciated.
as root type alsaconf then let it set up the card and you will be fine.
 
Old 01-24-2008, 07:46 AM   #3
houndhen
Member
 
Registered: Aug 2006
Location: Alabama
Distribution: pclos, Win 7, Linux lite, Window XP
Posts: 80

Original Poster
Rep: Reputation: 15
Sound error

Thanks, Drakeo. I will try that and see what happens. Thanks for the reply. I was wondering if maybe I had missed something obvious and should have known what to do. Since I am new to linux, I read a lot of posts and howtos but haven't found a solution that will rid me of my error popping up each boot.
thanks,
houndhen
 
Old 01-24-2008, 07:13 PM   #4
houndhen
Member
 
Registered: Aug 2006
Location: Alabama
Distribution: pclos, Win 7, Linux lite, Window XP
Posts: 80

Original Poster
Rep: Reputation: 15
command not found!

Drakeo, When I type alsaconf I get 'command not found'. I did a search for alsa* and there is a file named alsa.conf in the /etc folder. I also typed 'alsa.conf' but still got "command not found". What should that be telling me?
 
Old 02-04-2008, 01:29 AM   #5
tktim
Member
 
Registered: Mar 2003
Location: USA-Los Angeles, California
Distribution: Fedora 15
Posts: 119

Rep: Reputation: 16
add /sbin/ to command. Commands are in sbin directory.

/sbin/alsaconf
 
Old 02-04-2008, 08:36 PM   #6
houndhen
Member
 
Registered: Aug 2006
Location: Alabama
Distribution: pclos, Win 7, Linux lite, Window XP
Posts: 80

Original Poster
Rep: Reputation: 15
still not working

Here is the output from Konsole when trying the alsaconf command:
Quote:
[root@localhost harold]# /sbin/alsaconf
bash: /sbin/alsaconf: No such file or directory
[root@localhost harold]#
I looked in the sbin folder and this is the listing of the 'a' group up to the start of the b group:
Code:
accton
addpart
agetty
alsactl
arp
arping
audispd
auditctl
auditd
aulastlog
aureport
ausearch
autrace
avmcapictrl
badblocks
I did a search for the file alsaconf and didn't get a hit. Could that be part of the problem, the fact that I don't have the file alsaconf?
 
Old 02-05-2008, 02:08 AM   #7
tktim
Member
 
Registered: Mar 2003
Location: USA-Los Angeles, California
Distribution: Fedora 15
Posts: 119

Rep: Reputation: 16
I assumed the alsaconf was a good command.(It doesn't work on my pc either.) I've found most commands have to have the /sbin/ in front of them. One command that displays a list of pci devices on your pc screen is lspci. It works at the user level or root level for me but only with /sbin/ otherwise you get the error can't find command. /sbin/lspci
Fedora just switched to Pulseaudio for sound server, so maybe this error will be fixed shortly with an automatic update. I have a different sound error. So far I'm just waiting for a Fedora 8 specific update. Think I may have to add my self to some types of "groups" (pulse-rt? or pulse-access? or pulse? or Jack?)on my pc to correct error, but not sure yet. http://pulseaudio.org/
 
Old 02-05-2008, 09:09 AM   #8
houndhen
Member
 
Registered: Aug 2006
Location: Alabama
Distribution: pclos, Win 7, Linux lite, Window XP
Posts: 80

Original Poster
Rep: Reputation: 15
sound error

Actually tktim, since I started this thread, I put a check in the box so the error message wouldn't show up any more. My sound is working fine. I think that I have had a sound update. I know that I have had quite a few updates lately. Thanks for efforts by yourself and Drakeo in addressing this issue with me. It helps greatly in my learning process to get ideas and information from others that probably are more knowledgeable than myself. I am basically a newcomer to Linux. Anything that I can add to my computer knowledge is appreciated.

Thanks,
Harold
 
Old 02-05-2008, 09:48 AM   #9
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
Ok when the sound server crashes it resets. there is a reason for this if it is not used in like 60 seconds it goes down so any other program can use it. go into your sound system and make sure it is set to defaults. if for some reason it may be set for to much stuff. I get the crash onces in awhile during boot up this is caused by KDE the sound server is starting at the exact same time KDE is loading and KDE will try and take the server at that point.it crashes resets and kde is now using it. for the next 60 seconds or until another program like gxine or any other media player wants it. It never really crashes it is just a program that says print this message that there has been two or more programs colliding at the same ram point.the sound server can only be run by one program at a time this is a load bug and will not be fixed so as you can see the messages is correct CRASH
 
Old 02-05-2008, 09:52 AM   #10
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
as root alsaconf
 
Old 02-05-2008, 04:08 PM   #11
tktim
Member
 
Registered: Mar 2003
Location: USA-Los Angeles, California
Distribution: Fedora 15
Posts: 119

Rep: Reputation: 16
houndhen: You might find this helpful.
Right click “Applications”, click Edit Menus, click System, click Preferences, "check" Control Center, click Close. Then click System from drop down at top of screen, click Preferences, click Control Center. This allows you to control about 30 to 40 items in one spot.

Drakeo: (Thanks for your help.) I've tried the command at both the user lever and root (used my root password to go to root. - I'm sure I'm at root.) Both with and without /sbin/. Always says can't find command. The Control Center has a Sound Icon, Volume Control(Alsa mixer) Icon and a Soundcard Detection Icon, etc. I think the Soundcard Detection Icon may be the same or simular to alsaconf. It allows you to configure your soundcard.
 
Old 02-06-2008, 02:58 AM   #12
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
glad you got it going.I have not been using FC8 in a while I am a slackware person and as you know slackware you use the terminal a little more then the GUI so I will have to Bone up on some mor of the Gui distros. But I like to know what comes up when you type als then push the tab button this will show all the comands for als. mine comes up alsaconf alsactl alsamixer alsawizard. just curious how FC8 has edited ther commands
 
Old 02-07-2008, 12:53 AM   #13
deejxue
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Rep: Reputation: 0
same error message, alsa commands

I'm getting the same error. I found this thread looking for any known issues or fixes.

I found the following alsa commands (also on Fedora8):

alsacard; alsactl-advanced controls fof ALSA soundcard driver; alsamixer- soundcard mixer for ALSA coundcard driver, alsaunmute.

First try with alsacard barfed, got a connection error, used GUI to force reload of drivers and configuration, rebooted. No more error, but now I have no sound. Alsa driver ver 1.0.15, lib- alsa-lib-1.0.15-1.fc.8, utils- alsa-utils-1.0.15-1.fc.8.

Will look to see if these were just updated and maybe try rolling back to previous version if so. I need my sound to listen to a lecture.
 
Old 02-07-2008, 11:30 PM   #14
tktim
Member
 
Registered: Mar 2003
Location: USA-Los Angeles, California
Distribution: Fedora 15
Posts: 119

Rep: Reputation: 16
My Soundcard:
Vendor:Intel Corp,
Model:82801H (ICH8 Family) HD Audio Controller
Module:snd-hda-intel
ALSA Driver ver 1.0.15,
ALSA Lib package- alsa-lib-1.0.15-1.fc.8,
ALSA Utils package- alsa-utils-1.0.15-1.fc.8.
.
Under Control Center are 3 Icons 1)"Volume Control" unmute each. 2) "Sound" enable software sound mixing(ESD), also set most to Autodetect, Can test each item here. 3.)"Sound Card Detection" test,settings,etc., can also generate two reports here for trouble shooting. Under(drop down)Applications/Sound&Video/PulseAudio Volume Control unmuted.
 
Old 02-08-2008, 06:56 AM   #15
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
as I explained before it was not a sound card issue . now it is. befor it was two programs at startup trying to control the sound system it then crashed reset then used the desk top program. now you will have to go back and enable it in your gui what is F8 using kde or gnome not sure. but at this point you should reconfigure the card module make sure it is loaded the correct one make sure it is the correct one then do a alsactl that is the program that saves your setting and keeps it in your /etc/asoundstate. when you reload the configuration for your module it is kept in the /etc/modprobe.d/sound open that and you should see your card module. if it is incorrect then do a alsacard. this can be done also in gui. what is F8 using yum yeast or some interface program. and make sure it is not muted.
good luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5 with Sound Blaster NX USB driver fails to sound maybi7 Linux - Hardware 1 10-26-2006 04:31 PM
Alsa Sound Error: reduced sound to stereo from 5.1 after kernel upgrade vmt1 Linux - Hardware 1 06-03-2006 12:35 PM
Sound server informational message: Error while initializing the sound driver... LA004 Linux - Hardware 4 08-21-2005 09:25 PM
Sound Card on Fedora Core 2 only playing test sound silverado0103 Linux - Hardware 0 07-29-2004 04:23 PM
No Sound : request_module: failed /sbin/modprobe -- sound-slot-0. error = 256 Mebuh Linux - General 0 01-26-2004 08:51 AM


All times are GMT -5. The time now is 08:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration