LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 11-13-2004, 05:31 PM   #1
badsykes
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
fedora 3 get stuck at 'configuring kernel parameters' message at boot


Hello
I've just installed the Fedora 3 and of course i wanted the latest drivers for nvidia gf2 pro so i tried to install them...I do something wrong i know this.Here what i've done and the order:
1.downloaded the latest Ia32 linux driveres from nvidia website.
2.i used 'init 3' command to quit from 'X'
3.i installed the package normally
4.at this point normally i must edit the xorg.conf file from comand prompt but i didn't remember the directory and the whole modifications read on internet before 'init 3' command and i enter again in X interface and i edited the file from there.
5.i removed the line wich reffer to 'dri' and added instead of 'nv' the 'nvidia' word and reboot

After every rebootthe system get stuck at this message 'configuring kernel parameters' and a command prompt.How can i recover from this error.i don't know what to write at that prompt

Last edited by badsykes; 11-13-2004 at 05:32 PM.
 
Old 11-13-2004, 11:55 PM   #2
bsteele.com
LQ Newbie
 
Registered: Mar 2003
Distribution: redhat
Posts: 2

Rep: Reputation: 0
I had the same thing.

see: http://www.nvnews.net/vbulletin/showthread.php?t=40404

note that there are typo's in the receipe there. i've corrected it a bit below:

enter init 3,
#modprobe nvidia
#cp -a /dev/nvidia* /etc/udev/devices
#chown root.root /etc/udev/devices/nvidia*

save a copy of xorg.conf:
#cp /etc/X11/xorg.conf /etc/X11/xorg.conf.original
change /etc/X11/xorg.conf per /usr/share/doc/NVIDIA_GLX-1.0/README

in particular: find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist.


reboot
success

this is all magic to me but it's part of the new udev stuff. it's new but at least i didn't have to re-compile the kernel.

bob

Last edited by bsteele.com; 11-13-2004 at 11:59 PM.
 
Old 11-15-2004, 09:10 AM   #3
badsykes
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Original Poster
Rep: Reputation: 0
man ...i can't boot the system man....so i can't corect the problems in that file because in xorg.conf file when i edit it with vi or pico i can't see any lines....i think i will reinstall it
 
Old 11-16-2004, 04:10 AM   #4
pfarner
LQ Newbie
 
Registered: Nov 2004
Distribution: fedora
Posts: 1

Rep: Reputation: 0
> man ...i can't boot the system man....so i can't corect the problems

When I noticed a problem, I tried adding "selinux=0 single" to the kernel args (using the grub bootloader, with the "a" key). I was able to log in. I then tried with just "selinux=0", and it hung again. So the "single" (for a single-user shell) seems to be the relevant part. Try adding "single", and then when it gives you that shell you could edit files or (as I did) just exit the shell and let it boot. It came up fine, with the exception of the X server.

This is all with a vanilla Fedora Core 3 modified only to use nvidia's binary driver and with TwinView options in the xorg.conf.

Hope that helps.
 
Old 11-17-2004, 03:18 PM   #5
Ikebo
Member
 
Registered: Jun 2004
Location: Michigan, USA
Distribution: Ubuntu
Posts: 77

Rep: Reputation: 15
I was stuck unable to boot with the same situation. Burn the FC rescue CD and boot from it.
 
Old 11-18-2004, 04:03 AM   #6
beltandpants
LQ Newbie
 
Registered: Nov 2003
Posts: 11

Rep: Reputation: 0
RHGB

Hey, you don't need to use the recovery disk to boot up. Your computer is hanging when it tries to start up that fancy Red Hat Graphical Boot screen. When the grub menu comes up, hit "a" to edit the boot parameters for your kernel. All you need to do is remove the "rhgb" term, that'll let you boot to a command prompt so that you can fix the problem.

Last edited by beltandpants; 11-18-2004 at 04:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Struck at "Configuring Kernel Parameters " in Fedora core 3 booting infantpapa Linux - Software 12 06-03-2005 05:42 PM
Struck with "configuring kernel parameters" at boot in Fedora core 3 infantpapa Linux - Software 1 12-18-2004 11:12 AM
boot hangs at "configuring kernel parameters" desecrated Fedora 2 12-08-2004 08:11 PM
Boot stuck at 'Configuring kernel params...' linuxify Mandriva 0 02-16-2004 03:33 PM
boot stuck at 'Configuring kernel params...' linuxify Linux - Newbie 0 02-16-2004 12:39 PM


All times are GMT -5. The time now is 08:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration