LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-30-2015, 02:35 PM   #1
tnandy
Member
 
Registered: Oct 2003
Location: Tennessee
Distribution: Fedora 22, CentOS
Posts: 169

Rep: Reputation: 15
Fedora 21 hangs on boot after YUM update


This morning I was watching some online TV shows on CBS.com. After watching two shows, I tried to watch a third. Instead of a video, I got a screen saying I needed to install Adobe Flash. Obviously, Adobe Flash was already installed--that's how I had watched the first two videos. I decided maybe the problem was CBS wanted a later version of Flash. That's when I ran the YUM update.

Everything seemed to download OK except for firefox. It must have been downloading from a mirror somewhere on the other side of the planet because the download rate was something like 7kb/s. The ETA was something like two hours. I decided to end that terminal session and started the YUM update over again. This time it recognized it had already downloaded all the other packages and the download for firefox was several hundred kilobytes per second. After that the update seemed to go OK.

Unfortunately, when I rebooted and chose the new kernel in the grub list, the boot appears to hang just before I'm supposed to get a login screen. Normally, booting takes only a minute or so, but now all I get is a blinking cursor in the upper left corner, even after waiting 10 minutes. I hit the power switch to turn the computer off and rebooted.

This time I hit the escape key to watch the boot progress. These are the last three lines:
[ OK ] Started Command Scheduler
Starting Terminate Plymouth Boot Screen...
Starting wait for Plymouth Boot Screen to quit...

Then it hangs. Hitting the escape key has no effect. CTRL-ALT-DEL reboots.

According to grub, the newly updated kernel version is: Fedora (3.19.5-200.fc21.x86_64) 21 (Twenty One)

I tried another YUM update. Here's the results:
[root@XXXXX ~]# yum update
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* fedora: fedora.mirrors.tds.net
* rpmfusion-free: mirror.us.leaseweb.net
* rpmfusion-free-updates: mirror.us.leaseweb.net
* rpmfusion-nonfree: mirror.us.leaseweb.net
* rpmfusion-nonfree-updates: mirror.us.leaseweb.net
* updates: repo.atlantic.net
No packages marked for update
[root@XXXXX ~]#

I had been using the video driver available on nVidia.com on the previous kernel. (That kernel still works because I'm able to type this.) It's very likely not the latest version of video driver since it has been a while since I installed it. Could this have something to do with the hang?

What should I try to do next? Thanks for reading this.

Last edited by tnandy; 04-30-2015 at 02:43 PM.
 
Old 04-30-2015, 03:42 PM   #2
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 614
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
Probably not your video driver. It sounds like you have two or three separate problems going on here.

So try this:
- Make sure you have kernel-headers for your kernel version installed.
- Update your nVIDIA driver, and make sure it's compatible with your kernel. If it's not, you may be using CentOS for a while.
- Make sure Flash is installed, use this if you need help. You could have been watching HTML 5 videos.
- Delete all your user settings, as it could be a problem with how GNOME got configured. (Just delete everything in your home folder that begins with a .) This will reset everything, so you may want to make a backup in case this isn't it.
- Run fsck to make sure nothing got corrupted. (Tutorial if you need it)

Hope this helps!
 
Old 04-30-2015, 03:57 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
first there IS NO!!!!! new version of the linux flash
none
adobe killed off linux and apple flash
adobe is basically a MICROSOFT ONLY company now

-- nothing new well ever be added to it , just some security fixes ? maybe?

Quote:
I decided to end that terminal session and started and started the YUM update over again.
not good
a partly updated system might NEVER EVER BOOT EVER AGAIN
( that is why you never run a update during a thunder storm )


Quote:
Unfortunately, when I rebooted and chose the new kernel in the grub list,
that would be the default that you did not have to do anything to auto boot into


BINGO!!!!!!!
THIS IS YOUR PROBLEM!!!!!
Quote:
I had been using the video driver available on nVidia.com
the .run is a MANUALL INSTALL!!!!!
i take it you did not fallow ALL the expert advice and use the kmod-nvidia.rpm in the rpmfusion repo

the kmod-nvidia.rpm it the RECOMENDED driver and NOT the manuall .run

for the .run you MUST!!!! manually do a bunch of things
and REDO THEM !!!! for EVERY AND ALL!!! updates that include
the "kernel" , "xorg/X11", and "mesa"

EVERYTIME!!!! there is a kernel update ( almost EVERY !!! AND ALL updates for fedora
you MUST!!! reinstall the .run
in a TEXT ONLY!!! boot


now you might also have more issues
if you are seeing the Plymouth boot screen you still have the "Nouveau" driver instyalled and NOT blacklisted

the NVIDIA.run driver will add a blacklist BUT
the file might not be seen by fedora
( this is why the kmod-nvidia is RECOMMENDED )

1)
make sure that the Nouveau driver is uninstalled and blacklisted
2)
rebuild the boot image WITHOUT THE NOUVEAU DRIVER !!!
3)
install the kernel-devel and development tools ( gcc & autotools )
Code:
su -
yum groupinstall "development Tools"
yum install kernel-devel
4)
download and save the .run driver FOR your card ( you have to figure that out all on your own using the nvidia site )
save it to /
5)
run the installer
after the installer finishes ( WITH NO ERRORS )
6)
REINSTALL ALL OF MESA!!!!!!!!!!!!!
the .run REPLACES SYSTEM FILES!!!!
you have to change them BACK
Code:
su -
yum reinstall mesa*
the mesa-devel MUST BE REINSTALLED!!!!!!



personally if you have not been using the .run for 10+ years
USE THE kmod-nvidia.rpm driver !!!!


SEE: the fedora nvidia guide
http://www.forums.fedoraforum.org/sh...d.php?t=280750

Last edited by John VV; 04-30-2015 at 04:04 PM.
 
Old 05-04-2015, 10:31 AM   #4
tnandy
Member
 
Registered: Oct 2003
Location: Tennessee
Distribution: Fedora 22, CentOS
Posts: 169

Original Poster
Rep: Reputation: 15
I think if I could change the runlevel to 3, I might just get a text root login. If I could get a text root login, I believe I could run the nVidia driver script on the updated kernel.

Unfortunately, somebody got rid of /etc/inittab (WHICH WAS WORKING JUST FINE AND I KNEW HOW TO FIX IT. UGH. WHY DO PEOPLE CHANGE THINGS LIKE THIS?!? JUST TO CONFUSE ME?!? THEY DID THE SAME THING WITH GRUB...IT USED TO BE EASY TO GEDIT GRUB.CONF. NOW I HAVE TO MONKEY WITH HALF A DOZEN FILES AND IT STILL DOESN'T DO WHAT I WANT. I HAD TO SWITCH TO MATE BECAUSE THEY TOTALLY SCREWED UP GNOME. KEEP IT SIMPLE, STUPID!!!!!!! IF IT AIN'T BROKE, DON'T FIX IT!!!!!!!! GRRRRR... OK. Rant over. Sorry.)

When I looked at /etc/inittab, it said something about setting the target runlevel, but was entirely unclear as to how this works now.

By the way, now that firefox and flash have updated, the show that failed to play earlier on CBS.com now plays just fine on the previous (not updated) kernel.
 
Old 05-04-2015, 11:54 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
fedora has been using GRUB2 for many many years now ( fedora was the FIRST i think to use GRUB2 )
not the old grub0.9

but
you can STILL add a " 3" to the end of the boot line by hitting "e" during the 3 second count down BEFORE it boots
( you did keep that 3 sec. count down ? )

but you really SHOULD be using the kmod-mvidia.rpm from the rpmfusion repo

if you are NOT going to use the default installed Nouveau driver

see the fedora nvidia install guide i posted in the last link

this link
http://www.forums.fedoraforum.org/sh...d.php?t=280750

use the kmod or akmod-nvidia and NOT the NVIDIA.run
 
Old 05-26-2015, 04:59 PM   #6
tnandy
Member
 
Registered: Oct 2003
Location: Tennessee
Distribution: Fedora 22, CentOS
Posts: 169

Original Poster
Rep: Reputation: 15
Solved!!!

As I suspected from the beginning, the problem was the nVidia graphics driver was not being loaded. What I did in previous versions of linux was change the runlevel to 3 in /etc/inittab before running the nVidia device driver install script. This was simple, easy, and I could do it with gedit from a terminal. Note this does not apply to Fedora 21 (and perhaps earlier versions as well). Once I rebooted, I got a text login screen. I logged in as root, ran the nVidia device driver install, then changed the runlevel back to 5 using vi. Unfortunately, changing the runlevel in /etc/inittab no longer works.

I found the correct answer here.

The procedure that works now is:

Print these instructions out as a reference. You won't be able to view the linuxquestions.org web page using a graphical browser like firefox while you are on a text based window.

This also requires the kernel-devel package and the development tools. I got them by default when I installed Fedora 21. If you did not, you need to install them (and you can find out how to install software in other linuxquestions.org forums).

Download the proper graphics/video driver from nVidia.com. Store it in your user directory. For ease of use, I always rename the downloaded device driver file to "NVIDIA.run". Hereafter I will assume your username is "user1" and your computer name is "blah"; substitute accordingly.

Open a terminal window. FYI, DO NOT TYPE THE STUFF TO THE LEFT, UP TO AND INCLUDING THE POUNDSIGN ("#"). You only type the stuff to the right of the #.
Code:
[user1@blah]$ su -
Password:
[root@blah]# ln -fs /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
[root@blah]# reboot
Once your computer reboots, you will get a text screen login. Login as "root" and enter your root password. The only window in this runlevel IS a terminal, so....

Code:
[root@blah]# cd /home/user1
[root@blah]# sh ./NVIDIA.run
The nVidia driver installation script will ask a bunch of questions. I mostly answer "yes"/"accept"/"Sure, you do it" when prompted. Let the installation script finish. In order to get a GUI screen, enter:
Code:
[root@blah]# ln -fs /lib/systemd/system/graphical.target /etc/systemd/system/default.target
[root@blah]# reboot
You're done. If you subsequently update or upgrade kernel versions, you will have to do this again.
 
Old 05-26-2015, 10:53 PM   #7
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,832

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
There is no need to risk changing the links - targets can be passed to grub to override for just that one boot; systemd.unit=<whatever>.target
 
Old 07-02-2015, 09:45 AM   #8
tnandy
Member
 
Registered: Oct 2003
Location: Tennessee
Distribution: Fedora 22, CentOS
Posts: 169

Original Poster
Rep: Reputation: 15
Quote:
There is no need to risk changing the links - targets can be passed to grub to override for just that one boot; systemd.unit=<whatever>.target
That's interesting, but I don't know how to do that. Where and when, PRECISELY, do you enter the override? Please be as explicit as possible. Thanks.

In my case, this is a quadruple boot computer (Windblows XP, Windblows 7, Fedora 14 (last release with a decent gnome), Fedora 21 (now using mate)). Does that make any difference?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 12 `yum update -y` & ran out of space in my /var/yum/cache/directory. techknowtarded Linux - Newbie 7 08-13-2011 08:23 PM
[SOLVED] fedora 11 yum update kiran_y2 Fedora 4 04-13-2010 07:34 AM
Fedora 12 Yum hangs paleogryph Linux - Software 7 01-25-2010 05:47 PM
Initializing hardware hangs after "yum update kernel-smp.x86_64" jandersonlee Fedora - Installation 1 03-14-2006 10:39 PM
Fedora Hangs after Kernal Update b1gfunn Linux - Newbie 7 11-12-2004 02:00 PM


All times are GMT -5. The time now is 02:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration